summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbjarosze <bjarosze@users.noreply.github.com>2019-07-17 14:15:40 +0200
committerGitHub <noreply@github.com>2019-07-17 14:15:40 +0200
commit9986e428660d4aa8b22d94317282082bf844371d (patch)
tree9803b1564b918cd0009e435eda2003987ec644ea
parent355180f14ed94eef80aa10e716e01df2df2c084b (diff)
parent3604aefeb87a06f0bec880384492f7c18b5626bf (diff)
Merge pull request #9 from smcv/build-system
Add a build system for gschemas.compiled
-rw-r--r--.gitignore1
-rw-r--r--Makefile14
-rw-r--r--README.md19
-rw-r--r--schemas/gschemas.compiledbin476 -> 0 bytes
4 files changed, 34 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index a09c56d..e666a92 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
/.idea
+/schemas/gschemas.compiled
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b34acee
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+# Copyright 2019 Simon McVittie
+# SPDX-License-Identifier: GPL-2.0-or-later
+# (see extension.js for details)
+
+all:
+ glib-compile-schemas --strict --targetdir=schemas schemas
+
+dist: all
+ zip gnome-bluetooth-quick-connect.zip -9r *
+
+clean:
+ rm -fr gnome-bluetooth-quick-connect.zip schemas/gschemas.compiled
+
+.PHONY: all clean dist
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..5a6d8cb
--- /dev/null
+++ b/README.md
@@ -0,0 +1,19 @@
+# Bluetooth quick connect
+
+This extension allows paired Bluetooth devices to be connected and
+disconnected via the GNOME system menu, without having to enter the
+Settings app every time.
+
+## Installation from extensions.gnome.org
+
+https://extensions.gnome.org/extension/1401/bluetooth-quick-connect/
+
+## Installation from source code
+
+```
+git clone https://github.com/bjarosze/gnome-bluetooth-quick-connect
+cd gnome-bluetooth-quick-connect
+make
+rm -r ~/.local/share/gnome-shell/extensions/bluetooth-quick-connect@bjarosze.gmail.com
+cp -r gnome-bluetooth-quick-connect ~/.local/share/gnome-shell/extensions/bluetooth-quick-connect@bjarosze.gmail.com
+```
diff --git a/schemas/gschemas.compiled b/schemas/gschemas.compiled
deleted file mode 100644
index 85560bc..0000000
--- a/schemas/gschemas.compiled
+++ /dev/null
Binary files differ