summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2019-02-25 15:16:09 +0000
committerSimon McVittie <smcv@debian.org>2019-07-21 14:55:34 +0100
commit9adce5f77748a3afba0d11cbac094de2481d5ca8 (patch)
treeef3dd52272aba355f88936384860b2db415de6ee
parent0c3a1209f27f87031edbdd59f10a7fb767ef7ab4 (diff)
Add a build system for gschemas.compiled
Instead of including it in the git repository, build it from its source code (the XML) as needed. Forwarded: https://github.com/bjarosze/gnome-bluetooth-quick-connect/pull/9 Applied-upstream: upstream, 9, commit:3604aefeb87a06f0bec880384492f7c18b5626bf Gbp-Pq: Name Add-a-build-system-for-gschemas.compiled.patch
-rw-r--r--.gitignore1
-rw-r--r--Makefile14
2 files changed, 15 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index a09c56d..e666a92 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
/.idea
+/schemas/gschemas.compiled
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b34acee
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+# Copyright 2019 Simon McVittie
+# SPDX-License-Identifier: GPL-2.0-or-later
+# (see extension.js for details)
+
+all:
+ glib-compile-schemas --strict --targetdir=schemas schemas
+
+dist: all
+ zip gnome-bluetooth-quick-connect.zip -9r *
+
+clean:
+ rm -fr gnome-bluetooth-quick-connect.zip schemas/gschemas.compiled
+
+.PHONY: all clean dist