summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2019-08-01 22:15:07 +0100
committerSimon McVittie <smcv@debian.org>2019-08-01 22:15:07 +0100
commitad62a94bdb6437f20a94a9e7e8a86d484182a407 (patch)
tree881e04f08aacd886cc3c7d9d732a3537d5b139bc
parentc25d8c9334f1a4f10f09a432179ad1a18fe4346a (diff)
parente6e04e3678159084282fda2a9324e3aa601ae087 (diff)
Update upstream source from tag 'upstream/10'
Update to upstream version '10' with Debian dir 8c678d49b648f688c3d274f4b3d2c31fc3706c25
-rw-r--r--.gitignore1
-rw-r--r--Makefile14
-rw-r--r--README.md19
-rw-r--r--extension.js7
-rw-r--r--schemas/gschemas.compiledbin476 -> 0 bytes
5 files changed, 38 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index a09c56d..e666a92 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
/.idea
+/schemas/gschemas.compiled
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b34acee
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+# Copyright 2019 Simon McVittie
+# SPDX-License-Identifier: GPL-2.0-or-later
+# (see extension.js for details)
+
+all:
+ glib-compile-schemas --strict --targetdir=schemas schemas
+
+dist: all
+ zip gnome-bluetooth-quick-connect.zip -9r *
+
+clean:
+ rm -fr gnome-bluetooth-quick-connect.zip schemas/gschemas.compiled
+
+.PHONY: all clean dist
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..5a6d8cb
--- /dev/null
+++ b/README.md
@@ -0,0 +1,19 @@
+# Bluetooth quick connect
+
+This extension allows paired Bluetooth devices to be connected and
+disconnected via the GNOME system menu, without having to enter the
+Settings app every time.
+
+## Installation from extensions.gnome.org
+
+https://extensions.gnome.org/extension/1401/bluetooth-quick-connect/
+
+## Installation from source code
+
+```
+git clone https://github.com/bjarosze/gnome-bluetooth-quick-connect
+cd gnome-bluetooth-quick-connect
+make
+rm -r ~/.local/share/gnome-shell/extensions/bluetooth-quick-connect@bjarosze.gmail.com
+cp -r gnome-bluetooth-quick-connect ~/.local/share/gnome-shell/extensions/bluetooth-quick-connect@bjarosze.gmail.com
+```
diff --git a/extension.js b/extension.js
index 0a9b9d2..403d956 100644
--- a/extension.js
+++ b/extension.js
@@ -95,14 +95,15 @@ class BluetoothQuickConnect {
if (isOpen && this._autoPowerOnEnabled())
this._proxy.BluetoothAirplaneMode = false;
});
-
+
this._connectSignal(this._model, 'row-changed', () => this._sync());
this._connectSignal(this._model, 'row-deleted', () => this._sync());
this._connectSignal(this._model, 'row-inserted', () => this._sync());
- this._proxy.BluetoothAirplaneMode = false;
this._idleMonitor();
- this._sync();
+ if (!this._proxy.BluetoothAirplaneMode) {
+ this._sync();
+ }
}
disable() {
diff --git a/schemas/gschemas.compiled b/schemas/gschemas.compiled
deleted file mode 100644
index 85560bc..0000000
--- a/schemas/gschemas.compiled
+++ /dev/null
Binary files differ