summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/control4
-rw-r--r--debian/salsa-ci.yml3
-rw-r--r--extension.js9
-rw-r--r--metadata.json3
5 files changed, 21 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index e8ef66a..dac5fb3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+gnome-shell-extension-bluetooth-quick-connect (0~git20190701-1) unstable; urgency=medium
+
+ * New upstream snapshot
+ - Declare support for GNOME Shell 3.32
+ * d/salsa-ci.yml: Request standard CI on salsa.debian.org
+ * Standards-Version: 4.4.0 (no changes required)
+
+ -- Simon McVittie <smcv@debian.org> Mon, 15 Jul 2019 08:26:21 +0100
+
gnome-shell-extension-bluetooth-quick-connect (0~git20190225-1) unstable; urgency=medium
* Initial release (Closes: #923267)
diff --git a/debian/control b/debian/control
index 623a7b1..537c312 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Build-Depends:
debhelper-compat (= 12),
gettext,
libglib2.0-bin,
-Standards-Version: 4.3.0
+Standards-Version: 4.4.0
Homepage: https://github.com/bjarosze/gnome-bluetooth-quick-connect
Vcs-Git: https://salsa.debian.org/gnome-team/shell-extensions/gnome-shell-extension-bluetooth-quick-connect.git
Vcs-Browser: https://salsa.debian.org/gnome-team/shell-extensions/gnome-shell-extension-bluetooth-quick-connect
@@ -16,7 +16,7 @@ Rules-Requires-Root: no
Package: gnome-shell-extension-bluetooth-quick-connect
Architecture: all
Depends:
- gnome-shell (<< 3.31),
+ gnome-shell (<< 3.33),
gnome-shell (>= 3.28),
${misc:Depends},
Recommends:
diff --git a/debian/salsa-ci.yml b/debian/salsa-ci.yml
new file mode 100644
index 0000000..0c22dc4
--- /dev/null
+++ b/debian/salsa-ci.yml
@@ -0,0 +1,3 @@
+include:
+ - https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/salsa-ci.yml
+ - https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/pipeline-jobs.yml
diff --git a/extension.js b/extension.js
index 718c92d..403d956 100644
--- a/extension.js
+++ b/extension.js
@@ -76,7 +76,7 @@ class BluetoothDevice {
_call_bluetoothctl(command) {
let btctl_command = `echo -e "${command}\\n" | bluetoothctl`;
- Util.spawn(['/bin/bash', '-c', btctl_command]);
+ Util.spawn(['/usr/bin/env', 'bash', '-c', btctl_command]);
}
}
@@ -95,14 +95,15 @@ class BluetoothQuickConnect {
if (isOpen && this._autoPowerOnEnabled())
this._proxy.BluetoothAirplaneMode = false;
});
-
+
this._connectSignal(this._model, 'row-changed', () => this._sync());
this._connectSignal(this._model, 'row-deleted', () => this._sync());
this._connectSignal(this._model, 'row-inserted', () => this._sync());
- this._proxy.BluetoothAirplaneMode = false;
this._idleMonitor();
- this._sync();
+ if (!this._proxy.BluetoothAirplaneMode) {
+ this._sync();
+ }
}
disable() {
diff --git a/metadata.json b/metadata.json
index 4508c6b..dea519a 100644
--- a/metadata.json
+++ b/metadata.json
@@ -8,6 +8,7 @@
"shell-version": [
"3.26.2",
"3.28",
- "3.30"
+ "3.30",
+ "3.32"
]
}