summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/Integrate-with-Quick-Settings-menu-in-GNOME-43.patch4
-rw-r--r--extension.js2
3 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e7cce27..7c01bef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+gnome-shell-extension-bluetooth-quick-connect (29-3) unstable; urgency=medium
+
+ * Fix "this._proxy is undefined" error with some configuration options.
+ Thanks to frosth555 on Github
+
+ -- Simon McVittie <smcv@debian.org> Sat, 24 Sep 2022 20:35:20 +0100
+
gnome-shell-extension-bluetooth-quick-connect (29-2) unstable; urgency=medium
* Add proposed patch to integrate with GNOME Shell 43 (Closes: #1018186)
diff --git a/debian/patches/Integrate-with-Quick-Settings-menu-in-GNOME-43.patch b/debian/patches/Integrate-with-Quick-Settings-menu-in-GNOME-43.patch
index effd76e..8beab03 100644
--- a/debian/patches/Integrate-with-Quick-Settings-menu-in-GNOME-43.patch
+++ b/debian/patches/Integrate-with-Quick-Settings-menu-in-GNOME-43.patch
@@ -14,7 +14,7 @@ Forwarded: https://github.com/bjarosze/gnome-bluetooth-quick-connect/pull/66
create mode 100644 quickSettings.js
diff --git a/extension.js b/extension.js
-index b3c7167..5cd5331 100644
+index b3c7167..fc90e89 100644
--- a/extension.js
+++ b/extension.js
@@ -31,11 +31,24 @@ const BatteryProvider = Me.imports.power.UPowerBatteryProvider;
@@ -36,7 +36,7 @@ index b3c7167..5cd5331 100644
+ quickSettings.menu.addItem(newItem);
+ quickSettings.menu._grid.set_child_below_sibling(newItem, oldItem);
+ quickSettings.menu._grid.remove_child(oldItem);
-+ this._proxy = oldItem._proxy;
++ this._proxy = oldItem._client._proxy;
+ this._menu = newItem.menu;
+ } else {
+ this._menu = bluetooth._item.menu;
diff --git a/extension.js b/extension.js
index 5cd5331..fc90e89 100644
--- a/extension.js
+++ b/extension.js
@@ -43,7 +43,7 @@ class BluetoothQuickConnect {
quickSettings.menu.addItem(newItem);
quickSettings.menu._grid.set_child_below_sibling(newItem, oldItem);
quickSettings.menu._grid.remove_child(oldItem);
- this._proxy = oldItem._proxy;
+ this._proxy = oldItem._client._proxy;
this._menu = newItem.menu;
} else {
this._menu = bluetooth._item.menu;