summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rw-r--r--debian/gbp.conf14
-rw-r--r--debian/patches/Add-a-build-system-for-gschemas.compiled.patch3
-rw-r--r--debian/patches/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch33
-rw-r--r--debian/patches/series1
-rw-r--r--debian/watch7
6 files changed, 65 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index dac5fb3..a1f6815 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+gnome-shell-extension-bluetooth-quick-connect (8-1) unstable; urgency=medium
+
+ * Use an upstream release now that they are tagged
+ - d/p/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch:
+ Apply a patch that was in 0~git20190701 but not yet included in the
+ latest upstream release
+ * d/p/Add-a-build-system-for-gschemas.compiled.patch:
+ Mark as applied upstream
+ * d/watch: Only look for releases
+ * d/gbp.conf: Use GNOME team settings
+
+ -- Simon McVittie <smcv@debian.org> Sun, 21 Jul 2019 14:55:34 +0100
+
gnome-shell-extension-bluetooth-quick-connect (0~git20190701-1) unstable; urgency=medium
* New upstream snapshot
diff --git a/debian/gbp.conf b/debian/gbp.conf
index d0e67b7..1d4b985 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -1,5 +1,17 @@
[DEFAULT]
-patch-numbers = False
pristine-tar = True
debian-branch = debian/master
upstream-branch = upstream/latest
+upstream-vcs-tag = v%(version)s
+
+[buildpackage]
+sign-tags = True
+
+[dch]
+multimaint-merge = True
+
+[import-orig]
+postimport = dch -v%(version)s New upstream release; git add debian/changelog; debcommit
+
+[pq]
+patch-numbers = False
diff --git a/debian/patches/Add-a-build-system-for-gschemas.compiled.patch b/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
index 9df15d1..c216787 100644
--- a/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
+++ b/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
@@ -4,6 +4,9 @@ Subject: Add a build system for gschemas.compiled
Instead of including it in the git repository, build it from its source
code (the XML) as needed.
+
+Forwarded: https://github.com/bjarosze/gnome-bluetooth-quick-connect/pull/9
+Applied-upstream: upstream, 9, commit:3604aefeb87a06f0bec880384492f7c18b5626bf
---
.gitignore | 1 +
Makefile | 14 ++++++++++++++
diff --git a/debian/patches/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch b/debian/patches/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch
new file mode 100644
index 0000000..b04f412
--- /dev/null
+++ b/debian/patches/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch
@@ -0,0 +1,33 @@
+From: Andrei Tatar <6143482+andreittr@users.noreply.github.com>
+Date: Sat, 15 Jun 2019 14:12:02 +0200
+Subject: Do not force-enable BT on extension enable & only do sync if BT on
+
+Forwarded: https://github.com/bjarosze/gnome-bluetooth-quick-connect/pull/8
+Applied-upstream: upstream, 9, commit:9d28614c75e76805b808d4b93d77c8dc37bec066
+---
+ extension.js | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/extension.js b/extension.js
+index 0a9b9d2..403d956 100644
+--- a/extension.js
++++ b/extension.js
+@@ -95,14 +95,15 @@ class BluetoothQuickConnect {
+ if (isOpen && this._autoPowerOnEnabled())
+ this._proxy.BluetoothAirplaneMode = false;
+ });
+-
++
+ this._connectSignal(this._model, 'row-changed', () => this._sync());
+ this._connectSignal(this._model, 'row-deleted', () => this._sync());
+ this._connectSignal(this._model, 'row-inserted', () => this._sync());
+
+- this._proxy.BluetoothAirplaneMode = false;
+ this._idleMonitor();
+- this._sync();
++ if (!this._proxy.BluetoothAirplaneMode) {
++ this._sync();
++ }
+ }
+
+ disable() {
diff --git a/debian/patches/series b/debian/patches/series
index 649c386..d95eed9 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
+Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch
Add-a-build-system-for-gschemas.compiled.patch
diff --git a/debian/watch b/debian/watch
index 126a878..f64ea64 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,6 +1,3 @@
version=4
-opts="mode=git,dversionmangle=s/[~+](dfsg|ds)[0-9]*$//,compression=xz,repacksuffix=~dfsg,pretty=0~git%cd" \
-https://github.com/bjarosze/gnome-bluetooth-quick-connect \
-HEAD \
-debian \
-uupdate
+opts=filenamemangle=s/.+\/v?@ANY_VERSION@(@ARCHIVE_EXT@)/@PACKAGE@-$1$2/,dversionmangle=s/\+git[0-9.]+$// \
+https://github.com/bjarosze/gnome-bluetooth-quick-connect/tags .*/archive/v?@ANY_VERSION@@ARCHIVE_EXT@