summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-x.extract.sh2
-rw-r--r--Makefile3
-rw-r--r--Settings.ui543
-rw-r--r--debian/changelog16
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/watch2
-rw-r--r--metadata.json5
-rw-r--r--prefs.js15
-rw-r--r--settings.js6
-rw-r--r--ui.js3
-rw-r--r--utils.js6
12 files changed, 310 insertions, 300 deletions
diff --git a/.extract.sh b/.extract.sh
index a4578fe..b26f890 100755
--- a/.extract.sh
+++ b/.extract.sh
@@ -14,7 +14,7 @@ fi
mkdir -p "$dir"
cd "$dir"
-GS=/usr/lib/gnome-shell/libgnome-shell.so
+GS=/usr/lib64/gnome-shell/libgnome-shell.so
for r in $(gresource list $GS); do
t="${r/#\/org\/gnome\/shell\/}"
diff --git a/Makefile b/Makefile
index b34acee..23f71a0 100644
--- a/Makefile
+++ b/Makefile
@@ -11,4 +11,7 @@ dist: all
clean:
rm -fr gnome-bluetooth-quick-connect.zip schemas/gschemas.compiled
+install: dist
+ gnome-extensions install --force gnome-bluetooth-quick-connect.zip
+
.PHONY: all clean dist
diff --git a/Settings.ui b/Settings.ui
index d8acbe8..cd9a5a5 100644
--- a/Settings.ui
+++ b/Settings.ui
@@ -1,79 +1,69 @@
<?xml version="1.0" encoding="UTF-8"?>
+<!-- Generated with glade 3.38.2 -->
<!--
Copyright 2018 Bartosz Jaroszewski
SPDX-License-Identifier: GPL-2.0-or-later
(see extension.js for details)
-->
-<!-- Generated with glade 3.20.0 -->
<interface>
- <requires lib="gtk+" version="3.12"/>
+ <requires lib="gtk+" version="3.12" />
<object class="GtkAdjustment" id="auto_power_off_interval_adjustment">
<property name="lower">1</property>
<property name="upper">3600</property>
- <property name="step_increment">1</property>
- <property name="page_increment">5</property>
+ <property name="step-increment">1</property>
+ <property name="page-increment">5</property>
</object>
<object class="GtkBox" id="auto_power_off_settings">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="margin_left">24</property>
- <property name="margin_right">24</property>
- <property name="margin_top">24</property>
- <property name="margin_bottom">24</property>
+ <property name="can-focus">False</property>
+ <property name="margin-start">24</property>
+ <property name="margin-end">24</property>
+ <property name="margin-top">24</property>
+ <property name="margin-bottom">24</property>
<property name="orientation">vertical</property>
<property name="spacing">24</property>
<child>
<object class="GtkFrame">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="label_xalign">0</property>
- <property name="shadow_type">none</property>
+ <property name="can-focus">False</property>
+ <property name="label-xalign">0</property>
<child>
<object class="GtkListBox">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="selection_mode">none</property>
+ <property name="can-focus">False</property>
+ <property name="selection-mode">none</property>
<child>
<object class="GtkListBoxRow">
<property name="visible">True</property>
- <property name="can_focus">True</property>
+ <property name="can-focus">True</property>
<child>
- <object class="GtkGrid">
+ <object class="GtkBox">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="margin_left">12</property>
- <property name="margin_right">12</property>
- <property name="margin_top">12</property>
- <property name="margin_bottom">12</property>
- <property name="column_spacing">32</property>
+ <property name="can-focus">False</property>
+ <property name="margin-start">12</property>
+ <property name="margin-end">12</property>
+ <property name="margin-top">12</property>
+ <property name="margin-bottom">12</property>
<child>
<object class="GtkLabel">
<property name="visible">True</property>
- <property name="can_focus">False</property>
+ <property name="can-focus">False</property>
<property name="label" translatable="yes">Checking idle inteval (seconds)</property>
- <property name="xalign">0</property>
</object>
- <packing>
- <property name="left_attach">0</property>
- <property name="top_attach">0</property>
- </packing>
</child>
<child>
<object class="GtkSpinButton" id="auto_power_off_interval">
<property name="visible">True</property>
- <property name="can_focus">True</property>
+ <property name="can-focus">True</property>
<property name="halign">end</property>
<property name="hexpand">True</property>
<property name="text">60</property>
<property name="adjustment">auto_power_off_interval_adjustment</property>
- <property name="climb_rate">1</property>
- <property name="snap_to_ticks">True</property>
+ <property name="climb-rate">1</property>
+ <property name="snap-to-ticks">True</property>
<property name="numeric">True</property>
</object>
- <packing>
- <property name="left_attach">1</property>
- <property name="top_attach">0</property>
- </packing>
+
</child>
</object>
</child>
@@ -82,293 +72,294 @@ SPDX-License-Identifier: GPL-2.0-or-later
</object>
</child>
</object>
- <packing>
- <property name="expand">False</property>
- <property name="fill">True</property>
- <property name="position">0</property>
- </packing>
</child>
</object>
- <object class="GtkBox" id="bluetooth_quick_connect_settings">
+ <object class="GtkScrolledWindow" id="items_container">
+ <!-- <property name="width-request">450</property> -->
+ <!-- <property name="height-request">692</property> -->
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="margin_left">24</property>
- <property name="margin_right">24</property>
- <property name="margin_top">24</property>
- <property name="margin_bottom">24</property>
- <property name="orientation">vertical</property>
- <property name="spacing">24</property>
+ <property name="can-focus">True</property>
+ <property name="vexpand">True</property>
+ <property name="hscrollbar-policy">never</property>
<child>
- <object class="GtkFrame">
+ <object class="GtkViewport" id="main_prefs_vp">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="label_xalign">0</property>
- <property name="shadow_type">in</property>
+ <property name="can-focus">False</property>
<child>
- <object class="GtkListBox">
+ <object class="GtkBox" id="bluetooth_quick_connect_settings">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="selection_mode">none</property>
- <child>
- <object class="GtkListBoxRow">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <child>
- <object class="GtkGrid">
- <property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="margin_left">12</property>
- <property name="margin_right">12</property>
- <property name="margin_top">12</property>
- <property name="margin_bottom">12</property>
- <property name="column_spacing">32</property>
- <child>
- <object class="GtkSwitch" id="auto_power_on_switch">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="halign">end</property>
- <property name="valign">center</property>
- </object>
- <packing>
- <property name="left_attach">1</property>
- <property name="top_attach">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkLabel" id="auto_power_on_label">
- <property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="hexpand">True</property>
- <property name="label" translatable="yes">Enable bluetooth when menu opened</property>
- <property name="xalign">0</property>
- </object>
- <packing>
- <property name="left_attach">0</property>
- <property name="top_attach">0</property>
- </packing>
- </child>
- </object>
- </child>
- </object>
- </child>
+ <property name="can-focus">False</property>
+ <property name="margin-start">24</property>
+ <property name="margin-end">24</property>
+ <property name="margin-top">24</property>
+ <property name="margin-bottom">24</property>
+ <property name="orientation">vertical</property>
+ <property name="spacing">24</property>
<child>
- <object class="GtkListBoxRow">
- <property name="width_request">100</property>
+ <object class="GtkFrame">
<property name="visible">True</property>
- <property name="can_focus">True</property>
+ <property name="can-focus">False</property>
+ <property name="label-xalign">0</property>
<child>
- <object class="GtkGrid">
+ <object class="GtkListBox">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="margin_left">12</property>
- <property name="margin_right">12</property>
- <property name="margin_top">12</property>
- <property name="margin_bottom">12</property>
- <property name="column_spacing">32</property>
+ <property name="can-focus">False</property>
+ <property name="selection-mode">none</property>
<child>
- <object class="GtkLabel" id="auto_power_off_label">
+ <object class="GtkListBoxRow">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="hexpand">True</property>
- <property name="label" translatable="yes">Disable bluetooth if idle</property>
- <property name="use_markup">True</property>
- <property name="xalign">0</property>
- </object>
- <packing>
- <property name="left_attach">0</property>
- <property name="top_attach">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkBox">
- <property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="spacing">6</property>
+ <property name="can-focus">True</property>
<child>
- <object class="GtkButton" id="auto_power_off_settings_button">
+ <!-- n-columns=2 n-rows=1 -->
+ <object class="GtkGrid">
<property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="receives_default">True</property>
- <property name="halign">center</property>
- <property name="valign">center</property>
- <property name="xalign">0.46000000834465027</property>
+ <property name="can-focus">False</property>
+ <property name="margin-start">12</property>
+ <property name="margin-end">12</property>
+ <property name="margin-top">12</property>
+ <property name="margin-bottom">12</property>
+ <property name="column-spacing">32</property>
<child>
- <object class="GtkImage" id="image_window_previews_options2">
+ <object class="GtkSwitch" id="auto_power_on_switch">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="icon_name">emblem-system-symbolic</property>
+ <property name="can-focus">True</property>
+ <property name="halign">end</property>
+ <property name="valign">center</property>
+ <layout>
+ <property name="column">1</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ <child>
+ <object class="GtkLabel" id="auto_power_on_label">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="halign">start</property>
+ <property name="hexpand">True</property>
+ <property name="label" translatable="yes">Enable bluetooth when menu opened</property>
+ <layout>
+ <property name="column">0</property>
+ <property name="row">0</property>
+ </layout>
</object>
</child>
- <style>
- <class name="circular"/>
- </style>
- </object>
- <packing>
- <property name="expand">False</property>
- <property name="fill">True</property>
- <property name="position">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkSwitch" id="auto_power_off_switch">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="halign">end</property>
- <property name="valign">center</property>
</object>
- <packing>
- <property name="expand">False</property>
- <property name="fill">True</property>
- <property name="position">1</property>
- </packing>
</child>
</object>
- <packing>
- <property name="left_attach">1</property>
- <property name="top_attach">0</property>
- </packing>
</child>
- </object>
- </child>
- </object>
- </child>
- <child>
- <object class="GtkListBoxRow">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <child>
- <object class="GtkGrid">
- <property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="margin_left">12</property>
- <property name="margin_right">12</property>
- <property name="margin_top">12</property>
- <property name="margin_bottom">12</property>
- <property name="column_spacing">32</property>
<child>
- <object class="GtkSwitch" id="keep_menu_on_toggle">
+ <object class="GtkListBoxRow">
+ <property name="width-request">100</property>
<property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="halign">end</property>
- <property name="valign">center</property>
+ <property name="can-focus">True</property>
+ <child>
+ <!-- n-columns=2 n-rows=1 -->
+ <object class="GtkGrid">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="margin-start">12</property>
+ <property name="margin-end">12</property>
+ <property name="margin-top">12</property>
+ <property name="margin-bottom">12</property>
+ <property name="column-spacing">32</property>
+ <child>
+ <object class="GtkLabel" id="auto_power_off_label">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="halign">start</property>
+ <property name="hexpand">True</property>
+ <property name="label" translatable="yes">Disable bluetooth if idle</property>
+ <property name="use-markup">True</property>
+ <layout>
+ <property name="column">0</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ <child>
+ <object class="GtkBox">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="spacing">6</property>
+ <child>
+ <object class="GtkButton" id="auto_power_off_settings_button">
+ <property name="visible">True</property>
+ <property name="can-focus">True</property>
+ <property name="receives-default">True</property>
+ <property name="valign">center</property>
+ <child>
+ <object class="GtkImage" id="image_window_previews_options2">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="icon-name">emblem-system-symbolic</property>
+ </object>
+ </child>
+ <style>
+ <class name="circular" />
+ </style>
+ </object>
+
+ </child>
+ <child>
+ <object class="GtkSwitch" id="auto_power_off_switch">
+ <property name="visible">True</property>
+ <property name="can-focus">True</property>
+ <property name="halign">end</property>
+ <property name="valign">center</property>
+ </object>
+
+ </child>
+ <layout>
+ <property name="column">1</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ </object>
+ </child>
</object>
- <packing>
- <property name="left_attach">1</property>
- <property name="top_attach">0</property>
- </packing>
</child>
<child>
- <object class="GtkLabel" id="keep_menu_on_toggle_label">
+ <object class="GtkListBoxRow">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="hexpand">True</property>
- <property name="label" translatable="yes">Keep the menu open after toggling the connection (restart required)</property>
- <property name="xalign">0</property>
+ <property name="can-focus">True</property>
+ <child>
+ <!-- n-columns=2 n-rows=1 -->
+ <object class="GtkGrid">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="margin-start">12</property>
+ <property name="margin-end">12</property>
+ <property name="margin-top">12</property>
+ <property name="margin-bottom">12</property>
+ <property name="column-spacing">32</property>
+ <child>
+ <object class="GtkSwitch" id="keep_menu_on_toggle">
+ <property name="visible">True</property>
+ <property name="can-focus">True</property>
+ <property name="halign">end</property>
+ <property name="valign">center</property>
+ <layout>
+ <property name="column">1</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ <child>
+ <object class="GtkLabel" id="keep_menu_on_toggle_label">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="halign">start</property>
+ <property name="hexpand">True</property>
+ <property name="label" translatable="yes">Keep the menu open after toggling the connection (restart required)</property>
+ <layout>
+ <property name="column">0</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ </object>
+ </child>
</object>
- <packing>
- <property name="left_attach">0</property>
- <property name="top_attach">0</property>
- </packing>
</child>
- </object>
- </child>
- </object>
- </child>
- <child>
- <object class="GtkListBoxRow">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <child>
- <object class="GtkGrid">
- <property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="margin_left">12</property>
- <property name="margin_right">12</property>
- <property name="margin_top">12</property>
- <property name="margin_bottom">12</property>
- <property name="column_spacing">32</property>
<child>
- <object class="GtkSwitch" id="refresh_button_on">
+ <object class="GtkListBoxRow">
<property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="halign">end</property>
- <property name="valign">center</property>
+ <property name="can-focus">True</property>
+ <child>
+ <!-- n-columns=2 n-rows=1 -->
+ <object class="GtkGrid">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="margin-start">12</property>
+ <property name="margin-end">12</property>
+ <property name="margin-top">12</property>
+ <property name="margin-bottom">12</property>
+ <property name="column-spacing">32</property>
+ <child>
+ <object class="GtkSwitch" id="refresh_button_on">
+ <property name="visible">True</property>
+ <property name="can-focus">True</property>
+ <property name="halign">end</property>
+ <property name="valign">center</property>
+ <layout>
+ <property name="column">1</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ <child>
+ <object class="GtkLabel" id="refresh_button_on_label">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="halign">start</property>
+ <property name="hexpand">True</property>
+ <property name="label" translatable="yes">Show reconnect button (restart required)</property>
+ <layout>
+ <property name="column">0</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ </object>
+ </child>
</object>
- <packing>
- <property name="left_attach">1</property>
- <property name="top_attach">0</property>
- </packing>
</child>
<child>
- <object class="GtkLabel" id="refresh_button_on_label">
+ <object class="GtkListBoxRow">
<property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="hexpand">True</property>
- <property name="label" translatable="yes">Show reconnect button (restart required)</property>
- <property name="xalign">0</property>
+ <property name="can-focus">True</property>
+ <child>
+ <!-- n-columns=2 n-rows=1 -->
+ <object class="GtkGrid">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="margin-start">12</property>
+ <property name="margin-end">12</property>
+ <property name="margin-top">12</property>
+ <property name="margin-bottom">12</property>
+ <property name="column-spacing">32</property>
+ <child>
+ <object class="GtkSwitch" id="debug_mode_on">
+ <property name="visible">True</property>
+ <property name="can-focus">True</property>
+ <property name="halign">end</property>
+ <property name="valign">center</property>
+ <layout>
+ <property name="column">1</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ <child>
+ <object class="GtkLabel" id="debug_mode_on_label">
+ <property name="visible">True</property>
+ <property name="can-focus">False</property>
+ <property name="halign">start</property>
+ <property name="hexpand">True</property>
+ <property name="label" translatable="yes">Debug mode (restart required)</property>
+ <layout>
+ <property name="column">0</property>
+ <property name="row">0</property>
+ </layout>
+ </object>
+ </child>
+ </object>
+ </child>
</object>
- <packing>
- <property name="left_attach">0</property>
- <property name="top_attach">0</property>
- </packing>
</child>
</object>
</child>
- </object>
- </child>
- <child>
- <object class="GtkListBoxRow">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <child>
- <object class="GtkGrid">
- <property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="margin_left">12</property>
- <property name="margin_right">12</property>
- <property name="margin_top">12</property>
- <property name="margin_bottom">12</property>
- <property name="column_spacing">32</property>
- <child>
- <object class="GtkSwitch" id="debug_mode_on">
- <property name="visible">True</property>
- <property name="can_focus">True</property>
- <property name="halign">end</property>
- <property name="valign">center</property>
- </object>
- <packing>
- <property name="left_attach">1</property>
- <property name="top_attach">0</property>
- </packing>
- </child>
- <child>
- <object class="GtkLabel" id="debug_mode_on_label">
- <property name="visible">True</property>
- <property name="can_focus">False</property>
- <property name="hexpand">True</property>
- <property name="label" translatable="yes">Debug mode (restart required)</property>
- <property name="xalign">0</property>
- </object>
- <packing>
- <property name="left_attach">0</property>
- <property name="top_attach">0</property>
- </packing>
- </child>
- </object>
+ <child type="label_item">
+ <placeholder />
</child>
</object>
+
</child>
</object>
</child>
- <child type="label_item">
- <placeholder/>
- </child>
</object>
- <packing>
- <property name="expand">False</property>
- <property name="fill">True</property>
- <property name="position">0</property>
- </packing>
</child>
</object>
-</interface>
+</interface> \ No newline at end of file
diff --git a/debian/changelog b/debian/changelog
index a4b3422..1308e52 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+gnome-shell-extension-bluetooth-quick-connect (20-2) unstable; urgency=medium
+
+ * Release to unstable
+
+ -- Simon McVittie <smcv@debian.org> Sat, 11 Sep 2021 22:15:35 +0100
+
+gnome-shell-extension-bluetooth-quick-connect (20-1) experimental; urgency=medium
+
+ * New upstream release for GNOME 40 (Closes: #993057)
+ * d/watch: Update for Github changes
+ * Use debhelper compat level 13
+ * Disable dh_auto_install.
+ It doesn't do the right thing for upstream's `make install`.
+
+ -- Simon McVittie <smcv@debian.org> Tue, 31 Aug 2021 10:33:02 +0100
+
gnome-shell-extension-bluetooth-quick-connect (16-1) unstable; urgency=medium
* New upstream release
diff --git a/debian/control b/debian/control
index b5e4ab6..3e02cd8 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Simon McVittie <smcv@debian.org>
Uploaders: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Build-Depends:
- debhelper-compat (= 12),
+ debhelper-compat (= 13),
gettext,
libglib2.0-bin,
Standards-Version: 4.5.0
@@ -16,8 +16,8 @@ Rules-Requires-Root: no
Package: gnome-shell-extension-bluetooth-quick-connect
Architecture: all
Depends:
- gnome-shell (<< 3.39),
- gnome-shell (>= 3.37),
+ gnome-shell (<< 41~),
+ gnome-shell (>= 40~),
${misc:Depends},
Recommends:
gnome-shell-extension-prefs,
diff --git a/debian/rules b/debian/rules
index 3c746ff..8cc332e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,3 +5,6 @@ include /usr/share/dpkg/default.mk
%:
dh $@
+
+override_dh_auto_install:
+ # Upstream's `make install` is not suitable for packaging
diff --git a/debian/watch b/debian/watch
index f64ea64..0382f1e 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,3 +1,3 @@
version=4
opts=filenamemangle=s/.+\/v?@ANY_VERSION@(@ARCHIVE_EXT@)/@PACKAGE@-$1$2/,dversionmangle=s/\+git[0-9.]+$// \
-https://github.com/bjarosze/gnome-bluetooth-quick-connect/tags .*/archive/v?@ANY_VERSION@@ARCHIVE_EXT@
+https://github.com/bjarosze/gnome-bluetooth-quick-connect/tags .*/archive/refs/tags/v?@ANY_VERSION@@ARCHIVE_EXT@
diff --git a/metadata.json b/metadata.json
index 925b6c8..0d814bc 100644
--- a/metadata.json
+++ b/metadata.json
@@ -6,6 +6,9 @@
"settings-schema": "org.gnome.shell.extensions.bluetooth-quick-connect",
"gettext-domain": "bluetooth-quick-connect",
"shell-version": [
- "3.38"
+ "40.1",
+ "40.0",
+ "40.beta",
+ "40.rc"
]
}
diff --git a/prefs.js b/prefs.js
index 62b4bec..acb3318 100644
--- a/prefs.js
+++ b/prefs.js
@@ -21,33 +21,27 @@ class SettingsBuilder {
build() {
this._builder.add_from_file(Me.path + '/Settings.ui');
- this._settingsBox = this._builder.get_object('bluetooth_quick_connect_settings');
-
-
- this._viewport = new Gtk.Viewport();
- this._viewport.add(this._settingsBox);
- this._widget = new Gtk.ScrolledWindow();
- this._widget.add(this._viewport);
+ this._widget = this._builder.get_object('items_container')
this._builder.get_object('auto_power_off_settings_button').connect('clicked', () => {
let dialog = new Gtk.Dialog({
title: 'Auto power off settings',
- transient_for: this._widget.get_toplevel(),
+ transient_for: this._widget.get_ancestor(Gtk.Window),
use_header_bar: true,
modal: true
});
let box = this._builder.get_object('auto_power_off_settings');
- dialog.get_content_area().add(box);
+ dialog.get_content_area().append(box);
dialog.connect('response', (dialog) => {
dialog.get_content_area().remove(box);
dialog.destroy();
});
- dialog.show_all();
+ dialog.show();
});
@@ -84,7 +78,6 @@ function init() {
function buildPrefsWidget() {
let settings = new SettingsBuilder();
let widget = settings.build();
- widget.show_all();
return widget;
}
diff --git a/settings.js b/settings.js
index e7040df..e9c5afb 100644
--- a/settings.js
+++ b/settings.js
@@ -18,7 +18,7 @@ const ExtensionUtils = imports.misc.extensionUtils;
const Gio = imports.gi.Gio;
const GioSSS = Gio.SettingsSchemaSource;
-class Settings {
+var Settings = class Settings {
constructor() {
this.settings = this._loadSettings();
}
@@ -59,6 +59,6 @@ class Settings {
let schemaObj = schemaSource.lookup(schema, true);
- return new Gio.Settings({settings_schema: schemaObj});
+ return new Gio.Settings({ settings_schema: schemaObj });
}
-} \ No newline at end of file
+}; \ No newline at end of file
diff --git a/ui.js b/ui.js
index ea3354b..23bf2f1 100644
--- a/ui.js
+++ b/ui.js
@@ -24,7 +24,8 @@ const Config = imports.misc.config;
var PopupBluetoothDeviceMenuItem = GObject.registerClass(
class PopupSwitchWithButtonMenuItem extends PopupMenu.PopupSwitchMenuItem {
_init(device, params) {
- super._init(device.name, device.isConnected, {});
+ let label = device.name || '(unknown)';
+ super._init(label, device.isConnected, {});
this._device = device;
this._showRefreshButton = params.showRefreshButton;
diff --git a/utils.js b/utils.js
index f6676e7..9bb550e 100644
--- a/utils.js
+++ b/utils.js
@@ -34,7 +34,7 @@ function isDebugModeEnabled() {
return new Settings().isDebugModeEnabled();
}
-class Logger {
+var Logger = class Logger {
constructor(settings) {
this._enabled = settings.isDebugModeEnabled();
}
@@ -42,9 +42,9 @@ class Logger {
info(message) {
if (!this._enabled) return;
- global.log(`[bluetooth-quick-connect] ${message}`);
+ log(`[bluetooth-quick-connect] ${message}`);
}
-}
+};
function addSignalsHelperMethods(prototype) {
prototype._connectSignal = function (subject, signal_name, method) {