summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/Add-a-build-system-for-gschemas.compiled.patch3
-rw-r--r--debian/patches/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch33
-rw-r--r--debian/patches/series1
4 files changed, 43 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a5628d5..eb00ef5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,13 @@
gnome-shell-extension-bluetooth-quick-connect (8-1) UNRELEASED; urgency=medium
+ * New upstream release
+ - d/p/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch:
+ Apply a patch that was in 0~git20190701 but not yet included in the
+ latest upstream release
+ * d/p/Add-a-build-system-for-gschemas.compiled.patch:
+ Mark as applied upstream
* d/watch: Only look for releases
* d/gbp.conf: Use GNOME team settings
- * New upstream release
-- Simon McVittie <smcv@debian.org> Sun, 21 Jul 2019 12:32:58 +0100
diff --git a/debian/patches/Add-a-build-system-for-gschemas.compiled.patch b/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
index 9df15d1..c216787 100644
--- a/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
+++ b/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
@@ -4,6 +4,9 @@ Subject: Add a build system for gschemas.compiled
Instead of including it in the git repository, build it from its source
code (the XML) as needed.
+
+Forwarded: https://github.com/bjarosze/gnome-bluetooth-quick-connect/pull/9
+Applied-upstream: upstream, 9, commit:3604aefeb87a06f0bec880384492f7c18b5626bf
---
.gitignore | 1 +
Makefile | 14 ++++++++++++++
diff --git a/debian/patches/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch b/debian/patches/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch
new file mode 100644
index 0000000..b04f412
--- /dev/null
+++ b/debian/patches/Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch
@@ -0,0 +1,33 @@
+From: Andrei Tatar <6143482+andreittr@users.noreply.github.com>
+Date: Sat, 15 Jun 2019 14:12:02 +0200
+Subject: Do not force-enable BT on extension enable & only do sync if BT on
+
+Forwarded: https://github.com/bjarosze/gnome-bluetooth-quick-connect/pull/8
+Applied-upstream: upstream, 9, commit:9d28614c75e76805b808d4b93d77c8dc37bec066
+---
+ extension.js | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/extension.js b/extension.js
+index 0a9b9d2..403d956 100644
+--- a/extension.js
++++ b/extension.js
+@@ -95,14 +95,15 @@ class BluetoothQuickConnect {
+ if (isOpen && this._autoPowerOnEnabled())
+ this._proxy.BluetoothAirplaneMode = false;
+ });
+-
++
+ this._connectSignal(this._model, 'row-changed', () => this._sync());
+ this._connectSignal(this._model, 'row-deleted', () => this._sync());
+ this._connectSignal(this._model, 'row-inserted', () => this._sync());
+
+- this._proxy.BluetoothAirplaneMode = false;
+ this._idleMonitor();
+- this._sync();
++ if (!this._proxy.BluetoothAirplaneMode) {
++ this._sync();
++ }
+ }
+
+ disable() {
diff --git a/debian/patches/series b/debian/patches/series
index 649c386..d95eed9 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
+Do-not-force-enable-BT-on-extension-enable-only-do-sync-i.patch
Add-a-build-system-for-gschemas.compiled.patch