summaryrefslogtreecommitdiff
path: root/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/Add-a-build-system-for-gschemas.compiled.patch')
-rw-r--r--debian/patches/Add-a-build-system-for-gschemas.compiled.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/debian/patches/Add-a-build-system-for-gschemas.compiled.patch b/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
new file mode 100644
index 0000000..9df15d1
--- /dev/null
+++ b/debian/patches/Add-a-build-system-for-gschemas.compiled.patch
@@ -0,0 +1,39 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Mon, 25 Feb 2019 15:16:09 +0000
+Subject: Add a build system for gschemas.compiled
+
+Instead of including it in the git repository, build it from its source
+code (the XML) as needed.
+---
+ .gitignore | 1 +
+ Makefile | 14 ++++++++++++++
+ 2 files changed, 15 insertions(+)
+ create mode 100644 Makefile
+
+diff --git a/.gitignore b/.gitignore
+index a09c56d..e666a92 100644
+--- a/.gitignore
++++ b/.gitignore
+@@ -1 +1,2 @@
+ /.idea
++/schemas/gschemas.compiled
+diff --git a/Makefile b/Makefile
+new file mode 100644
+index 0000000..b34acee
+--- /dev/null
++++ b/Makefile
+@@ -0,0 +1,14 @@
++# Copyright 2019 Simon McVittie
++# SPDX-License-Identifier: GPL-2.0-or-later
++# (see extension.js for details)
++
++all:
++ glib-compile-schemas --strict --targetdir=schemas schemas
++
++dist: all
++ zip gnome-bluetooth-quick-connect.zip -9r *
++
++clean:
++ rm -fr gnome-bluetooth-quick-connect.zip schemas/gschemas.compiled
++
++.PHONY: all clean dist