summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <rra@debian.org>2019-10-23 15:06:35 -0700
committerRuss Allbery <rra@debian.org>2019-10-23 15:06:35 -0700
commit13f52ec31899c42e1c5558e73034963823978c8a (patch)
treea22e2a95d4f25715c49ef3a9a232ccb0f451edec
parent32bf33cf758096dfc9ed79993edcd156db2471d7 (diff)
Build against Python 3 instead of Python 2
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules2
3 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d3274ed..bd89c47 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+gnubg (1.06.002-3) UNRELEASED; urgency=medium
+
+ * Build against Python 3 instead of Python 2. (Closes: #936627)
+
+ -- Russ Allbery <rra@debian.org> Wed, 23 Oct 2019 15:06:01 -0700
+
gnubg (1.06.002-2) unstable; urgency=medium
* Increase the size of static buffers used to build messages during
diff --git a/debian/control b/debian/control
index 61c7b8f..a552afc 100644
--- a/debian/control
+++ b/debian/control
@@ -21,7 +21,7 @@ Build-Depends:
libreadline-dev,
libsqlite3-dev,
lsb-release,
- python-dev,
+ python3-dev,
Build-Depends-Indep:
dblatex,
docbook-xsl,
diff --git a/debian/rules b/debian/rules
index 202ff21..0ed3f59 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,7 +47,7 @@ override_dh_autoreconf:
# reproducible builds.
override_dh_auto_configure:
dh_auto_configure -- --with-gtk --with-board3d --with-sqlite \
- --with-python --enable-threads $(SSE)
+ --with-python=/usr/bin/python3 --enable-threads $(SSE)
echo '#define BUILD_DATE $(BUILD_DATE)' >> config.h
# Disable building the rollout databases during an architecture-specific