summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2019-09-30 08:12:12 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2019-09-30 08:12:12 +0200
commitce99760f92e1ac82d24674cb8e87d4e885716b48 (patch)
treecabd9049fbbebd827abfc159b58175d53e19a131
parent7943b12fd14bf1dd1ef9c698ea66706042f884f8 (diff)
parent6383269341b770c3a320094cf06a35805c3ddbb7 (diff)
Update upstream source from tag 'upstream/0.4'
Update to upstream version '0.4' with Debian dir 470c65488419a6214cbeca805221e1e81058f224
-rw-r--r--CMakeLists.txt6
-rwxr-xr-xapps/sdr-zmq-daemon4
-rwxr-xr-xpython/app/receive_dabplus.py2
3 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8f79fdf..f9a26f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,10 +42,10 @@ set(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING "")
list(INSERT CMAKE_MODULE_PATH 0 ${CMAKE_SOURCE_DIR}/cmake/Modules)
# Set the version information here
-set(VERSION_MAJOR 1)
-set(VERSION_API 0)
+set(VERSION_MAJOR 3)
+set(VERSION_API 8)
set(VERSION_ABI 0)
-set(VERSION_PATCH git)
+#set(VERSION_PATCH git)
cmake_policy(SET CMP0011 NEW)
diff --git a/apps/sdr-zmq-daemon b/apps/sdr-zmq-daemon
index 16cad1c..6ddfc10 100755
--- a/apps/sdr-zmq-daemon
+++ b/apps/sdr-zmq-daemon
@@ -1,4 +1,4 @@
-#!/usr/bin/env python2
+#!/usr/bin/env python3
# -*- coding: utf-8 -*-
#
# Copyright 2018 by Ruben Undheim
@@ -99,7 +99,7 @@ def main(top_block_cls=top_block, options=None):
tb = top_block_cls()
tb.start()
try:
- raw_input('Press Enter to quit: ')
+ input('Press Enter to quit: ')
except EOFError:
pass
tb.stop()
diff --git a/python/app/receive_dabplus.py b/python/app/receive_dabplus.py
index 7ad031a..14fb441 100755
--- a/python/app/receive_dabplus.py
+++ b/python/app/receive_dabplus.py
@@ -89,7 +89,7 @@ def receive_dabplus(frequency=220.352e6, rf_gain=25, if_gain=0, bb_gain=0, ppm=8
fg.start()
- raw_input("Running..")
+ input("Running..")
#new = grdab.dabplus_audio_decoder_ff(grdab.parameters.dab_parameters(mode=1, sample_rate=samp_rate, verbose=False), 64, 304, 64, 1, True)
#newaudio = audio.sink(44100, '', True)
fg.stop()