summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xapps/sdr-zmq-daemon2
-rw-r--r--debian/changelog10
-rw-r--r--debian/control1
-rw-r--r--debian/patches/0001-Fix-library-version.patch26
-rw-r--r--debian/patches/0002-sdr-zmq-daemon-is-also-Python-3.patch18
-rw-r--r--debian/patches/series2
-rw-r--r--debian/watch1
-rwxr-xr-xpython/app/receive_dabplus.py2
8 files changed, 13 insertions, 49 deletions
diff --git a/apps/sdr-zmq-daemon b/apps/sdr-zmq-daemon
index 2ae1506..6ddfc10 100755
--- a/apps/sdr-zmq-daemon
+++ b/apps/sdr-zmq-daemon
@@ -99,7 +99,7 @@ def main(top_block_cls=top_block, options=None):
tb = top_block_cls()
tb.start()
try:
- raw_input('Press Enter to quit: ')
+ input('Press Enter to quit: ')
except EOFError:
pass
tb.stop()
diff --git a/debian/changelog b/debian/changelog
index a1e2e2a..6344619 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,15 @@
+gr-dab (0.4-1) unstable; urgency=medium
+
+ * New upstream release
+ * debian/control: Install-depend on python3-six
+ * debian/patches: Drop patches
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Tue, 15 Oct 2019 19:24:31 +0200
+
gr-dab (0.4~alpha-1) unstable; urgency=medium
* New upstream release
- - Builds with gnuradio 3.8 and Python 3 (Closes: #935822)
+ - Builds with gnuradio 3.8 and Python 3 (Closes: #935822, #936656)
* debian/control:
- libgnuradio-dab3.7.13 -> libgnuradio-dab3.8.0
- New standards version 4.4.0 - no changes
diff --git a/debian/control b/debian/control
index 675544f..9478a2d 100644
--- a/debian/control
+++ b/debian/control
@@ -29,6 +29,7 @@ Depends: libgnuradio-dab3.8.0 (= ${binary:Version}),
gnuradio,
python3,
python3-yaml,
+ python3-six,
gr-osmosdr
Description: Gnuradio blocks and tools for receiving DAB and DAB+ radio
Contains necessary DSP blocks for receiving DAB and DAB+ transmissions
diff --git a/debian/patches/0001-Fix-library-version.patch b/debian/patches/0001-Fix-library-version.patch
deleted file mode 100644
index c56c720..0000000
--- a/debian/patches/0001-Fix-library-version.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Ruben Undheim <ruben.undheim@gmail.com>
-Date: Sun, 29 Sep 2019 08:57:08 +0200
-Subject: Fix library version
-
----
- CMakeLists.txt | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8f79fdf..f9a26f4 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -42,10 +42,10 @@ set(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING "")
- list(INSERT CMAKE_MODULE_PATH 0 ${CMAKE_SOURCE_DIR}/cmake/Modules)
-
- # Set the version information here
--set(VERSION_MAJOR 1)
--set(VERSION_API 0)
-+set(VERSION_MAJOR 3)
-+set(VERSION_API 8)
- set(VERSION_ABI 0)
--set(VERSION_PATCH git)
-+#set(VERSION_PATCH git)
-
- cmake_policy(SET CMP0011 NEW)
-
diff --git a/debian/patches/0002-sdr-zmq-daemon-is-also-Python-3.patch b/debian/patches/0002-sdr-zmq-daemon-is-also-Python-3.patch
deleted file mode 100644
index 5c8fb16..0000000
--- a/debian/patches/0002-sdr-zmq-daemon-is-also-Python-3.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-From: Ruben Undheim <ruben.undheim@gmail.com>
-Date: Sun, 29 Sep 2019 10:17:16 +0000
-Subject: sdr-zmq-daemon is also Python 3
-
----
- apps/sdr-zmq-daemon | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/apps/sdr-zmq-daemon b/apps/sdr-zmq-daemon
-index 16cad1c..2ae1506 100755
---- a/apps/sdr-zmq-daemon
-+++ b/apps/sdr-zmq-daemon
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2
-+#!/usr/bin/env python3
- # -*- coding: utf-8 -*-
- #
- # Copyright 2018 by Ruben Undheim
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index e2cd4ee..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,2 +0,0 @@
-0001-Fix-library-version.patch
-0002-sdr-zmq-daemon-is-also-Python-3.patch
diff --git a/debian/watch b/debian/watch
index e70dce6..8b4946f 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,2 +1,3 @@
version=3
+opts=uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha)\d*)$/$1~$2/ \
https://github.com/andrmuel/gr-dab/releases /andrmuel/gr-dab/archive/(\d\S+)\.tar\.(?:bz2|gz|xz)
diff --git a/python/app/receive_dabplus.py b/python/app/receive_dabplus.py
index 7ad031a..14fb441 100755
--- a/python/app/receive_dabplus.py
+++ b/python/app/receive_dabplus.py
@@ -89,7 +89,7 @@ def receive_dabplus(frequency=220.352e6, rf_gain=25, if_gain=0, bb_gain=0, ppm=8
fg.start()
- raw_input("Running..")
+ input("Running..")
#new = grdab.dabplus_audio_decoder_ff(grdab.parameters.dab_parameters(mode=1, sample_rate=samp_rate, verbose=False), 64, 304, 64, 1, True)
#newaudio = audio.sink(44100, '', True)
fg.stop()