summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2019-09-13 17:50:01 +0200
committerDidier Raboud <odyx@debian.org>2019-09-13 17:50:01 +0200
commit81bc85bf03d4677964d3e96698106f5c3fcd1f5c (patch)
treec6a1edd83736742f22b550ba1251bce97ea0dff7
parenta05c7376487e7d853339cc459583d9a8dc69bcd7 (diff)
git-debrebase convert-from-dgit-view: drop upstream changes from breakwater
Drop upstream changes, and delete debian/patches, as part of converting to git-debrebase format. Upstream changes will appear as commits. [git-debrebase convert-from-dgit-view drop-patches]
-rw-r--r--configure.ac6
-rw-r--r--debian/patches/0001-Don-t-run-the-insanely-long-test-rastertogutenprint.patch23
-rw-r--r--debian/patches/0002-Fix-format-warning.patch36
-rw-r--r--debian/patches/0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch22
-rw-r--r--debian/patches/0004-Need-to-increment-current_interface-as-well-as-binar.patch22
-rw-r--r--debian/patches/0005-Also-need-to-fix-gutenprintui2_current_interface.patch22
-rw-r--r--debian/patches/0006-Mirror-doc-developer-cleanwarnings.pl-from-upstream.patch58
-rw-r--r--debian/patches/0007-Run-tests-with-custom-verbose-log-driver.patch186
-rw-r--r--debian/patches/series7
-rw-r--r--doc/developer/cleanwarnings.pl41
-rw-r--r--scripts/global.mk4
-rw-r--r--scripts/test-driver-verbose151
-rw-r--r--src/cups/Makefile.am2
-rw-r--r--src/cups/backend_common.c2
-rw-r--r--src/cups/gutenprint.c2
15 files changed, 6 insertions, 578 deletions
diff --git a/configure.ac b/configure.ac
index c61f06e..0ae13ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,9 +77,9 @@ pushdef([GUTENPRINT_MAJOR_VERSION], [5])
pushdef([GUTENPRINT_MINOR_VERSION], [3])
pushdef([GUTENPRINT_MICRO_VERSION], [1])
pushdef([GUTENPRINT_EXTRA_VERSION], [])
-pushdef([GUTENPRINT_CURRENT_INTERFACE], [10])
+pushdef([GUTENPRINT_CURRENT_INTERFACE], [9])
pushdef([GUTENPRINT_BINARY_AGE], [1])
-pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [3])
+pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [2])
pushdef([GUTENPRINTUI2_BINARY_AGE], [1])
pushdef([GUTENPRINT_VERSION], GUTENPRINT_MAJOR_VERSION.GUTENPRINT_MINOR_VERSION.GUTENPRINT_MICRO_VERSION[]GUTENPRINT_EXTRA_VERSION)
@@ -710,7 +710,7 @@ AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
dnl Compiler flags
if test x$ac_compiler_gnu = "xyes"; then
- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 -Wformat -Werror=format-security -Wmissing-prototypes],, [GNUCFLAGS])
+ STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
if test x${USE_MAINTAINER_MODE} = xyes ; then
STP_ADD_COMPILER_ARGS([-D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
fi
diff --git a/debian/patches/0001-Don-t-run-the-insanely-long-test-rastertogutenprint.patch b/debian/patches/0001-Don-t-run-the-insanely-long-test-rastertogutenprint.patch
deleted file mode 100644
index e166dae..0000000
--- a/debian/patches/0001-Don-t-run-the-insanely-long-test-rastertogutenprint.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 1769dac7748bc0d1a1dd4a894afb38596008d967 Mon Sep 17 00:00:00 2001
-From: Didier Raboud <odyx@debian.org>
-Date: Sun, 4 May 2014 12:34:59 +0200
-Subject: Don't run the insanely long test-rastertogutenprint
-
- build-test that lets sbuild timeout on all architectures
----
- src/cups/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cups/Makefile.am b/src/cups/Makefile.am
-index 2f707010..90a94534 100644
---- a/src/cups/Makefile.am
-+++ b/src/cups/Makefile.am
-@@ -100,7 +100,7 @@ endif
- AM_TESTS_ENVIRONMENT=$(STP_ENV)
- test-rastertogutenprint: min-pagesize
- test-rastertogutenprint.check: test-rastertogutenprint
--TESTS= test-ppds test-rastertogutenprint.check
-+TESTS= test-ppds
- noinst_SCRIPTS=test-ppds \
- test-rastertogutenprint \
- test-rastertogutenprint.check \
diff --git a/debian/patches/0002-Fix-format-warning.patch b/debian/patches/0002-Fix-format-warning.patch
deleted file mode 100644
index e815317..0000000
--- a/debian/patches/0002-Fix-format-warning.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From fb019c55c5d12c20f0371b417cb416d6caec3ad6 Mon Sep 17 00:00:00 2001
-From: Robert Krawitz <rlk@alum.mit.edu>
-Date: Tue, 25 Sep 2018 13:48:47 -0400
-Subject: Fix format warning
-
----
- configure.ac | 2 +-
- src/cups/gutenprint.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 0ae13ba4..b7c54972 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -710,7 +710,7 @@ AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
-
- dnl Compiler flags
- if test x$ac_compiler_gnu = "xyes"; then
-- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
-+ STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 -Wformat -Werror=format-security -Wmissing-prototypes],, [GNUCFLAGS])
- if test x${USE_MAINTAINER_MODE} = xyes ; then
- STP_ADD_COMPILER_ARGS([-D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
- fi
-diff --git a/src/cups/gutenprint.c b/src/cups/gutenprint.c
-index 6ab2194e..56b55994 100644
---- a/src/cups/gutenprint.c
-+++ b/src/cups/gutenprint.c
-@@ -122,7 +122,7 @@ cat_ppd(const char *uri) /* I - Driver URI */
- const char *lang = NULL;
- char *s;
- char filename[1024], /* Filename */
-- ppd_location[1024]; /* Installed location */
-+ ppd_location[2048]; /* Installed location */
- const char *infix = "";
- ppd_type_t ppd_type = PPD_STANDARD;
- gpfile outFD;
diff --git a/debian/patches/0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch b/debian/patches/0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch
deleted file mode 100644
index 3c5a760..0000000
--- a/debian/patches/0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From bcfbba4c2a422f7d4502b4712921fa0d70ad52e3 Mon Sep 17 00:00:00 2001
-From: Solomon Peachy <pizza@shaftnet.org>
-Date: Fri, 28 Sep 2018 11:03:53 -0400
-Subject: backend: Fix a compile warning that popped up on Debian 9
-
----
- src/cups/backend_common.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cups/backend_common.c b/src/cups/backend_common.c
-index 09ea0785..09406f8b 100644
---- a/src/cups/backend_common.c
-+++ b/src/cups/backend_common.c
-@@ -1354,7 +1354,7 @@ void dump_markers(struct marker *markers, int marker_count, int full)
-
- ATTR("marker-colors=");
- for (i = 0 ; i < marker_count; i++) {
-- DEBUG2(markers[i].color);
-+ DEBUG2("%s", markers[i].color);
- if ((i+1) < marker_count)
- DEBUG2(",");
- }
diff --git a/debian/patches/0004-Need-to-increment-current_interface-as-well-as-binar.patch b/debian/patches/0004-Need-to-increment-current_interface-as-well-as-binar.patch
deleted file mode 100644
index 72d10f6..0000000
--- a/debian/patches/0004-Need-to-increment-current_interface-as-well-as-binar.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 73427b40bcf3e1e8d87d911b22b4ccb6db23791b Mon Sep 17 00:00:00 2001
-From: Robert Krawitz <rlk@alum.mit.edu>
-Date: Fri, 28 Sep 2018 09:45:14 -0400
-Subject: Need to increment current_interface as well as binary_age.
-
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index b7c54972..be142e93 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -77,7 +77,7 @@ pushdef([GUTENPRINT_MAJOR_VERSION], [5])
- pushdef([GUTENPRINT_MINOR_VERSION], [3])
- pushdef([GUTENPRINT_MICRO_VERSION], [1])
- pushdef([GUTENPRINT_EXTRA_VERSION], [])
--pushdef([GUTENPRINT_CURRENT_INTERFACE], [9])
-+pushdef([GUTENPRINT_CURRENT_INTERFACE], [10])
- pushdef([GUTENPRINT_BINARY_AGE], [1])
- pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [2])
- pushdef([GUTENPRINTUI2_BINARY_AGE], [1])
diff --git a/debian/patches/0005-Also-need-to-fix-gutenprintui2_current_interface.patch b/debian/patches/0005-Also-need-to-fix-gutenprintui2_current_interface.patch
deleted file mode 100644
index d3fc776..0000000
--- a/debian/patches/0005-Also-need-to-fix-gutenprintui2_current_interface.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 4e8b7eeb3ab66c330e4ffe13535eeb348fdc5fdd Mon Sep 17 00:00:00 2001
-From: Robert Krawitz <rlk@alum.mit.edu>
-Date: Sun, 30 Sep 2018 10:49:11 -0400
-Subject: Also need to fix gutenprintui2_current_interface.
-
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index be142e93..c61f06e8 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -79,7 +79,7 @@ pushdef([GUTENPRINT_MICRO_VERSION], [1])
- pushdef([GUTENPRINT_EXTRA_VERSION], [])
- pushdef([GUTENPRINT_CURRENT_INTERFACE], [10])
- pushdef([GUTENPRINT_BINARY_AGE], [1])
--pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [2])
-+pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [3])
- pushdef([GUTENPRINTUI2_BINARY_AGE], [1])
- pushdef([GUTENPRINT_VERSION], GUTENPRINT_MAJOR_VERSION.GUTENPRINT_MINOR_VERSION.GUTENPRINT_MICRO_VERSION[]GUTENPRINT_EXTRA_VERSION)
-
diff --git a/debian/patches/0006-Mirror-doc-developer-cleanwarnings.pl-from-upstream.patch b/debian/patches/0006-Mirror-doc-developer-cleanwarnings.pl-from-upstream.patch
deleted file mode 100644
index bb801c3..0000000
--- a/debian/patches/0006-Mirror-doc-developer-cleanwarnings.pl-from-upstream.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 82ee55983110c5975405c017fe719e232e2ce8b9 Mon Sep 17 00:00:00 2001
-From: Didier Raboud <odyx@debian.org>
-Date: Sat, 1 Dec 2018 01:39:17 +0100
-Subject: Mirror doc/developer/cleanwarnings.pl from upstream
-
-Taken from upstream's master; it is needed to rebuild the doc PDFs from source
----
- doc/developer/cleanwarnings.pl | 41 ++++++++++++++++++++++++++++++++++
- 1 file changed, 41 insertions(+)
- create mode 100644 doc/developer/cleanwarnings.pl
-
-diff --git a/doc/developer/cleanwarnings.pl b/doc/developer/cleanwarnings.pl
-new file mode 100644
-index 00000000..42df7784
---- /dev/null
-+++ b/doc/developer/cleanwarnings.pl
-@@ -0,0 +1,41 @@
-+# -*- Mode: Perl -*-
-+## Copyright (C) 2013 Robert Krawitz
-+##
-+## This program is free software; you can redistribute it and/or modify
-+## it under the terms of the GNU General Public License as published by
-+## the Free Software Foundation; either version 2, or (at your option)
-+## any later version.
-+##
-+## This program is distributed in the hope that it will be useful,
-+## but WITHOUT ANY WARRANTY; without even the implied warranty of
-+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+## GNU General Public License for more details.
-+##
-+## You should have received a copy of the GNU General Public License
-+## along with this program. If not, see <https://www.gnu.org/licenses/>.
-+
-+# Remove annoying TeX warnings from db2pdf.
-+
-+$nc="";
-+while (<>) {
-+ next if /^$/;
-+ chomp;
-+ LINE:
-+ if (/^Overfull \\hbox|^LaTeX Font Warning:|^LaTeX Warning: Reference.*undefined on input line|^Package hyperref Warning:/) {
-+ $nc=" ";
-+ $_=<>;
-+ $_=<>;
-+ while (<>) {
-+ if (! /^ *$/) {
-+ chomp;
-+ goto LINE;
-+ }
-+ }
-+ } else {
-+ print "${nc}$_";
-+ $nc="\n";
-+ }
-+}
-+if ($nc ne "") {
-+ print "\n";
-+}
diff --git a/debian/patches/0007-Run-tests-with-custom-verbose-log-driver.patch b/debian/patches/0007-Run-tests-with-custom-verbose-log-driver.patch
deleted file mode 100644
index 73bb386..0000000
--- a/debian/patches/0007-Run-tests-with-custom-verbose-log-driver.patch
+++ /dev/null
@@ -1,186 +0,0 @@
-From 010b3758ebde325b6b832c5c9026ea14af712638 Mon Sep 17 00:00:00 2001
-From: Didier Raboud <odyx@debian.org>
-Date: Sun, 4 May 2014 12:34:59 +0200
-Subject: Run tests with custom verbose log driver
-
-This avoids timing out on slow architectures
-
-Closes: #868743
----
- scripts/global.mk | 4 +
- scripts/test-driver-verbose | 151 ++++++++++++++++++++++++++++++++++++
- 2 files changed, 155 insertions(+)
- create mode 100644 scripts/test-driver-verbose
-
-diff --git a/scripts/global.mk b/scripts/global.mk
-index c4054826..3c55e55d 100644
---- a/scripts/global.mk
-+++ b/scripts/global.mk
-@@ -8,6 +8,10 @@
-
- AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(LOCAL_CPPFLAGS) $(GNUCFLAGS)
-
-+# Use a verbose script to avoid timing out
-+LOG_DRIVER = $(top_srcdir)/scripts/test-driver-verbose
-+
-+
- LIBS = $(INTLLIBS) @LIBS@
-
- # Libraries
-diff --git a/scripts/test-driver-verbose b/scripts/test-driver-verbose
-new file mode 100644
-index 00000000..221fa9e2
---- /dev/null
-+++ b/scripts/test-driver-verbose
-@@ -0,0 +1,151 @@
-+#! /bin/sh
-+# test-driver - testsuite driver script inherited from Automake's basic, but with verbose output.
-+# Verbosity patch by Didier Raboud <odyx@debian.org>
-+
-+scriptversion=2018-03-07.03; # UTC
-+
-+# Copyright (C) 2011-2018 Free Software Foundation, Inc.
-+#
-+# This program is free software; you can redistribute it and/or modify
-+# it under the terms of the GNU General Public License as published by
-+# the Free Software Foundation; either version 2, or (at your option)
-+# any later version.
-+#
-+# This program is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+# GNU General Public License for more details.
-+#
-+# You should have received a copy of the GNU General Public License
-+# along with this program. If not, see <https://www.gnu.org/licenses/>.
-+
-+# As a special exception to the GNU General Public License, if you
-+# distribute this file as part of a program that contains a
-+# configuration script generated by Autoconf, you may include it under
-+# the same distribution terms that you use for the rest of that program.
-+
-+# Make unconditional expansion of undefined variables an error. This
-+# helps a lot in preventing typo-related bugs.
-+set -u
-+
-+usage_error ()
-+{
-+ echo "$0: $*" >&2
-+ print_usage >&2
-+ exit 2
-+}
-+
-+print_usage ()
-+{
-+ cat <<END
-+Usage:
-+ test-driver --test-name=NAME --log-file=PATH --trs-file=PATH
-+ [--expect-failure={yes|no}] [--color-tests={yes|no}]
-+ [--enable-hard-errors={yes|no}] [--]
-+ TEST-SCRIPT [TEST-SCRIPT-ARGUMENTS]
-+The '--test-name', '--log-file' and '--trs-file' options are mandatory.
-+END
-+}
-+
-+test_name= # Used for reporting.
-+log_file= # Where to save the output of the test script.
-+trs_file= # Where to save the metadata of the test run.
-+expect_failure=no
-+color_tests=no
-+enable_hard_errors=yes
-+while test $# -gt 1; do
-+ arg=${1%=*}
-+ val=${1#*=}
-+ if [ $arg = $val ]; then
-+ val=$2
-+ shift
-+ fi
-+ case $arg in
-+ --help) print_usage; exit $?;;
-+ --version) echo "test-driver $scriptversion"; exit $?;;
-+ --test-name) test_name=$val;;
-+ --log-file) log_file=$val;;
-+ --trs-file) trs_file=$val;;
-+ --color-tests) color_tests=$val;;
-+ --expect-failure) expect_failure=$val;;
-+ --enable-hard-errors) enable_hard_errors=$val;;
-+ --) break;;
-+ -*) usage_error "invalid option: '$1'";;
-+ esac
-+ [ $arg != $val ] && shift
-+done
-+
-+missing_opts=
-+test x"$test_name" = x && missing_opts="$missing_opts --test-name"
-+test x"$log_file" = x && missing_opts="$missing_opts --log-file"
-+test x"$trs_file" = x && missing_opts="$missing_opts --trs-file"
-+if test x"$missing_opts" != x; then
-+ usage_error "the following mandatory options are missing:$missing_opts"
-+fi
-+
-+if test $# -eq 0; then
-+ usage_error "missing argument"
-+fi
-+
-+if test $color_tests = yes; then
-+ # Keep this in sync with 'lib/am/check.am:$(am__tty_colors)'.
-+ red='' # Red.
-+ grn='' # Green.
-+ lgn='' # Light green.
-+ blu='' # Blue.
-+ mgn='' # Magenta.
-+ std='' # No color.
-+else
-+ red= grn= lgn= blu= mgn= std=
-+fi
-+
-+do_exit='rm -f $log_file $trs_file; (exit $st); exit $st'
-+trap "st=129; $do_exit" 1
-+trap "st=130; $do_exit" 2
-+trap "st=141; $do_exit" 13
-+trap "st=143; $do_exit" 15
-+
-+# Test script is run here.
-+# OdyX: Make it verbose by using tee
-+"$@" 2>&1 | tee -a $log_file
-+estatus=$?
-+
-+if test $enable_hard_errors = no && test $estatus -eq 99; then
-+ tweaked_estatus=1
-+else
-+ tweaked_estatus=$estatus
-+fi
-+
-+case $tweaked_estatus:$expect_failure in
-+ 0:yes) col=$red res=XPASS recheck=yes gcopy=yes;;
-+ 0:*) col=$grn res=PASS recheck=no gcopy=no;;
-+ 77:*) col=$blu res=SKIP recheck=no gcopy=yes;;
-+ 99:*) col=$mgn res=ERROR recheck=yes gcopy=yes;;
-+ *:yes) col=$lgn res=XFAIL recheck=no gcopy=yes;;
-+ *:*) col=$red res=FAIL recheck=yes gcopy=yes;;
-+esac
-+
-+# Report the test outcome and exit status in the logs, so that one can
-+# know whether the test passed or failed simply by looking at the '.log'
-+# file, without the need of also peaking into the corresponding '.trs'
-+# file (automake bug#11814).
-+echo "$res $test_name (exit status: $estatus)" >>$log_file
-+
-+# Report outcome to console.
-+echo "${col}${res}${std}: $test_name"
-+
-+# Register the test result, and other relevant metadata.
-+echo ":test-result: $res" > $trs_file
-+echo ":global-test-result: $res" >> $trs_file
-+echo ":recheck: $recheck" >> $trs_file
-+echo ":copy-in-global-log: $gcopy" >> $trs_file
-+
-+# Local Variables:
-+# mode: shell-script
-+# sh-indentation: 2
-+# eval: (add-hook 'before-save-hook 'time-stamp)
-+# time-stamp-start: "scriptversion="
-+# time-stamp-format: "%:y-%02m-%02d.%02H"
-+# time-stamp-time-zone: "UTC0"
-+# time-stamp-end: "; # UTC"
-+# End:
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index e698504..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,7 +0,0 @@
-0001-Don-t-run-the-insanely-long-test-rastertogutenprint.patch
-0002-Fix-format-warning.patch
-0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch
-0004-Need-to-increment-current_interface-as-well-as-binar.patch
-0005-Also-need-to-fix-gutenprintui2_current_interface.patch
-0006-Mirror-doc-developer-cleanwarnings.pl-from-upstream.patch
-0007-Run-tests-with-custom-verbose-log-driver.patch
diff --git a/doc/developer/cleanwarnings.pl b/doc/developer/cleanwarnings.pl
deleted file mode 100644
index 42df778..0000000
--- a/doc/developer/cleanwarnings.pl
+++ /dev/null
@@ -1,41 +0,0 @@
-# -*- Mode: Perl -*-
-## Copyright (C) 2013 Robert Krawitz
-##
-## This program is free software; you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
-## any later version.
-##
-## This program is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU General Public License for more details.
-##
-## You should have received a copy of the GNU General Public License
-## along with this program. If not, see <https://www.gnu.org/licenses/>.
-
-# Remove annoying TeX warnings from db2pdf.
-
-$nc="";
-while (<>) {
- next if /^$/;
- chomp;
- LINE:
- if (/^Overfull \\hbox|^LaTeX Font Warning:|^LaTeX Warning: Reference.*undefined on input line|^Package hyperref Warning:/) {
- $nc=" ";
- $_=<>;
- $_=<>;
- while (<>) {
- if (! /^ *$/) {
- chomp;
- goto LINE;
- }
- }
- } else {
- print "${nc}$_";
- $nc="\n";
- }
-}
-if ($nc ne "") {
- print "\n";
-}
diff --git a/scripts/global.mk b/scripts/global.mk
index 3c55e55..c405482 100644
--- a/scripts/global.mk
+++ b/scripts/global.mk
@@ -8,10 +8,6 @@
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(LOCAL_CPPFLAGS) $(GNUCFLAGS)
-# Use a verbose script to avoid timing out
-LOG_DRIVER = $(top_srcdir)/scripts/test-driver-verbose
-
-
LIBS = $(INTLLIBS) @LIBS@
# Libraries
diff --git a/scripts/test-driver-verbose b/scripts/test-driver-verbose
deleted file mode 100644
index 221fa9e..0000000
--- a/scripts/test-driver-verbose
+++ /dev/null
@@ -1,151 +0,0 @@
-#! /bin/sh
-# test-driver - testsuite driver script inherited from Automake's basic, but with verbose output.
-# Verbosity patch by Didier Raboud <odyx@debian.org>
-
-scriptversion=2018-03-07.03; # UTC
-
-# Copyright (C) 2011-2018 Free Software Foundation, Inc.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
-# any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <https://www.gnu.org/licenses/>.
-
-# As a special exception to the GNU General Public License, if you
-# distribute this file as part of a program that contains a
-# configuration script generated by Autoconf, you may include it under
-# the same distribution terms that you use for the rest of that program.
-
-# Make unconditional expansion of undefined variables an error. This
-# helps a lot in preventing typo-related bugs.
-set -u
-
-usage_error ()
-{
- echo "$0: $*" >&2
- print_usage >&2
- exit 2
-}
-
-print_usage ()
-{
- cat <<END
-Usage:
- test-driver --test-name=NAME --log-file=PATH --trs-file=PATH
- [--expect-failure={yes|no}] [--color-tests={yes|no}]
- [--enable-hard-errors={yes|no}] [--]
- TEST-SCRIPT [TEST-SCRIPT-ARGUMENTS]
-The '--test-name', '--log-file' and '--trs-file' options are mandatory.
-END
-}
-
-test_name= # Used for reporting.
-log_file= # Where to save the output of the test script.
-trs_file= # Where to save the metadata of the test run.
-expect_failure=no
-color_tests=no
-enable_hard_errors=yes
-while test $# -gt 1; do
- arg=${1%=*}
- val=${1#*=}
- if [ $arg = $val ]; then
- val=$2
- shift
- fi
- case $arg in
- --help) print_usage; exit $?;;
- --version) echo "test-driver $scriptversion"; exit $?;;
- --test-name) test_name=$val;;
- --log-file) log_file=$val;;
- --trs-file) trs_file=$val;;
- --color-tests) color_tests=$val;;
- --expect-failure) expect_failure=$val;;
- --enable-hard-errors) enable_hard_errors=$val;;
- --) break;;
- -*) usage_error "invalid option: '$1'";;
- esac
- [ $arg != $val ] && shift
-done
-
-missing_opts=
-test x"$test_name" = x && missing_opts="$missing_opts --test-name"
-test x"$log_file" = x && missing_opts="$missing_opts --log-file"
-test x"$trs_file" = x && missing_opts="$missing_opts --trs-file"
-if test x"$missing_opts" != x; then
- usage_error "the following mandatory options are missing:$missing_opts"
-fi
-
-if test $# -eq 0; then
- usage_error "missing argument"
-fi
-
-if test $color_tests = yes; then
- # Keep this in sync with 'lib/am/check.am:$(am__tty_colors)'.
- red='' # Red.
- grn='' # Green.
- lgn='' # Light green.
- blu='' # Blue.
- mgn='' # Magenta.
- std='' # No color.
-else
- red= grn= lgn= blu= mgn= std=
-fi
-
-do_exit='rm -f $log_file $trs_file; (exit $st); exit $st'
-trap "st=129; $do_exit" 1
-trap "st=130; $do_exit" 2
-trap "st=141; $do_exit" 13
-trap "st=143; $do_exit" 15
-
-# Test script is run here.
-# OdyX: Make it verbose by using tee
-"$@" 2>&1 | tee -a $log_file
-estatus=$?
-
-if test $enable_hard_errors = no && test $estatus -eq 99; then
- tweaked_estatus=1
-else
- tweaked_estatus=$estatus
-fi
-
-case $tweaked_estatus:$expect_failure in
- 0:yes) col=$red res=XPASS recheck=yes gcopy=yes;;
- 0:*) col=$grn res=PASS recheck=no gcopy=no;;
- 77:*) col=$blu res=SKIP recheck=no gcopy=yes;;
- 99:*) col=$mgn res=ERROR recheck=yes gcopy=yes;;
- *:yes) col=$lgn res=XFAIL recheck=no gcopy=yes;;
- *:*) col=$red res=FAIL recheck=yes gcopy=yes;;
-esac
-
-# Report the test outcome and exit status in the logs, so that one can
-# know whether the test passed or failed simply by looking at the '.log'
-# file, without the need of also peaking into the corresponding '.trs'
-# file (automake bug#11814).
-echo "$res $test_name (exit status: $estatus)" >>$log_file
-
-# Report outcome to console.
-echo "${col}${res}${std}: $test_name"
-
-# Register the test result, and other relevant metadata.
-echo ":test-result: $res" > $trs_file
-echo ":global-test-result: $res" >> $trs_file
-echo ":recheck: $recheck" >> $trs_file
-echo ":copy-in-global-log: $gcopy" >> $trs_file
-
-# Local Variables:
-# mode: shell-script
-# sh-indentation: 2
-# eval: (add-hook 'before-save-hook 'time-stamp)
-# time-stamp-start: "scriptversion="
-# time-stamp-format: "%:y-%02m-%02d.%02H"
-# time-stamp-time-zone: "UTC0"
-# time-stamp-end: "; # UTC"
-# End:
diff --git a/src/cups/Makefile.am b/src/cups/Makefile.am
index 90a9453..2f70701 100644
--- a/src/cups/Makefile.am
+++ b/src/cups/Makefile.am
@@ -100,7 +100,7 @@ endif
AM_TESTS_ENVIRONMENT=$(STP_ENV)
test-rastertogutenprint: min-pagesize
test-rastertogutenprint.check: test-rastertogutenprint
-TESTS= test-ppds
+TESTS= test-ppds test-rastertogutenprint.check
noinst_SCRIPTS=test-ppds \
test-rastertogutenprint \
test-rastertogutenprint.check \
diff --git a/src/cups/backend_common.c b/src/cups/backend_common.c
index 09406f8..09ea078 100644
--- a/src/cups/backend_common.c
+++ b/src/cups/backend_common.c
@@ -1354,7 +1354,7 @@ void dump_markers(struct marker *markers, int marker_count, int full)
ATTR("marker-colors=");
for (i = 0 ; i < marker_count; i++) {
- DEBUG2("%s", markers[i].color);
+ DEBUG2(markers[i].color);
if ((i+1) < marker_count)
DEBUG2(",");
}
diff --git a/src/cups/gutenprint.c b/src/cups/gutenprint.c
index 56b5599..6ab2194 100644
--- a/src/cups/gutenprint.c
+++ b/src/cups/gutenprint.c
@@ -122,7 +122,7 @@ cat_ppd(const char *uri) /* I - Driver URI */
const char *lang = NULL;
char *s;
char filename[1024], /* Filename */
- ppd_location[2048]; /* Installed location */
+ ppd_location[1024]; /* Installed location */
const char *infix = "";
ppd_type_t ppd_type = PPD_STANDARD;
gpfile outFD;