summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2018-09-26 09:47:37 +0200
committerDidier Raboud <odyx@debian.org>2018-09-30 11:05:03 +0200
commit34a143feb1c96b8eb1665cbaf86e101947a08428 (patch)
tree1efc7df5e2efd33cc0e52870766c0cbaa488306f
parent38c911ce9ad8d509bd1690355beb44140e623352 (diff)
parent73427b40bcf3e1e8d87d911b22b4ccb6db23791b (diff)
merge patched-debian/experimental into debian/experimental
-rw-r--r--configure.ac4
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/patches/0002-Fix-format-warning.patch36
-rw-r--r--debian/patches/0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch22
-rw-r--r--debian/patches/0004-Need-to-increment-current_interface-as-well-as-binar.patch22
-rw-r--r--debian/patches/series3
-rw-r--r--src/cups/backend_common.c2
-rw-r--r--src/cups/gutenprint.c2
8 files changed, 89 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0ae13ba..be142e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,7 +77,7 @@ pushdef([GUTENPRINT_MAJOR_VERSION], [5])
pushdef([GUTENPRINT_MINOR_VERSION], [3])
pushdef([GUTENPRINT_MICRO_VERSION], [1])
pushdef([GUTENPRINT_EXTRA_VERSION], [])
-pushdef([GUTENPRINT_CURRENT_INTERFACE], [9])
+pushdef([GUTENPRINT_CURRENT_INTERFACE], [10])
pushdef([GUTENPRINT_BINARY_AGE], [1])
pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [2])
pushdef([GUTENPRINTUI2_BINARY_AGE], [1])
@@ -710,7 +710,7 @@ AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
dnl Compiler flags
if test x$ac_compiler_gnu = "xyes"; then
- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
+ STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 -Wformat -Werror=format-security -Wmissing-prototypes],, [GNUCFLAGS])
if test x${USE_MAINTAINER_MODE} = xyes ; then
STP_ADD_COMPILER_ARGS([-D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
fi
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 58cc558..742add8 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
# see git-dpm(1) from git-dpm package
-1769dac7748bc0d1a1dd4a894afb38596008d967
-1769dac7748bc0d1a1dd4a894afb38596008d967
+73427b40bcf3e1e8d87d911b22b4ccb6db23791b
+73427b40bcf3e1e8d87d911b22b4ccb6db23791b
e50542121e724e851fc5d6c68bb773f80c0bc12c
e50542121e724e851fc5d6c68bb773f80c0bc12c
gutenprint_5.3.1.orig.tar.xz
diff --git a/debian/patches/0002-Fix-format-warning.patch b/debian/patches/0002-Fix-format-warning.patch
new file mode 100644
index 0000000..e815317
--- /dev/null
+++ b/debian/patches/0002-Fix-format-warning.patch
@@ -0,0 +1,36 @@
+From fb019c55c5d12c20f0371b417cb416d6caec3ad6 Mon Sep 17 00:00:00 2001
+From: Robert Krawitz <rlk@alum.mit.edu>
+Date: Tue, 25 Sep 2018 13:48:47 -0400
+Subject: Fix format warning
+
+---
+ configure.ac | 2 +-
+ src/cups/gutenprint.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0ae13ba4..b7c54972 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -710,7 +710,7 @@ AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
+
+ dnl Compiler flags
+ if test x$ac_compiler_gnu = "xyes"; then
+- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
++ STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 -Wformat -Werror=format-security -Wmissing-prototypes],, [GNUCFLAGS])
+ if test x${USE_MAINTAINER_MODE} = xyes ; then
+ STP_ADD_COMPILER_ARGS([-D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
+ fi
+diff --git a/src/cups/gutenprint.c b/src/cups/gutenprint.c
+index 6ab2194e..56b55994 100644
+--- a/src/cups/gutenprint.c
++++ b/src/cups/gutenprint.c
+@@ -122,7 +122,7 @@ cat_ppd(const char *uri) /* I - Driver URI */
+ const char *lang = NULL;
+ char *s;
+ char filename[1024], /* Filename */
+- ppd_location[1024]; /* Installed location */
++ ppd_location[2048]; /* Installed location */
+ const char *infix = "";
+ ppd_type_t ppd_type = PPD_STANDARD;
+ gpfile outFD;
diff --git a/debian/patches/0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch b/debian/patches/0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch
new file mode 100644
index 0000000..3c5a760
--- /dev/null
+++ b/debian/patches/0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch
@@ -0,0 +1,22 @@
+From bcfbba4c2a422f7d4502b4712921fa0d70ad52e3 Mon Sep 17 00:00:00 2001
+From: Solomon Peachy <pizza@shaftnet.org>
+Date: Fri, 28 Sep 2018 11:03:53 -0400
+Subject: backend: Fix a compile warning that popped up on Debian 9
+
+---
+ src/cups/backend_common.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/cups/backend_common.c b/src/cups/backend_common.c
+index 09ea0785..09406f8b 100644
+--- a/src/cups/backend_common.c
++++ b/src/cups/backend_common.c
+@@ -1354,7 +1354,7 @@ void dump_markers(struct marker *markers, int marker_count, int full)
+
+ ATTR("marker-colors=");
+ for (i = 0 ; i < marker_count; i++) {
+- DEBUG2(markers[i].color);
++ DEBUG2("%s", markers[i].color);
+ if ((i+1) < marker_count)
+ DEBUG2(",");
+ }
diff --git a/debian/patches/0004-Need-to-increment-current_interface-as-well-as-binar.patch b/debian/patches/0004-Need-to-increment-current_interface-as-well-as-binar.patch
new file mode 100644
index 0000000..72d10f6
--- /dev/null
+++ b/debian/patches/0004-Need-to-increment-current_interface-as-well-as-binar.patch
@@ -0,0 +1,22 @@
+From 73427b40bcf3e1e8d87d911b22b4ccb6db23791b Mon Sep 17 00:00:00 2001
+From: Robert Krawitz <rlk@alum.mit.edu>
+Date: Fri, 28 Sep 2018 09:45:14 -0400
+Subject: Need to increment current_interface as well as binary_age.
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index b7c54972..be142e93 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -77,7 +77,7 @@ pushdef([GUTENPRINT_MAJOR_VERSION], [5])
+ pushdef([GUTENPRINT_MINOR_VERSION], [3])
+ pushdef([GUTENPRINT_MICRO_VERSION], [1])
+ pushdef([GUTENPRINT_EXTRA_VERSION], [])
+-pushdef([GUTENPRINT_CURRENT_INTERFACE], [9])
++pushdef([GUTENPRINT_CURRENT_INTERFACE], [10])
+ pushdef([GUTENPRINT_BINARY_AGE], [1])
+ pushdef([GUTENPRINTUI2_CURRENT_INTERFACE], [2])
+ pushdef([GUTENPRINTUI2_BINARY_AGE], [1])
diff --git a/debian/patches/series b/debian/patches/series
index 6e37c16..e8dea6f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,4 @@
0001-Don-t-run-the-insanely-long-test-rastertogutenprint.patch
+0002-Fix-format-warning.patch
+0003-backend-Fix-a-compile-warning-that-popped-up-on-Debi.patch
+0004-Need-to-increment-current_interface-as-well-as-binar.patch
diff --git a/src/cups/backend_common.c b/src/cups/backend_common.c
index 09ea078..09406f8 100644
--- a/src/cups/backend_common.c
+++ b/src/cups/backend_common.c
@@ -1354,7 +1354,7 @@ void dump_markers(struct marker *markers, int marker_count, int full)
ATTR("marker-colors=");
for (i = 0 ; i < marker_count; i++) {
- DEBUG2(markers[i].color);
+ DEBUG2("%s", markers[i].color);
if ((i+1) < marker_count)
DEBUG2(",");
}
diff --git a/src/cups/gutenprint.c b/src/cups/gutenprint.c
index 6ab2194..56b5599 100644
--- a/src/cups/gutenprint.c
+++ b/src/cups/gutenprint.c
@@ -122,7 +122,7 @@ cat_ppd(const char *uri) /* I - Driver URI */
const char *lang = NULL;
char *s;
char filename[1024], /* Filename */
- ppd_location[1024]; /* Installed location */
+ ppd_location[2048]; /* Installed location */
const char *infix = "";
ppd_type_t ppd_type = PPD_STANDARD;
gpfile outFD;