summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Krawitz <rlk@alum.mit.edu>2018-09-25 13:48:47 -0400
committerDidier Raboud <odyx@debian.org>2018-09-26 09:47:25 +0200
commitfb019c55c5d12c20f0371b417cb416d6caec3ad6 (patch)
tree459b7ace35f5ce2ae6e6ee1268893e292f81f9fa
parent1769dac7748bc0d1a1dd4a894afb38596008d967 (diff)
Fix format warning
-rw-r--r--configure.ac2
-rw-r--r--src/cups/gutenprint.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0ae13ba..b7c5497 100644
--- a/configure.ac
+++ b/configure.ac
@@ -710,7 +710,7 @@ AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
dnl Compiler flags
if test x$ac_compiler_gnu = "xyes"; then
- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
+ STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 -Wformat -Werror=format-security -Wmissing-prototypes],, [GNUCFLAGS])
if test x${USE_MAINTAINER_MODE} = xyes ; then
STP_ADD_COMPILER_ARGS([-D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
fi
diff --git a/src/cups/gutenprint.c b/src/cups/gutenprint.c
index 6ab2194..56b5599 100644
--- a/src/cups/gutenprint.c
+++ b/src/cups/gutenprint.c
@@ -122,7 +122,7 @@ cat_ppd(const char *uri) /* I - Driver URI */
const char *lang = NULL;
char *s;
char filename[1024], /* Filename */
- ppd_location[1024]; /* Installed location */
+ ppd_location[2048]; /* Installed location */
const char *infix = "";
ppd_type_t ppd_type = PPD_STANDARD;
gpfile outFD;