summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Krawitz <rlk@alum.mit.edu>2018-09-25 13:48:47 -0400
committerDidier Raboud <odyx@debian.org>2019-09-13 17:50:01 +0200
commitcf5f431a886c657a12116ee540340e6500385580 (patch)
treeb1d8b08a74146046811cdfda51f4ae1b8db3e8b6
parentd8b8d0bbf70e3b08fda39f4088f277ed8013e5b8 (diff)
Fix format warning
Gbp-Pq: Name 0002-Fix-format-warning.patch
-rw-r--r--configure.ac2
-rw-r--r--src/cups/gutenprint.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0ae13ba..b7c5497 100644
--- a/configure.ac
+++ b/configure.ac
@@ -710,7 +710,7 @@ AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
dnl Compiler flags
if test x$ac_compiler_gnu = "xyes"; then
- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
+ STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 -Wformat -Werror=format-security -Wmissing-prototypes],, [GNUCFLAGS])
if test x${USE_MAINTAINER_MODE} = xyes ; then
STP_ADD_COMPILER_ARGS([-D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
fi
diff --git a/src/cups/gutenprint.c b/src/cups/gutenprint.c
index 6ab2194..56b5599 100644
--- a/src/cups/gutenprint.c
+++ b/src/cups/gutenprint.c
@@ -122,7 +122,7 @@ cat_ppd(const char *uri) /* I - Driver URI */
const char *lang = NULL;
char *s;
char filename[1024], /* Filename */
- ppd_location[1024]; /* Installed location */
+ ppd_location[2048]; /* Installed location */
const char *infix = "";
ppd_type_t ppd_type = PPD_STANDARD;
gpfile outFD;