summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2018-04-10 07:44:22 -0400
committerClint Adams <clint@debian.org>2018-04-10 07:44:22 -0400
commit6bc47b82f790ce2e85fbba2633f44848ceed9f6a (patch)
tree3dbf18a3076e60836d490a8f9f3b7661460d4aa7
parent6e1e94bc4efd8a0ac37f34ac84f4813bcb0105cc (diff)
Cope with Cabal 2.0 gen-pkg-config output change.
-rw-r--r--Dh_Haskell.sh4
-rw-r--r--debian/changelog6
-rw-r--r--debian/control6
3 files changed, 9 insertions, 7 deletions
diff --git a/Dh_Haskell.sh b/Dh_Haskell.sh
index 9f07aff..f614396 100644
--- a/Dh_Haskell.sh
+++ b/Dh_Haskell.sh
@@ -502,7 +502,7 @@ haddock_recipe(){
extra_depends_recipe(){
# local PS5=$PS4; PS4=" + extra_depends_recipe> "; set -x
hc=$1
- pkg_config=`${DEB_SETUP_BIN_NAME} register --builddir=dist-${hc} --gen-pkg-config | tr -d ' \n' | sed -r 's,^.*:,,'`
+ pkg_config=`LC_ALL=C ${DEB_SETUP_BIN_NAME} register --builddir=dist-${hc} --gen-pkg-config --verbose=1 | sed -r -n '/^Creating package registration file: /s///p'`
run dh_haskell_extra_depends ${hc} $pkg_config
rm $pkg_config
# PS4=$PS5
@@ -519,7 +519,7 @@ install_dev_recipe(){
( run cd debian/tmp-inst-${hc} ; run mkdir -p ${libdir} ; run find ${libdir}/ \
\( ! -name "*_p.a" ! -name "*.p_hi" ! -type d \) \
-exec install -Dm 644 '{}' ../${PKG}/'{}' ';' )
- pkg_config=`${DEB_SETUP_BIN_NAME} register --builddir=dist-${hc} --gen-pkg-config | tr -d ' \n' | sed -r 's,^.*:,,'`
+ pkg_config=`LC_ALL=C ${DEB_SETUP_BIN_NAME} register --builddir=dist-${hc} --gen-pkg-config --verbose=1 | sed -r -n '/^Creating package registration file: /s///p'`
if [ "${HASKELL_HIDE_PACKAGES}" ]; then sed -i 's/^exposed: True$/exposed: False/' $pkg_config; fi
run install -Dm 644 $pkg_config debian/${PKG}/${pkgdir}/$pkg_config
run rm -f $pkg_config
diff --git a/debian/changelog b/debian/changelog
index 2d26845..becc037 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+haskell-devscripts (0.13.4) unstable; urgency=medium
+
+ * Cope with Cabal 2.0 gen-pkg-config output change.
+
+ -- Clint Adams <clint@debian.org> Tue, 10 Apr 2018 07:43:36 -0400
+
haskell-devscripts (0.13.3) unstable; urgency=medium
* Patch from Chris Lamb to sort haskell:Recommends substvar.
diff --git a/debian/control b/debian/control
index 4a312fb..c0d5c6c 100644
--- a/debian/control
+++ b/debian/control
@@ -2,16 +2,12 @@ Source: haskell-devscripts
Section: haskell
Priority: extra
Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
-Uploaders: Marco Silva <marcot@debian.org>, Joachim Breitner <nomeata@debian.org>
- , Louis Bettens <louis@bettens.info>
- , Dmitry Bogatov <KAction@gnu.org>
Build-Depends: debhelper (>= 9)
Build-Depends-Indep: perl
-Standards-Version: 3.9.8
+Standards-Version: 4.1.4
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/haskell-devscripts.git
Vcs-Git: https://anonscm.debian.org/git/pkg-haskell/haskell-devscripts.git
-
Package: haskell-devscripts-minimal
Architecture: all
Depends: dctrl-tools