summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2017-01-06 17:20:29 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2017-01-06 17:20:29 +0000
commit2780f8ded2a630d9ac6c87ee3656296b459afa00 (patch)
tree6894f957c553a9629c5fd23d6d8a8a358601c724
parent08e6d785454f2b3deb838748f2ddba4647246fba (diff)
Add patch canonical_host: avoid use of @CANONICAL_HOST@, which breaks reproducibility on e.g. x86.
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/canonical_host32
-rw-r--r--debian/patches/series1
-rw-r--r--tools/krb5-config.in17
4 files changed, 41 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index 79932954a..655ae620f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+heimdal (7.1.0+dfsg-4) UNRELEASED; urgency=medium
+
+ * Add patch canonical_host: avoid use of @CANONICAL_HOST@, which
+ breaks reproducibility on e.g. x86.
+
+ -- Jelmer Vernooij <jelmer@debian.org> Thu, 05 Jan 2017 20:15:22 +0000
+
heimdal (7.1.0+dfsg-3) unstable; urgency=medium
* Fix building arch-only. Closes: #806045
diff --git a/debian/patches/canonical_host b/debian/patches/canonical_host
new file mode 100644
index 000000000..000be6b8a
--- /dev/null
+++ b/debian/patches/canonical_host
@@ -0,0 +1,32 @@
+Description: Disable use of @CANONICAL_HOST@, which is not reproducible.
+Status: not forwarded upstream (not applicable)
+Bug: https://github.com/heimdal/heimdal/issues/237
+
+diff --git a/tools/krb5-config.in b/tools/krb5-config.in
+index 53b4387a6..5288f84ae 100644
+--- a/tools/krb5-config.in
++++ b/tools/krb5-config.in
+@@ -181,22 +181,7 @@ fi
+ # option... And MIT's krb5-config does include rpath flags.
+ #
+ # Compatibility with MIT is the winning consideration for now.
+-case "@CANONICAL_HOST@" in
+-alpha*-dec-osf*)
+- rpath_flag='-Wl,-rpath -Wl,';;
+-*-*-hpux*)
+- rpath_flag='-Wl,+b,';;
+-*-*-irix* | mips-*-netbsd*)
+- rpath_flag='-Wl,-rpath -Wl,';;
+-*-*-netbsd* | *-*-openbsd* | *-*-solaris*)
+- rpath_flag='-R';;
+-*-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu | *-*-freebsd*)
+- rpath_flag='-Wl,--enable-new-dtags -Wl,-rpath -Wl,';;
+-*-*-aix*)
+- rpath_flag='-Wl,-blibpath:';;
+-*)
+-rpath_flag=;;
+-esac
++rpath_flag='-Wl,--enable-new-dtags -Wl,-rpath -Wl,';;
+
+ if test "$do_libs" = "yes"; then
+ deplibs=""
diff --git a/debian/patches/series b/debian/patches/series
index 4c35c66eb..4146a3529 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -13,3 +13,4 @@ installsh
parallel-build
check_iprop_races
disable_iprop
+canonical_host
diff --git a/tools/krb5-config.in b/tools/krb5-config.in
index 53b4387a6..5288f84ae 100644
--- a/tools/krb5-config.in
+++ b/tools/krb5-config.in
@@ -181,22 +181,7 @@ fi
# option... And MIT's krb5-config does include rpath flags.
#
# Compatibility with MIT is the winning consideration for now.
-case "@CANONICAL_HOST@" in
-alpha*-dec-osf*)
- rpath_flag='-Wl,-rpath -Wl,';;
-*-*-hpux*)
- rpath_flag='-Wl,+b,';;
-*-*-irix* | mips-*-netbsd*)
- rpath_flag='-Wl,-rpath -Wl,';;
-*-*-netbsd* | *-*-openbsd* | *-*-solaris*)
- rpath_flag='-R';;
-*-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu | *-*-freebsd*)
- rpath_flag='-Wl,--enable-new-dtags -Wl,-rpath -Wl,';;
-*-*-aix*)
- rpath_flag='-Wl,-blibpath:';;
-*)
-rpath_flag=;;
-esac
+rpath_flag='-Wl,--enable-new-dtags -Wl,-rpath -Wl,';;
if test "$do_libs" = "yes"; then
deplibs=""