summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2017-01-08 00:54:17 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2017-01-08 00:58:34 +0000
commit65b4cbb8b894c84841f4c47fc392961d0b300ff9 (patch)
tree7d1d3084081da7c64c7fdf7b4a80e1c9f510ea9f
parentbf8eaacf7d3a2bbb5c36e9298986c10d78644500 (diff)
Don't build on MIPS, to work around #884227.
-rw-r--r--debian/changelog7
-rw-r--r--debian/control1
-rw-r--r--debian/patches/no_test_dbinfo69
-rw-r--r--debian/patches/series1
-rw-r--r--kdc/set_dbinfo.c2
-rw-r--r--lib/hdb/Makefile.am2
-rw-r--r--lib/hdb/Makefile.in2
-rw-r--r--tests/db/Makefile.am2
-rw-r--r--tests/db/Makefile.in2
9 files changed, 14 insertions, 74 deletions
diff --git a/debian/changelog b/debian/changelog
index a3a5e9387..20e8fcb00 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+heimdal (7.1.0+dfsg-5) UNRELEASED; urgency=medium
+
+ * Don't build on MIPS, to work around #884227 for now.
+ + Drop no_test_dbinfo patch.
+
+ -- Jelmer Vernooij <jelmer@debian.org> Sun, 08 Jan 2017 00:51:17 +0000
+
heimdal (7.1.0+dfsg-4) unstable; urgency=medium
* Add patch canonical_host: avoid use of @CANONICAL_HOST@, which
diff --git a/debian/control b/debian/control
index 00e94dbad..ad43b55dc 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,7 @@ Maintainer: Brian May <bam@debian.org>
Uploaders: Jelmer Vernooij <jelmer@debian.org>
Homepage: http://www.h5l.org/
Standards-Version: 3.9.8
+Architecture: amd64 armel armhf i386 ia64 kfreebsd-amd64 kfreebsd-i386 powerpc s390 s390x sparc sh4 m68k ppc64el x32
Build-Depends: bison,
comerr-dev (>= 1.41.11),
debhelper (>= 9),
diff --git a/debian/patches/no_test_dbinfo b/debian/patches/no_test_dbinfo
deleted file mode 100644
index 61a5491af..000000000
--- a/debian/patches/no_test_dbinfo
+++ /dev/null
@@ -1,69 +0,0 @@
-Description: Disable test_dbinfo as it fails to build on MIPS
-Author: Jelmer Vernooij <jelmer@debian.org>
-Bug-Debian: https://bugs.debian.org/844227
-
-diff --git a/lib/hdb/Makefile.am b/lib/hdb/Makefile.am
-index c17305767..85b078bcb 100644
---- a/lib/hdb/Makefile.am
-+++ b/lib/hdb/Makefile.am
-@@ -73,7 +73,7 @@ if versionscript
- libhdb_la_LDFLAGS += $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
- endif
-
--noinst_PROGRAMS = test_dbinfo test_hdbkeys test_mkey test_hdbplugin
-+noinst_PROGRAMS = test_hdbkeys test_mkey test_hdbplugin
-
- dist_libhdb_la_SOURCES = \
- common.c \
-diff --git a/lib/hdb/Makefile.in b/lib/hdb/Makefile.in
-index f54940d23..f4a408a4c 100644
---- a/lib/hdb/Makefile.in
-+++ b/lib/hdb/Makefile.in
-@@ -98,7 +98,7 @@ build_triplet = @build@
- host_triplet = @host@
- @HAVE_DBHEADER_TRUE@am__append_1 = -I$(DBHEADER)
- @versionscript_TRUE@am__append_2 = $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
--noinst_PROGRAMS = test_dbinfo$(EXEEXT) test_hdbkeys$(EXEEXT) \
-+noinst_PROGRAMS = test_hdbkeys$(EXEEXT) \
- test_mkey$(EXEEXT) test_hdbplugin$(EXEEXT)
- subdir = lib/hdb
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-diff --git a/kdc/set_dbinfo.c b/kdc/set_dbinfo.c
-index d22e083f7..f49aaa163 100644
---- a/kdc/set_dbinfo.c
-+++ b/kdc/set_dbinfo.c
-@@ -85,8 +85,6 @@ krb5_kdc_set_dbinfo(krb5_context context, struct krb5_kdc_configuration *c)
- if (ret)
- goto out;
-
-- kdc_log(context, c, 0, "label: %s",
-- hdb_dbinfo_get_label(context, d));
- kdc_log(context, c, 0, "\tdbname: %s",
- hdb_dbinfo_get_dbname(context, d));
- kdc_log(context, c, 0, "\tmkey_file: %s",
-diff --git a/tests/db/Makefile.am b/tests/db/Makefile.am
-index 9597a0b44..b92fb1a06 100644
---- a/tests/db/Makefile.am
-+++ b/tests/db/Makefile.am
-@@ -6,7 +6,7 @@ noinst_DATA = krb5.conf krb5.conf-sqlite krb5.conf-db3 krb5.conf-db1 krb5.conf-l
-
- noinst_SCRIPTS = have-db
-
--check_SCRIPTS = loaddump-db add-modify-delete check-dbinfo check-aliases
-+check_SCRIPTS = loaddump-db add-modify-delete check-aliases
-
- TESTS = $(check_SCRIPTS)
-
-diff --git a/tests/db/Makefile.in b/tests/db/Makefile.in
-index e8f4854ed..edc58455c 100644
---- a/tests/db/Makefile.in
-+++ b/tests/db/Makefile.in
-@@ -632,7 +632,7 @@ heim_verbose_ = $(heim_verbose_$(AM_DEFAULT_VERBOSITY))
- heim_verbose_0 = @echo " GEN "$@;
- noinst_DATA = krb5.conf krb5.conf-sqlite krb5.conf-db3 krb5.conf-db1 krb5.conf-lmdb
- noinst_SCRIPTS = have-db
--check_SCRIPTS = loaddump-db add-modify-delete check-dbinfo check-aliases
-+check_SCRIPTS = loaddump-db add-modify-delete check-aliases
- TESTS = $(check_SCRIPTS)
- do_subst = sed -e 's,[@]srcdir[@],$(srcdir),g' \
- -e 's,[@]top_builddir[@],$(top_builddir),g' \
diff --git a/debian/patches/series b/debian/patches/series
index 1432cd0bc..4146a3529 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -14,4 +14,3 @@ parallel-build
check_iprop_races
disable_iprop
canonical_host
-no_test_dbinfo
diff --git a/kdc/set_dbinfo.c b/kdc/set_dbinfo.c
index f49aaa163..d22e083f7 100644
--- a/kdc/set_dbinfo.c
+++ b/kdc/set_dbinfo.c
@@ -85,6 +85,8 @@ krb5_kdc_set_dbinfo(krb5_context context, struct krb5_kdc_configuration *c)
if (ret)
goto out;
+ kdc_log(context, c, 0, "label: %s",
+ hdb_dbinfo_get_label(context, d));
kdc_log(context, c, 0, "\tdbname: %s",
hdb_dbinfo_get_dbname(context, d));
kdc_log(context, c, 0, "\tmkey_file: %s",
diff --git a/lib/hdb/Makefile.am b/lib/hdb/Makefile.am
index 85b078bcb..c17305767 100644
--- a/lib/hdb/Makefile.am
+++ b/lib/hdb/Makefile.am
@@ -73,7 +73,7 @@ if versionscript
libhdb_la_LDFLAGS += $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
endif
-noinst_PROGRAMS = test_hdbkeys test_mkey test_hdbplugin
+noinst_PROGRAMS = test_dbinfo test_hdbkeys test_mkey test_hdbplugin
dist_libhdb_la_SOURCES = \
common.c \
diff --git a/lib/hdb/Makefile.in b/lib/hdb/Makefile.in
index f4a408a4c..f54940d23 100644
--- a/lib/hdb/Makefile.in
+++ b/lib/hdb/Makefile.in
@@ -98,7 +98,7 @@ build_triplet = @build@
host_triplet = @host@
@HAVE_DBHEADER_TRUE@am__append_1 = -I$(DBHEADER)
@versionscript_TRUE@am__append_2 = $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
-noinst_PROGRAMS = test_hdbkeys$(EXEEXT) \
+noinst_PROGRAMS = test_dbinfo$(EXEEXT) test_hdbkeys$(EXEEXT) \
test_mkey$(EXEEXT) test_hdbplugin$(EXEEXT)
subdir = lib/hdb
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/tests/db/Makefile.am b/tests/db/Makefile.am
index b92fb1a06..9597a0b44 100644
--- a/tests/db/Makefile.am
+++ b/tests/db/Makefile.am
@@ -6,7 +6,7 @@ noinst_DATA = krb5.conf krb5.conf-sqlite krb5.conf-db3 krb5.conf-db1 krb5.conf-l
noinst_SCRIPTS = have-db
-check_SCRIPTS = loaddump-db add-modify-delete check-aliases
+check_SCRIPTS = loaddump-db add-modify-delete check-dbinfo check-aliases
TESTS = $(check_SCRIPTS)
diff --git a/tests/db/Makefile.in b/tests/db/Makefile.in
index edc58455c..e8f4854ed 100644
--- a/tests/db/Makefile.in
+++ b/tests/db/Makefile.in
@@ -632,7 +632,7 @@ heim_verbose_ = $(heim_verbose_$(AM_DEFAULT_VERBOSITY))
heim_verbose_0 = @echo " GEN "$@;
noinst_DATA = krb5.conf krb5.conf-sqlite krb5.conf-db3 krb5.conf-db1 krb5.conf-lmdb
noinst_SCRIPTS = have-db
-check_SCRIPTS = loaddump-db add-modify-delete check-aliases
+check_SCRIPTS = loaddump-db add-modify-delete check-dbinfo check-aliases
TESTS = $(check_SCRIPTS)
do_subst = sed -e 's,[@]srcdir[@],$(srcdir),g' \
-e 's,[@]top_builddir[@],$(top_builddir),g' \