summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2017-01-07 16:18:04 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2017-01-07 16:50:10 +0000
commit6a49f3e786a06522cce6ec13481985247beec33c (patch)
tree53f12f0e86fc71634dc15b46970e0e1ea9e2b746
parentfe620ba76518411d70866e467f45423b3bd7f1e2 (diff)
Add patch no_test_dbinfo: disable test_dbinfo, as it fails to build on MIPS. Works around #844227.
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/no_test_dbinfo30
-rw-r--r--debian/patches/series1
-rw-r--r--lib/hdb/Makefile.am2
-rw-r--r--lib/hdb/Makefile.in2
5 files changed, 35 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8ef5c5a0e..190bc11b7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ heimdal (7.1.0+dfsg-4) UNRELEASED; urgency=medium
* Add patch canonical_host: avoid use of @CANONICAL_HOST@, which
breaks reproducibility on e.g. x86.
* Change Vcs headers to new Git location.
+ * Add patch no_test_dbinfo: disable test_dbinfo, as it fails to build
+ on MIPS. Works around #844227.
-- Jelmer Vernooij <jelmer@debian.org> Thu, 05 Jan 2017 20:15:22 +0000
diff --git a/debian/patches/no_test_dbinfo b/debian/patches/no_test_dbinfo
new file mode 100644
index 000000000..5269115e9
--- /dev/null
+++ b/debian/patches/no_test_dbinfo
@@ -0,0 +1,30 @@
+Description: Disable test_dbinfo as it fails to build on MIPS
+Author: Jelmer Vernooij <jelmer@debian.org>
+Bug-Debian: https://bugs.debian.org/844227
+
+diff --git a/lib/hdb/Makefile.am b/lib/hdb/Makefile.am
+index c17305767..85b078bcb 100644
+--- a/lib/hdb/Makefile.am
++++ b/lib/hdb/Makefile.am
+@@ -73,7 +73,7 @@ if versionscript
+ libhdb_la_LDFLAGS += $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
+ endif
+
+-noinst_PROGRAMS = test_dbinfo test_hdbkeys test_mkey test_hdbplugin
++noinst_PROGRAMS = test_hdbkeys test_mkey test_hdbplugin
+
+ dist_libhdb_la_SOURCES = \
+ common.c \
+diff --git a/lib/hdb/Makefile.in b/lib/hdb/Makefile.in
+index f54940d23..f4a408a4c 100644
+--- a/lib/hdb/Makefile.in
++++ b/lib/hdb/Makefile.in
+@@ -98,7 +98,7 @@ build_triplet = @build@
+ host_triplet = @host@
+ @HAVE_DBHEADER_TRUE@am__append_1 = -I$(DBHEADER)
+ @versionscript_TRUE@am__append_2 = $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
+-noinst_PROGRAMS = test_dbinfo$(EXEEXT) test_hdbkeys$(EXEEXT) \
++noinst_PROGRAMS = test_hdbkeys$(EXEEXT) \
+ test_mkey$(EXEEXT) test_hdbplugin$(EXEEXT)
+ subdir = lib/hdb
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/debian/patches/series b/debian/patches/series
index 4146a3529..1432cd0bc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -14,3 +14,4 @@ parallel-build
check_iprop_races
disable_iprop
canonical_host
+no_test_dbinfo
diff --git a/lib/hdb/Makefile.am b/lib/hdb/Makefile.am
index c17305767..85b078bcb 100644
--- a/lib/hdb/Makefile.am
+++ b/lib/hdb/Makefile.am
@@ -73,7 +73,7 @@ if versionscript
libhdb_la_LDFLAGS += $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
endif
-noinst_PROGRAMS = test_dbinfo test_hdbkeys test_mkey test_hdbplugin
+noinst_PROGRAMS = test_hdbkeys test_mkey test_hdbplugin
dist_libhdb_la_SOURCES = \
common.c \
diff --git a/lib/hdb/Makefile.in b/lib/hdb/Makefile.in
index f54940d23..f4a408a4c 100644
--- a/lib/hdb/Makefile.in
+++ b/lib/hdb/Makefile.in
@@ -98,7 +98,7 @@ build_triplet = @build@
host_triplet = @host@
@HAVE_DBHEADER_TRUE@am__append_1 = -I$(DBHEADER)
@versionscript_TRUE@am__append_2 = $(LDFLAGS_VERSION_SCRIPT)$(srcdir)/version-script.map
-noinst_PROGRAMS = test_dbinfo$(EXEEXT) test_hdbkeys$(EXEEXT) \
+noinst_PROGRAMS = test_hdbkeys$(EXEEXT) \
test_mkey$(EXEEXT) test_hdbplugin$(EXEEXT)
subdir = lib/hdb
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4