summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2017-01-07 19:23:52 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2017-01-07 19:23:52 +0000
commit9e8b1ef20e373b66e94339f44b7d5a52bd42c423 (patch)
tree375513b4175e7980b5957b2886dd77c1973bade7
parent88813a7ccb8c78ab4c0f0056e21a51a159b60bb7 (diff)
Also disable actual running of dbinfo test.
-rw-r--r--debian/patches/no_test_dbinfo26
-rw-r--r--tests/db/Makefile.am2
-rw-r--r--tests/db/Makefile.in2
3 files changed, 28 insertions, 2 deletions
diff --git a/debian/patches/no_test_dbinfo b/debian/patches/no_test_dbinfo
index be97dbd08..61a5491af 100644
--- a/debian/patches/no_test_dbinfo
+++ b/debian/patches/no_test_dbinfo
@@ -41,3 +41,29 @@ index d22e083f7..f49aaa163 100644
kdc_log(context, c, 0, "\tdbname: %s",
hdb_dbinfo_get_dbname(context, d));
kdc_log(context, c, 0, "\tmkey_file: %s",
+diff --git a/tests/db/Makefile.am b/tests/db/Makefile.am
+index 9597a0b44..b92fb1a06 100644
+--- a/tests/db/Makefile.am
++++ b/tests/db/Makefile.am
+@@ -6,7 +6,7 @@ noinst_DATA = krb5.conf krb5.conf-sqlite krb5.conf-db3 krb5.conf-db1 krb5.conf-l
+
+ noinst_SCRIPTS = have-db
+
+-check_SCRIPTS = loaddump-db add-modify-delete check-dbinfo check-aliases
++check_SCRIPTS = loaddump-db add-modify-delete check-aliases
+
+ TESTS = $(check_SCRIPTS)
+
+diff --git a/tests/db/Makefile.in b/tests/db/Makefile.in
+index e8f4854ed..edc58455c 100644
+--- a/tests/db/Makefile.in
++++ b/tests/db/Makefile.in
+@@ -632,7 +632,7 @@ heim_verbose_ = $(heim_verbose_$(AM_DEFAULT_VERBOSITY))
+ heim_verbose_0 = @echo " GEN "$@;
+ noinst_DATA = krb5.conf krb5.conf-sqlite krb5.conf-db3 krb5.conf-db1 krb5.conf-lmdb
+ noinst_SCRIPTS = have-db
+-check_SCRIPTS = loaddump-db add-modify-delete check-dbinfo check-aliases
++check_SCRIPTS = loaddump-db add-modify-delete check-aliases
+ TESTS = $(check_SCRIPTS)
+ do_subst = sed -e 's,[@]srcdir[@],$(srcdir),g' \
+ -e 's,[@]top_builddir[@],$(top_builddir),g' \
diff --git a/tests/db/Makefile.am b/tests/db/Makefile.am
index 9597a0b44..b92fb1a06 100644
--- a/tests/db/Makefile.am
+++ b/tests/db/Makefile.am
@@ -6,7 +6,7 @@ noinst_DATA = krb5.conf krb5.conf-sqlite krb5.conf-db3 krb5.conf-db1 krb5.conf-l
noinst_SCRIPTS = have-db
-check_SCRIPTS = loaddump-db add-modify-delete check-dbinfo check-aliases
+check_SCRIPTS = loaddump-db add-modify-delete check-aliases
TESTS = $(check_SCRIPTS)
diff --git a/tests/db/Makefile.in b/tests/db/Makefile.in
index e8f4854ed..edc58455c 100644
--- a/tests/db/Makefile.in
+++ b/tests/db/Makefile.in
@@ -632,7 +632,7 @@ heim_verbose_ = $(heim_verbose_$(AM_DEFAULT_VERBOSITY))
heim_verbose_0 = @echo " GEN "$@;
noinst_DATA = krb5.conf krb5.conf-sqlite krb5.conf-db3 krb5.conf-db1 krb5.conf-lmdb
noinst_SCRIPTS = have-db
-check_SCRIPTS = loaddump-db add-modify-delete check-dbinfo check-aliases
+check_SCRIPTS = loaddump-db add-modify-delete check-aliases
TESTS = $(check_SCRIPTS)
do_subst = sed -e 's,[@]srcdir[@],$(srcdir),g' \
-e 's,[@]top_builddir[@],$(top_builddir),g' \