summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-11-12 09:48:51 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-11-12 09:48:51 -0700
commit2e28281d92de663d4437bee09403a33fe1fbdeb6 (patch)
tree56631450590ff347f779bf6ffea397daee808ebc
parenta2b55b9bae7984508b4e00ca32d8ff141276acb4 (diff)
remove async dependency
Upstream specifies a dependency on async.el in order to fix installation from MELPA. The Debian installation process avoids the issue. We remove the dependency from ${elpa:Depends} and provide a Recommends: elpa-async in debian/control. Gbp-Pq: Name 0005-remove-async-dependency.patch
-rw-r--r--helm-core-pkg.el3
-rw-r--r--helm-pkg.el1
2 files changed, 1 insertions, 3 deletions
diff --git a/helm-core-pkg.el b/helm-core-pkg.el
index 98800d28..0cab47ad 100644
--- a/helm-core-pkg.el
+++ b/helm-core-pkg.el
@@ -2,8 +2,7 @@
(define-package "helm-core" "2.3.2"
"Development files for Helm"
- '((emacs "24.4")
- (async "1.9"))
+ '((emacs "24.4"))
:url "https://emacs-helm.github.io/helm/")
;; Local Variables:
diff --git a/helm-pkg.el b/helm-pkg.el
index 5a42ba87..c9a7e6b5 100644
--- a/helm-pkg.el
+++ b/helm-pkg.el
@@ -3,7 +3,6 @@
(define-package "helm" "2.3.2"
"Helm is an Emacs incremental and narrowing framework"
'((emacs "24.4")
- (async "1.9")
(popup "0.5.3")
(helm-core "2.3.2"))
:url "https://emacs-helm.github.io/helm/")