summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-10-17 09:48:48 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-10-17 09:48:48 -0700
commit6ed7ef2f56fb1de511c8a9b2d95dbfbe86aded88 (patch)
tree776cdac3bf80c930da631c626f69de309336235f
parent8d27b0e4d072531fbb94307126095910703c2732 (diff)
remove async dependency
Upstream specifies a dependency on async.el in order to fix installation from MELPA. The Debian installation process avoids the issue. We remove the dependency from ${elpa:Depends} and provide a Recommends: elpa-async in debian/control. Gbp-Pq: Name 0005-remove-async-dependency.patch
-rw-r--r--helm-core-pkg.el3
-rw-r--r--helm-pkg.el1
2 files changed, 1 insertions, 3 deletions
diff --git a/helm-core-pkg.el b/helm-core-pkg.el
index 91690563..532359e0 100644
--- a/helm-core-pkg.el
+++ b/helm-core-pkg.el
@@ -2,8 +2,7 @@
(define-package "helm-core" "2.3.0"
"Development files for Helm"
- '((emacs "24.4")
- (async "1.9"))
+ '((emacs "24.4"))
:url "https://emacs-helm.github.io/helm/")
;; Local Variables:
diff --git a/helm-pkg.el b/helm-pkg.el
index e4f231a9..05cee828 100644
--- a/helm-pkg.el
+++ b/helm-pkg.el
@@ -3,7 +3,6 @@
(define-package "helm" "2.3.0"
"Helm is an Emacs incremental and narrowing framework"
'((emacs "24.4")
- (async "1.9")
(popup "0.5.3")
(helm-core "2.3.0"))
:url "https://emacs-helm.github.io/helm/")