summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-12-04 11:22:54 -0700
committerSean Whitton <spwhitton@spwhitton.name>2016-12-04 11:22:54 -0700
commit9d7729bcffecd51a4b67fda0512163aa51ed2f92 (patch)
treebe48650827ef48e093cc69e83bd20ea742483c17
parentfdf8a2f2f922911814bafd2912e564e5dafd958d (diff)
remove async dependency
Upstream specifies a dependency on async.el in order to fix installation from MELPA. The Debian installation process avoids the issue. We remove the dependency from ${elpa:Depends} and provide a Recommends: elpa-async in debian/control. Gbp-Pq: Name 0005-remove-async-dependency.patch
-rw-r--r--helm-core-pkg.el3
-rw-r--r--helm-pkg.el1
2 files changed, 1 insertions, 3 deletions
diff --git a/helm-core-pkg.el b/helm-core-pkg.el
index 3fcc6947..03a5ce05 100644
--- a/helm-core-pkg.el
+++ b/helm-core-pkg.el
@@ -2,8 +2,7 @@
(define-package "helm-core" "2.3.3"
"Development files for Helm"
- '((emacs "24.4")
- (async "1.9"))
+ '((emacs "24.4"))
:url "https://emacs-helm.github.io/helm/")
;; Local Variables:
diff --git a/helm-pkg.el b/helm-pkg.el
index 33641288..33f0365d 100644
--- a/helm-pkg.el
+++ b/helm-pkg.el
@@ -3,7 +3,6 @@
(define-package "helm" "2.3.3"
"Helm is an Emacs incremental and narrowing framework"
'((emacs "24.4")
- (async "1.9")
(popup "0.5.3")
(helm-core "2.3.3"))
:url "https://emacs-helm.github.io/helm/")