summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThierry Volpiatto <thierry.volpiatto@gmail.com>2017-05-05 13:36:15 +0200
committerThierry Volpiatto <thierry.volpiatto@gmail.com>2017-05-05 13:36:15 +0200
commit5f2c1b596167795fbfbb7fe9952e56922379563a (patch)
tree93b45cb1eacc8e8cfc3be387049bfdb687f7c8df /Makefile
parentb133fb3e8a77b4d476e4b3e3ffd7aff9663506e8 (diff)
Improve makefile.
* Makefile: Test is elpa dir exists.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e0edbf51..99521f99 100644
--- a/Makefile
+++ b/Makefile
@@ -36,6 +36,7 @@ PKGDIR := .
LOADPATH := -L $(PKGDIR)
ELPA_DIR = $(HOME)/.emacs.d/elpa
ASYNC_ELPA_DIR = $(shell \
+ test -d $(ELPA_DIR) && \
find -L $(ELPA_DIR) -maxdepth 1 -regex '.*/async-[.0-9]*' 2> /dev/null | \
sort | tail -n 1)
ifneq "$(ASYNC_ELPA_DIR)" ""