summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorFlorian Bruhin <git@the-compiler.org>2013-08-13 11:13:45 +0200
committerThorsten Wißmann <edu@thorsten-wissmann.de>2013-08-15 12:35:57 +0200
commit10a3e0c30a699f6d8563dc7867a3fa46e588e518 (patch)
tree2f2a6d390ece898598c0fae600b0dd774d26d0e2 /Makefile
parentcd0eb060ef7c6d59460d15fb59a9f21fc5c5034f (diff)
Fix make uninstall
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 8e9bd605..82882996 100644
--- a/Makefile
+++ b/Makefile
@@ -132,7 +132,7 @@ install-nodoc: all-nodoc
uninstall:
@echo "==> deleting files..."
- $(foreach TARGET,$(TARGETS),-$(RM) '$(DESTDIR)$(BINDIR)/$(TARGET)';)
+ -$(foreach TARGET,$(TARGETS),$(RM) '$(DESTDIR)$(BINDIR)/$(TARGET)';)
-$(RM) '$(DESTDIR)$(LICENSEDIR)/LICENSE'
-$(RM) '$(DESTDIR)$(MAN1DIR)/herbstclient.1'
-$(RM) '$(DESTDIR)$(MAN1DIR)/herbstluftwm.1'
@@ -150,7 +150,7 @@ uninstall:
-$(RM) '$(DESTDIR)$(ZSHCOMPLETIONDIR)/_herbstclient'
-$(RM) '$(DESTDIR)$(XSESSIONSDIR)/herbstluftwm.desktop'
-$(RM) '$(DESTDIR)$(EXAMPLESDIR)/README'
- $(foreach SCRIPT,$(wildcard '$(DESTDIR)$(EXAMPLESDIR)/*.sh'),-$(RM) '$(SCRIPT)';)
+ -$(RM) '$(DESTDIR)$(EXAMPLESDIR)'/*.sh
@echo "==> deleting directories..."
-$(RMDIR) '$(EXAMPLESDIR)'
-$(RMDIR) '$(DOCDIR)'