summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThorsten Wißmann <edu@thorsten-wissmann.de>2011-06-26 00:23:45 +0200
committerThorsten Wißmann <edu@thorsten-wissmann.de>2011-06-26 00:24:09 +0200
commit2553c50aa036fe154b0eb82219697aa7f59aa882 (patch)
treea5d5e3233e0053a755ec267165fad390fdf51d7f /Makefile
parentc2ffb96a79212a7f0a9a8b6ffad31e827c9b9a9c (diff)
now also use glib
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f976468b..47e1f5e4 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@ include config.mk
# project
SRCDIR = src
SRC = $(wildcard $(SRCDIR)/*.c)
+HEADER = $(wildcard $(SRCDIR)/*.h)
OBJ = ${SRC:.c=.o}
TARGET = herbstluftwm
@@ -26,7 +27,7 @@ $(TARGET): $(OBJ)
@$(LD) -o $@ $(LDFLAGS) $(OBJ)
-$(SRCDIR)/%.o: $(SRCDIR)/%.c
+$(SRCDIR)/%.o: $(SRCDIR)/%.c $(HEADER)
$(call colorecho,CC,$<)
@$(CC) -c $(CFLAGS) -o $@ $<