summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThorsten Wißmann <edu@thorsten-wissmann.de>2011-10-02 23:01:08 +0200
committerThorsten Wißmann <edu@thorsten-wissmann.de>2011-10-02 23:01:08 +0200
commit5110e71e347faf547091dd602f58e481503a8afa (patch)
tree1578e3dd247f7a89933bc7cdea98b4ed4acbcecb /Makefile
parentf86425f8cdb8d95f395e22ee83b7ad64f7b00179 (diff)
added make tar that creates source tarball
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 08850640..a0ca17c3 100644
--- a/Makefile
+++ b/Makefile
@@ -36,6 +36,9 @@ clean-herbstclient:
doc: doc/herbstclient.1 doc/herbstclient.html doc/herbstluftwm.1 doc/herbstluftwm.html
+tar:
+ tar -czf $(TARFILE) `git ls-files`
+
doc/%.1: doc/%.txt
$(call colorecho,DOC,$@)
@a2x -f manpage -a "herbstluftwmversion=herbstluftwm $(VERSION)" -a "date=`date +%Y-%m-%d`" $<