summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThorsten Wißmann <edu@thorsten-wissmann.de>2011-07-30 22:56:49 +0200
committerThorsten Wißmann <edu@thorsten-wissmann.de>2011-07-30 22:56:49 +0200
commit6e7a2695120414d124811af1286760c84b1736ae (patch)
treef598afdb20bd9394eae824a1d73f56c2a35f4308 /Makefile
parentd0ea9498ced774060f5f9ff229d2511688ddb31a (diff)
make: also install LICENSE and BUGS
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 221fc4e8..3b1b2a84 100644
--- a/Makefile
+++ b/Makefile
@@ -42,6 +42,7 @@ doc/%.html: doc/%.txt
install: all
@echo creating dirs...
mkdir -p $(PREFIX)
+ mkdir -p $(LICENSEDIR)
mkdir -p $(BINDIR)
mkdir -p $(MANDIR)
mkdir -p $(DOCDIR)
@@ -51,10 +52,12 @@ install: all
@echo copyiing files...
install $(TARGET) $(BINDIR)
install ipc-client/herbstclient $(BINDIR)/
+ install LICENSE $(LICENSEDIR)
install doc/herbstclient.1 $(MANDIR)/
install doc/herbstluftwm.1 $(MANDIR)/
install doc/herbstclient.html $(DOCDIR)/
install doc/herbstluftwm.html $(DOCDIR)/
+ install BUGS $(DOCDIR)/
install share/herbstluftrc $(CONFIGDIR)/
install share/herbstclient-completion $(ETCDIR)/bash_completion.d/