summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThorsten Wißmann <edu@thorsten-wissmann.de>2011-07-22 19:46:08 +0200
committerThorsten Wißmann <edu@thorsten-wissmann.de>2011-07-22 19:46:08 +0200
commit80e3b6f1c780ed77459422874a29d89163dc6682 (patch)
tree438679f685022284e165efebfebbd68524c9eabc /Makefile
parent92c54e1dadc64a3889a273d5e83130b1c18be39d (diff)
some Makefile refactoring
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile32
1 files changed, 1 insertions, 31 deletions
diff --git a/Makefile b/Makefile
index 47e1f5e4..38ce1224 100644
--- a/Makefile
+++ b/Makefile
@@ -8,35 +8,5 @@ HEADER = $(wildcard $(SRCDIR)/*.h)
OBJ = ${SRC:.c=.o}
TARGET = herbstluftwm
-# colors
-COLOR_ACTION = "\e[1;33m"
-COLOR_FILE = "\e[1;32m"
-COLOR_BRACKET = "\e[0;34m"
-COLOR_NORMAL = "\e[0m"
-define colorecho
- @echo -e $(COLOR_BRACKET)" ["$(COLOR_ACTION)$1$(COLOR_BRACKET)"] " $(COLOR_FILE)$2$(COLOR_BRACKET)... $(COLOR_NORMAL)
-endef
-
-
-all: $(TARGET)
-
-rb: clean all
-
-$(TARGET): $(OBJ)
- $(call colorecho,LD,$(TARGET))
- @$(LD) -o $@ $(LDFLAGS) $(OBJ)
-
-
-$(SRCDIR)/%.o: $(SRCDIR)/%.c $(HEADER)
- $(call colorecho,CC,$<)
- @$(CC) -c $(CFLAGS) -o $@ $<
-
-
-clean:
- $(call colorecho,RM,$(TARGET))
- @rm -f $(TARGET)
- $(call colorecho,RM,$(OBJ))
- @rm -f $(OBJ)
-
-.PHONY: all clean rb
+include rules.mk