summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThorsten Wißmann <edu@thorsten-wissmann.de>2012-09-10 02:08:45 +0200
committerThorsten Wißmann <edu@thorsten-wissmann.de>2012-09-10 02:12:05 +0200
commit8d7a6a48cbed8a9817b81afabdb908975134c97c (patch)
tree91fa3788599f4df114fd55691ee9418755cd04e9 /Makefile
parentd81c4b971ad9a8db114553be6532054b4a49c3ab (diff)
Add a herbstluftwm tutorial
This adds a herbstluftwm tutorial, already describing: - The Installation - The basic configuration with herbstclient
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 5b311649..e26e7526 100644
--- a/Makefile
+++ b/Makefile
@@ -17,6 +17,7 @@ DEPS = $(OBJ:.o=.d)
HERBSTCLIENTDOC = doc/herbstclient.txt
HERBSTLUFTWMDOC = doc/herbstluftwm.txt
+TUTORIAL = doc/herbstluftwm-tutorial.txt
.PHONY: depend all all-nodoc doc install info www
.PHONY: cleandoc cleanwww cleandeps clean
@@ -62,11 +63,17 @@ cleandoc:
$(VERBOSE) rm -f doc/herbstluftwm.1
$(call colorecho,RM,doc/herbstluftwm.html)
$(VERBOSE) rm -f doc/herbstluftwm.html
+ $(call colorecho,RM,doc/herbstluftwm-tutorial.7)
+ $(VERBOSE) rm -f doc/herbstluftwm-tutorial.7
+ $(call colorecho,RM,doc/herbstluftwm-tutorial.html)
+ $(VERBOSE) rm -f doc/herbstluftwm-tutorial.html
doc: doc/herbstclient.1 \
doc/herbstclient.html \
doc/herbstluftwm.1 \
- doc/herbstluftwm.html
+ doc/herbstluftwm.html \
+ doc/herbstluftwm-tutorial.7 \
+ doc/herbstluftwm-tutorial.html
tar: doc
tar -czf $(TARFILE) `git ls-files` doc/*.html doc/*.[0-9]
@@ -76,7 +83,7 @@ tar: doc
tar -czf $(TARFILE) $(TMPTARDIR)
rm -rf $(TMPTARDIR)
-doc/%.1: doc/%.txt version.mk
+doc/%.1 doc/%.7: doc/%.txt version.mk
$(call colorecho,DOC,$@)
$(VERBOSE) $(A2X) -f manpage -a "herbstluftwmversion=herbstluftwm $(VERSION)" -a "date=`date +%Y-%m-%d`" $<