summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThorsten Wißmann <re06huxa@stud.informatik.uni-erlangen.de>2012-01-25 13:01:28 +0100
committerThorsten Wißmann <re06huxa@stud.informatik.uni-erlangen.de>2012-01-25 13:01:50 +0100
commit9caaba14e77da2acf73f2e449363609b1ea41321 (patch)
tree076d2d18c7e5aaf540dd9928af845c4d0f1877bc /Makefile
parent5d99b52b37f0f63073c7c2f64fcd2beade4bcb74 (diff)
tarball now contains a directory of files
Now no files are in the root directory of the tarball anymore.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5ed34fe0..3878e1e3 100644
--- a/Makefile
+++ b/Makefile
@@ -39,6 +39,12 @@ doc: doc/herbstclient.1 doc/herbstclient.html doc/herbstluftwm.1 doc/herbstluftw
tar: doc
tar -czf $(TARFILE) `git ls-files` doc/*.html doc/*.[0-9]
+ rm -rf $(TMPTARDIR)
+ mkdir -p $(TMPTARDIR)
+ tar -xvf $(TARFILE) -C $(TMPTARDIR)
+ tar -czf $(TARFILE) $(TMPTARDIR)
+ rm -rf $(TMPTARDIR)
+
doc/%.1: doc/%.txt
$(call colorecho,DOC,$@)