summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChristoph Egger <christoph@debian.org>2016-02-08 22:20:48 +0100
committerChristoph Egger <christoph@debian.org>2016-02-08 22:20:48 +0100
commita00c6531e911ed7c0fa711843e3ef428489ce70c (patch)
tree79a42e22297ea374fbe1e42553d13cadfad3275f /Makefile
parent03c24961fb1b9e6b238a531017746bd1dbc453ba (diff)
Imported Upstream version 0.6.2
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 82882996..43ac860c 100644
--- a/Makefile
+++ b/Makefile
@@ -28,7 +28,7 @@ $(HCTARGET): $(HCOBJ)
$(TARGETS):
$(call colorecho,LD,$@)
- $(VERBOSE) $(LD) -o $@ $(LDFLAGS) $^ $(LIBS)
+ $(VERBOSE) $(LD) -o $@ $(CFLAGS) $(LDFLAGS) $^ $(LIBS)
-include $(DEPS)
@@ -152,9 +152,9 @@ uninstall:
-$(RM) '$(DESTDIR)$(EXAMPLESDIR)/README'
-$(RM) '$(DESTDIR)$(EXAMPLESDIR)'/*.sh
@echo "==> deleting directories..."
- -$(RMDIR) '$(EXAMPLESDIR)'
- -$(RMDIR) '$(DOCDIR)'
- -$(RMDIR) '$(CONFIGDIR)'
+ -$(RMDIR) '$(DESTDIR)$(EXAMPLESDIR)/'
+ -$(RMDIR) '$(DESTDIR)$(DOCDIR)/'
+ -$(RMDIR) '$(DESTDIR)$(CONFIGDIR)/'
www:
make -C www