summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorHans-Peter Deifel <hpdeifel@gmx.de>2012-05-30 01:22:45 +0200
committerThorsten Wißmann <re06huxa@stud.informatik.uni-erlangen.de>2012-06-01 09:52:52 +0200
commit1c29ce143e5d7c8460aefd86cee7f119b23e2c0d (patch)
treec4872c7598efacde41d530c19bccc721f067fe29 /config.mk
parenta4934f2c62a1f53d98fcceb6b36a2034e3e358dd (diff)
Use CFLAGS and LDFLAGS from the environment for compiling
Some CFLAGS are still required (such as -std=c99), but others can now be overridden (such as -g).
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/config.mk b/config.mk
index 94529bf8..faa5edeb 100644
--- a/config.mk
+++ b/config.mk
@@ -13,13 +13,14 @@ endif
# FLAGS
CC ?= gcc
LD = $(CC)
-CFLAGS = -g -std=c99 -pedantic -Wall ${INCS} -D _XOPEN_SOURCE=600
+CFlAGS ?= -g -pedantic -Wall
+CFLAGS += -std=c99 ${INCS} -D _XOPEN_SOURCE=600
VERSIONFLAGS = \
-D HERBSTLUFT_VERSION=$(VERSION) \
-D HERBSTLUFT_VERSION_MAJOR=$(VERSION_MAJOR) \
-D HERBSTLUFT_VERSION_MINOR=$(VERSION_MINOR)
CFLAGS += $(VERSIONFLAGS)
-LDFLAGS = -g
+LDFLAGS ?= -g
INSTALLDIR = /
PREFIX = $(INSTALLDIR)/usr/
BINDIR = $(PREFIX)/bin