summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorChristoph Egger <christoph@debian.org>2012-08-19 01:29:07 +0200
committerThorsten Wißmann <edu@thorsten-wissmann.de>2012-08-19 01:29:38 +0200
commit277587f5824763d9431e5485cdc795c9b662a50c (patch)
tree740ea986812ff083f45cb59cf6c6b140cd6096fc /config.mk
parent644de845738820fc437ffcd44db654564d03afe2 (diff)
Honor CPPFLAGS
As the C Preprocessor is never called separately just add CPPFLAGS to CFLAGS at the beginning of the Makefile so they get passed to all compiler calls.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/config.mk b/config.mk
index 4d3ae303..0359ed23 100644
--- a/config.mk
+++ b/config.mk
@@ -19,6 +19,7 @@ CC ?= gcc
LD = $(CC)
CFLAGS ?= -g -pedantic -Wall
CFLAGS += -std=c99 ${INCS} -D _XOPEN_SOURCE=600
+CFLAGS += $(CPPFLAGS)
VERSIONFLAGS = \
-D HERBSTLUFT_VERSION=$(VERSION) \
-D HERBSTLUFT_VERSION_MAJOR=$(VERSION_MAJOR) \