summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorHans-Peter Deifel <hpdeifel@gmx.de>2012-05-30 02:35:01 +0200
committerThorsten Wißmann <re06huxa@stud.informatik.uni-erlangen.de>2012-06-01 09:57:46 +0200
commit7b8dd3dc169c4d0e8f16b84f018b05b3370d27bc (patch)
tree81dc5baef178121616419d0f2d7a531fb9557045 /config.mk
parent51106de4445db30e4a99f178a2c3d16029042556 (diff)
Autotoolify the Makefile
Let the Makefile behave more like the infamous GNU-Autotools. Specifically, the following has changed: - INSTALLDIR is now called DESTDIR - PREFIX is an absolute path and not relative to DESTDIR. The reason for this is that DESTDIR is solely used for installing (for example by gentoos portage, which first install into a temporary directory), while PREFIX and the other variables specify final paths, that can also be included in the application itself or the documentation. - PREFIX is now /usr/local instead of /usr - SHAREDIR is now DATADIR - MANDIR changed from $(DATADIR)/man/man1 to $(DATADIR)/man. - There is now a MAN1DIR. - LICENSEDIR is now set to $(DOCDIR) by default - ETCDIR is now SYSCONFDIR - bash completion is now installed in $(BASHCOMPLETIONDIR)
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk23
1 files changed, 12 insertions, 11 deletions
diff --git a/config.mk b/config.mk
index cfea6548..0c01f95c 100644
--- a/config.mk
+++ b/config.mk
@@ -21,19 +21,20 @@ VERSIONFLAGS = \
-D HERBSTLUFT_VERSION_MINOR=$(VERSION_MINOR)
CFLAGS += $(VERSIONFLAGS)
LDFLAGS ?= -g
-INSTALLDIR = /
-PREFIX = $(INSTALLDIR)/usr/
+DESTDIR = /
+PREFIX = /usr/local
BINDIR = $(PREFIX)/bin
-SHAREDIR = $(PREFIX)/share
-MANDIR = $(SHAREDIR)/man/man1
-DOCDIR = $(SHAREDIR)/doc/herbstluftwm
+DATADIR = $(PREFIX)/share
+MANDIR = $(DATADIR)/man
+MAN1DIR = $(MANDIR)/man1
+DOCDIR = $(DATADIR)/doc/herbstluftwm
EXAMPLESDIR = $(DOCDIR)/examples
-LICENSEDIR = $(SHAREDIR)/licenses/herbstluftwm
-ETCDIR = $(INSTALLDIR)/etc/
-CONFIGDIR = $(ETCDIR)/xdg/herbstluftwm/
-XSESSIONSDIR = $(SHAREDIR)/xsessions
-ZSHCOMPLETIONDIR = $(SHAREDIR)/zsh/functions/Completion/X/
-BASHCOMPLETIONDIR = $(ETCDIR)/bash_completion.d/
+LICENSEDIR = $(DOCDIR)
+SYSCONFDIR = /etc
+CONFIGDIR = $(SYSCONFDIR)/xdg/herbstluftwm
+XSESSIONSDIR = $(DATADIR)/xsessions
+ZSHCOMPLETIONDIR = $(DATADIR)/zsh/functions/Completion/X/
+BASHCOMPLETIONDIR = $(SYSCONFDIR)/bash_completion.d/
TARFILE = herbstluftwm-$(VERSION_MAJOR).$(VERSION_MINOR)$(VERSION_SUFFIX).tar.gz
A2X = a2x
ASCIIDOC = asciidoc