summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorHans-Peter Deifel <hpdeifel@gmx.de>2012-05-30 01:16:02 +0200
committerThorsten Wißmann <re06huxa@stud.informatik.uni-erlangen.de>2012-06-01 09:52:52 +0200
commita4934f2c62a1f53d98fcceb6b36a2034e3e358dd (patch)
tree827e107e3b2153963b8a2ca98ebbdbabe612d304 /config.mk
parent40ce02cbbbf52163e64df0cccbb8fb4bcd34758c (diff)
Use CC from the environment for compiling
The Makefile now uses ${CC} defined in the environment if it's defined, and only falls back to gcc otherwise. Note: ${LD} is not used, but instead initialized to $(CC) in the Makefile, since it's rare that one wants to use a separate linker these days and it's also very likely to break.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/config.mk b/config.mk
index 0ebd21d8..94529bf8 100644
--- a/config.mk
+++ b/config.mk
@@ -11,8 +11,8 @@ LIBS += -lrt
endif
# FLAGS
-LD = gcc
-CC = gcc
+CC ?= gcc
+LD = $(CC)
CFLAGS = -g -std=c99 -pedantic -Wall ${INCS} -D _XOPEN_SOURCE=600
VERSIONFLAGS = \
-D HERBSTLUFT_VERSION=$(VERSION) \