summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorChristoph Egger <christoph@debian.org>2016-02-08 22:20:48 +0100
committerChristoph Egger <christoph@debian.org>2016-02-08 22:20:48 +0100
commita00c6531e911ed7c0fa711843e3ef428489ce70c (patch)
tree79a42e22297ea374fbe1e42553d13cadfad3275f /www
parent03c24961fb1b9e6b238a531017746bd1dbc453ba (diff)
Imported Upstream version 0.6.2
Diffstat (limited to 'www')
-rw-r--r--www/.gitignore1
-rw-r--r--www/Makefile35
-rwxr-xr-xwww/compose.py131
-rwxr-xr-xwww/compose.sh101
-rw-r--r--www/download.txt50
-rw-r--r--www/faq.txt7
-rw-r--r--www/footer.txt6
-rw-r--r--www/header.txt8
-rw-r--r--www/herbstclient.txt1
-rw-r--r--www/herbstluftwm.txt1
-rw-r--r--www/index.txt72
-rwxr-xr-xwww/install.sh14
-rw-r--r--www/main.css134
-rw-r--r--www/migration.txt1
-rw-r--r--www/tutorial.txt1
15 files changed, 314 insertions, 249 deletions
diff --git a/www/.gitignore b/www/.gitignore
index d5edc6c1..f7e13931 100644
--- a/www/.gitignore
+++ b/www/.gitignore
@@ -3,3 +3,4 @@
*.png
*.jpeg
*.jpg
+herbstluftwm.svg
diff --git a/www/Makefile b/www/Makefile
index 7b7c0b0c..d638160d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -5,31 +5,40 @@ include ../colors.mk
.PHONY: all clean install
-TARGET = cip:wwwcip/herbstluftwm/
+TARGET = herbstluftwm.org:www/
+
ASCIIDOCFLAGS = -s
TXT = $(wildcard *.txt)
+INSTALLFILES = $(TXT:.txt=.html) \
+ herbstluftwm.html \
+ herbstclient.html \
+ herbstluftwm.svg \
+ main.css
-all: $(TXT:.txt=.html) herbstluftwm.html herbstclient.html
+all: $(INSTALLFILES)
%-content.html: %.txt
$(call colorecho,DOC,$@)
$(ASCIIDOC) $(ASCIIDOCFLAGS) -o $@ $<
-%.html: %-content.html compose.sh
- ./compose.sh $< > $@
-
-herbstluftwm-content.html: ../doc/herbstluftwm.txt
- $(call colorecho,DOC,$@)
- @$(ASCIIDOC) $(ASCIIDOCFLAGS) -o $@ $<
+%.html: %-content.html compose.py
+ ./compose.py $< > $@
-herbstclient-content.html: ../doc/herbstclient.txt
- $(call colorecho,DOC,$@)
- @$(ASCIIDOC) $(ASCIIDOCFLAGS) -o $@ $<
+herbstluftwm.svg: ../share/herbstluftwm.svg
+ cp $^ $@
news.html: ../NEWS
+migration.html: ../MIGRATION
+
+herbstluftwm.html: ../doc/herbstluftwm.txt
+
+herbstclient.html: ../doc/herbstclient.txt
+
+tour.html: ../doc/herbstluftwm-tutorial.txt
+
clean:
rm -f *.html *-content.html
-install:
- @echo scp index.html main.css $(TARGET)
+install: all
+ rsync -v $(INSTALLFILES) $(TARGET)
diff --git a/www/compose.py b/www/compose.py
new file mode 100755
index 00000000..1ca9d159
--- /dev/null
+++ b/www/compose.py
@@ -0,0 +1,131 @@
+#! /usr/bin/env python2
+
+import sys
+import datetime
+import types
+from collections import OrderedDict
+
+tabs = OrderedDict([
+ ("Overview", OrderedDict([
+ ("index",""),
+ ])),
+ ("Documentation", OrderedDict([
+ ("news", "News"),
+ ("migration", "Migration"),
+ ("tutorial", "Tutorial"),
+ ("herbstluftwm", "herbstluftwm(1)"),
+ ("herbstclient", "herbstclient(1)"),
+ ])),
+ ("FAQ", OrderedDict([
+ ("faq", "FAQ"),
+ ])),
+ ("Download", OrderedDict([
+ ("download", "Download"),
+ ])),
+ ("Wiki", "http://wiki.herbstluftwm.org"),
+])
+
+page2tab = {}
+
+filename = sys.argv[1]
+name = filename.replace('-content.html', '')
+
+windowtitle = "herbstluftwm"
+for title, subpages in tabs.iteritems():
+ if not isinstance(subpages, basestring):
+ for fn, subtitle in subpages.iteritems():
+ page2tab[fn] = title
+ if not ("" == subtitle) and (name == fn):
+ windowtitle = subtitle + " - herbstluftwm"
+
+
+curtab = page2tab[name]
+
+#====~===~=========~==
+# Header
+#====~===~=========~==
+print """\
+<html>
+ <head>
+ <link rel="stylesheet" href="main.css" type="text/css" />
+ <meta http-equiv="Content-Type" content="application/xhtml+xml; charset=UTF-8" />
+ <title>{title}</title>
+ </head>
+ <body>
+ <div id="frame">
+ <div id="header">
+ <div id="logoname">
+ <img id="icon" src="herbstluftwm.svg"/>
+ <div id="squeezeheader">
+ <h1>herbstluftwm</h1>
+ <div id="subheader">
+ a manual tiling window manager for X
+ </div>
+ </div>
+ </div>
+ </div>""".format(title=windowtitle)
+
+#====~===~=========~==
+# Navigation bar
+#====~===~=========~==
+
+print """\
+ <ul id="navigationbar">"""
+
+for title, subpages in tabs.iteritems():
+ classstring = "notab"
+ if title == curtab:
+ classstring = "curtab"
+ if isinstance(subpages, basestring):
+ trg = subpages
+ else:
+ trg = subpages.keys()[0] + ".html"
+ print '<li class="{cls}"><a href="{target}">{title}</a></li>'.format(
+ cls = classstring,
+ target = trg,
+ title = title)
+
+
+print """\
+ </ul>\
+ <div class="tabbarseparator"></div>
+"""
+
+subpages = tabs[page2tab[name]]
+
+if len(subpages) > 1:
+ print '<div class="subpagebar">'
+ for basename, title in subpages.iteritems():
+ if basename == name:
+ cls = "subpagecur subpage"
+ else:
+ cls = "subpage"
+ print '<span class="{cls}">'.format(cls = cls)
+ print '<a href="{url}">{title}</a></span>'.format(
+ url = basename + ".html",title = title)
+ print "</div>"
+
+print """\
+ <div id="content">\
+"""
+
+print open(filename).read()
+
+
+print """\
+ <div class="footer">
+ Generated on {date}
+ </div>
+""".format(date=datetime.datetime.now().strftime('%Y-%m-%d at %H:%M:%S %Z'))
+
+#====~===~=========~==
+# Footer
+#====~===~=========~==
+print """\
+ </div>
+ </div>
+ </body>
+</html>
+"""
+
+# vim: noet
diff --git a/www/compose.sh b/www/compose.sh
deleted file mode 100755
index f1b66321..00000000
--- a/www/compose.sh
+++ /dev/null
@@ -1,101 +0,0 @@
-#!/bin/bash
-
-# usage: $0 A
-# composes a content file A by adding a header and a footer
-
-file="$1"
-id="${file%-content.html}"
-
-prefix="herbstluftwm - "
-
-# titles that are shown in <title>
-declare -A id2title
-id2title=(
- ["index"]="herbstluftwm"
- ["news"]="${prefix}NEWS"
- ["faq"]="${prefix}FAQ"
- ["herbstluftwm"]="herbstluftwm(1)"
- ["herbstclient"]="herbstclient(1)"
-)
-
-# how names are shown in the navigation bar
-declare -A id2name
-id2name=(
- ["index"]="Home"
- ["news"]="NEWS"
- ["faq"]="FAQ"
- ["herbstluftwm"]="herbstluftwm(1)"
- ["herbstclient"]="herbstclient(1)"
-)
-
-navigationbar=( index news herbstluftwm herbstclient faq )
-
-title=${id2title[$id]}
-
-#====~===~=========~==
-# Header
-#====~===~=========~==
-cat <<EOF
-<html>
- <head>
- <link rel="stylesheet" href="main.css" type="text/css" />
- <meta http-equiv="Content-Type" content="application/xhtml+xml; charset=UTF-8" />
- <title>$title</title>
- </head>
- <body>
- <div id="frame">
- <div id="header">
- <h1>herbstluftwm</h1>
- <div id="subheader">
- a manual tiling window manager for X
- </div>
- </div>
-EOF
-
-#====~===~=========~==
-# Navigation bar
-#====~===~=========~==
-
-cat <<EOF
- <table width="100%" id="navigationbar" cellspacing="0">
- <tr>
-EOF
-for i in "${navigationbar[@]}" ; do
- name="${id2name[$i]:-$i}"
- [ "$id" = "$i" ] && current=' class="curtab"' || current=' class="notab"'
- cat <<EOF
- <td class="notab spacing">&nbsp</td>
- <td${current}><a href="$i.html">$name</a></td>
-EOF
-done
-cat <<EOF
- <td class="notab spacing">&nbsp</td>
- <td class="notab"><a href="http://wiki.herbstluftwm.org">Wiki</a></td>
-EOF
-cat <<EOF
- <td class="notab spacing">&nbsp</td>
- </tr>
- </table>
-EOF
-
-#====~===~=========~==
-# Content
-#====~===~=========~==
-cat <<EOF
- <div id="content">
-EOF
-cat "$file" - <<EOF
- <div class="footer">
- Generated on $(date +'%Y-%m-%d at %H:%M:%S %Z').
- </div>
-EOF
-
-#====~===~=========~==
-# Footer
-#====~===~=========~==
-cat <<EOF
- </div>
- </div>
- </body>
-</html>
-EOF
diff --git a/www/download.txt b/www/download.txt
new file mode 100644
index 00000000..59b7a76c
--- /dev/null
+++ b/www/download.txt
@@ -0,0 +1,50 @@
+Get it!
+-------
+Install herbstluftwm via your package manager! It is currently available on the
+following platforms:
+
+ * Arch Linux via the
+ link:https://aur.archlinux.org/packages.php?O=0&K=herbstluftwm[Arch User
+ Repository]
+ * link:http://packages.debian.org/search?keywords=herbstluftwm[Debian]
+ * link:http://packages.gentoo.org/package/x11-wm/herbstluftwm[Gentoo Linux]
+ * Mac OS X via
+ link:http://trac.macports.org/browser/trunk/dports/x11/herbstluftwm/Portfile[MacPorts]
+ * FreeBSD
+ * Ubuntu Linux
+ * link:https://apps.fedoraproject.org/packages/herbstluftwm[Fedora]
+ * link:http://www.openbsd.org/cgi-bin/cvsweb/ports/x11/herbstluftwm/[OpenBSD]
+
+It's confirmed to run on:
+
+ * Cygwin
+ * Many other Linux distributions
+
+If your distribution is not supported you can build a package on your own using
+the most current released tarball:
+
+[options="header"]
+|==========================================================================================================
+| Version | Date | link:tarballs/MD5SUMS[MD5SUMS] | Tarball
+| 0.1 | 2011-10-02 | 284067728e56f... | link:tarballs/herbstluftwm-0.1.tar.gz[tar.gz]
+| 0.2 | 2012-01-25 | 1628f236a7086... | link:tarballs/herbstluftwm-0.2.tar.gz[tar.gz]
+| 0.3 | 2012-04-12 | 176b82a7b5881... | link:tarballs/herbstluftwm-0.3.tar.gz[tar.gz]
+| 0.4 | 2012-08-18 | 698b43bde76f9... | link:tarballs/herbstluftwm-0.4.tar.gz[tar.gz]
+| 0.4.1 | 2012-08-30 | 2cf235dd9e0c4... | link:tarballs/herbstluftwm-0.4.1.tar.gz[tar.gz]
+| 0.5.0 | 2012-12-31 | ed28cc9d89d5f... | link:tarballs/herbstluftwm-0.5.0.tar.gz[tar.gz]
+| 0.5.1 | 2013-01-05 | c6ea924d947df... | link:tarballs/herbstluftwm-0.5.1.tar.gz[tar.gz]
+| 0.5.2 | 2013-06-23 | 4cbbe35ac3627... | link:tarballs/herbstluftwm-0.5.2.tar.gz[tar.gz]
+| 0.5.3 | 2013-12-24 | 8b7f430c85d22... | link:tarballs/herbstluftwm-0.5.3.tar.gz[tar.gz]
+| 0.6.0 | 2014-03-19 | c62caa0c67a25... | link:tarballs/herbstluftwm-0.6.0.tar.gz[tar.gz]
+| 0.6.1 | 2014-03-25 | c385fe9e68876... | link:tarballs/herbstluftwm-0.6.1.tar.gz[tar.gz]
+// do not remove this: next version line will be added here
+|==========================================================================================================
+
+The current development version is available in the
+link:http://git.informatik.uni-erlangen.de/?p=re06huxa/herbstluftwm[GitWeb]
+or can be cloned with:
+
+----
+git clone git://git.informatik.uni-erlangen.de/re06huxa/herbstluftwm
+----
+
diff --git a/www/faq.txt b/www/faq.txt
index bd34644b..4df8a1b9 100644
--- a/www/faq.txt
+++ b/www/faq.txt
@@ -202,7 +202,7 @@ Q: How can I start external panels correctly?::
panel needs 31 pixels at the bottom of monitor 0):
+
----
-# add a external panel
+# add an external panel
{
pids=( )
# reserve some space for the panel on monitor 0
@@ -221,5 +221,6 @@ Q: How can I start external panels correctly?::
----
Q: I'm using a compositing manager like xcompmgr and get ugly artifacts when switching tags or splitting frames::
- You probably have +frame_bg_transparent+ enabled. Disable this setting and
- use +frame_active_opacity+ and/or +frame_normal_opacity+ instead.
+ You probably have an old version of herbstluftwm and +frame_bg_transparent+
+ enabled. Disable this setting and use +frame_active_opacity+ and/or
+ +frame_normal_opacity+ instead or upgrade to the current git version.
diff --git a/www/footer.txt b/www/footer.txt
deleted file mode 100644
index f9a2a655..00000000
--- a/www/footer.txt
+++ /dev/null
@@ -1,6 +0,0 @@
-
-Imprint
--------
-Thorsten Wißmann,
-+edu \_at_ thorsten \_minus_ wissmann \_dot_ de+,
-November 2011-2012
diff --git a/www/header.txt b/www/header.txt
deleted file mode 100644
index c9390cf6..00000000
--- a/www/header.txt
+++ /dev/null
@@ -1,8 +0,0 @@
-Herbstluftwm
-============
-
-****
-link:index.html[About]
-link:news.html[NEWS]
-link:faq.html[FAQ]
-****
diff --git a/www/herbstclient.txt b/www/herbstclient.txt
new file mode 100644
index 00000000..c2aff33b
--- /dev/null
+++ b/www/herbstclient.txt
@@ -0,0 +1 @@
+include::../doc/herbstclient.txt[]
diff --git a/www/herbstluftwm.txt b/www/herbstluftwm.txt
new file mode 100644
index 00000000..345fd49c
--- /dev/null
+++ b/www/herbstluftwm.txt
@@ -0,0 +1 @@
+include::../doc/herbstluftwm.txt[]
diff --git a/www/index.txt b/www/index.txt
index 9b2899fd..6210ed9e 100644
--- a/www/index.txt
+++ b/www/index.txt
@@ -20,75 +20,35 @@ Its main features can be described with:
link:http://wmii.suckless.org/[wmii]/
link:http://aerosuidae.net/musca.html[musca])
-Get it!
--------
-Install herbstluftwm via your package manager! It is currently available on the
-following platforms:
-
- * Arch Linux via the
- link:https://aur.archlinux.org/packages.php?O=0&K=herbstluftwm[Arch User
- Repository]
- * Debian (0.3 in
- link:http://packages.debian.org/squeeze-backports/herbstluftwm[squeeze-backports],
- link:http://packages.debian.org/wheezy/herbstluftwm[wheezy],
- 0.5.1 on all link:http://packages.debian.org/sid/herbstluftwm[sid
- architectures (including Hurd)])
- * link:http://packages.gentoo.org/package/x11-wm/herbstluftwm[Gentoo Linux]
- * Mac OS X via
- link:http://trac.macports.org/browser/trunk/dports/x11/herbstluftwm/Portfile[MacPorts]
- * FreeBSD
- * 0.3 on Ubuntu Linux via
- link:https://launchpad.net/ubuntu/+source/herbstluftwm[Launchpad]
-
-It's confirmed to run on:
-
- * Cygwin
- * OpenBSD
- * Many other Linux distributions
-
-If your distribution is not supported you can build a package on your own using
-the most current released tarball:
-
-[options="header"]
-|==========================================================================================================
-| Version | Date | link:tarballs/MD5SUMS[MD5SUMS] | Tarball
-| 0.1 | 2011-10-02 | 284067728e56f... | link:tarballs/herbstluftwm-0.1.tar.gz[tar.gz]
-| 0.2 | 2012-01-25 | 1628f236a7086... | link:tarballs/herbstluftwm-0.2.tar.gz[tar.gz]
-| 0.3 | 2012-04-12 | 176b82a7b5881... | link:tarballs/herbstluftwm-0.3.tar.gz[tar.gz]
-| 0.4 | 2012-08-18 | 698b43bde76f9... | link:tarballs/herbstluftwm-0.4.tar.gz[tar.gz]
-| 0.4.1 | 2012-08-30 | 2cf235dd9e0c4... | link:tarballs/herbstluftwm-0.4.1.tar.gz[tar.gz]
-| 0.5.0 | 2012-12-31 | ed28cc9d89d5f... | link:tarballs/herbstluftwm-0.5.0.tar.gz[tar.gz]
-| 0.5.1 | 2013-01-05 | c6ea924d947df... | link:tarballs/herbstluftwm-0.5.1.tar.gz[tar.gz]
-| 0.5.2 | 2013-06-23 | 4cbbe35ac3627... | link:tarballs/herbstluftwm-0.5.2.tar.gz[tar.gz]
-// do not remove this: next version line will be added here
-|==========================================================================================================
-
-The current development version is available in the
-link:http://git.informatik.uni-erlangen.de/?p=re06huxa/herbstluftwm[GitWeb]
-or can be cloned with:
+How to get it?
+--------------
+Install it via the package manager, link:download.html[download tarballs], or
+clone the git repository:
----
-git clone git://git.informatik.uni-erlangen.de/re06huxa/herbstluftwm
+git clone git://git.cs.fau.de/hlwm
----
-Documentation
--------------
-There are manpages in the +doc/+ directory. They also can be seen online:
+How to use it?
+---------------
+If you are new to herbstluftwm, the link:tutorial.html[tutorial] is the best
+place to start.
- * link:herbstluftwm.html[herbstluftwm]
- * link:herbstclient.html[herbstclient]
+There are manpages for link:herbstluftwm.html[herbstluftwm] and
+link:herbstclient.html[herbstclient] in the +doc/+ directory. They also can be
+seen link:herbstluftwm.html[online].
Support
-------
-Feel free to join the IRC channel +#herbstluftwm+ on +irc.freenode.net+.
+You are welcome to join the IRC channel +#herbstluftwm+ on +irc.freenode.net+.
For further bug reporting or patch submission contact the mailing list:
----
-herbstluftwm-devel@lists.sourceforge.net
+hlwm@lists.herbstluftwm.org
----
You can subscribe by sending a mail with the subject +subscribe+ to
-+herbstluftwm-devel-request@lists.sourceforge.net+ or by using the
-link:https://lists.sourceforge.net/lists/listinfo/herbstluftwm-devel[Mailman
++hlwm-request@lists.herbstluftwm.org+ or by using the
+link:https://lists.schokokeks.org/mailman/listinfo.cgi/hlwm[Mailman
web interface].
Screenshots
diff --git a/www/install.sh b/www/install.sh
deleted file mode 100755
index 0e48265c..00000000
--- a/www/install.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/bash
-
-# USAGE:
-# $0 [TARGET]
-
-# target directory, you propably have to parse the right directory to it ;)
-target=${1:-cip:.www/herbstluftwm}
-
-files=(
- *.html
- main.css
-)
-
-rsync -v "${files[@]}" "$target"
diff --git a/www/main.css b/www/main.css
index 6b3e4f6d..39db9330 100644
--- a/www/main.css
+++ b/www/main.css
@@ -1,5 +1,5 @@
body {
- background-color: #66770A;
+ background-color: #FFD694;
padding: 10px;
margin: 0px;
}
@@ -9,57 +9,45 @@ body {
margin-right: auto;
margin-top: 0.5em;
margin-bottom: 2em;
- border: 0px solid #555753;
width: 90%; max-width: 70em;
- -moz-box-shadow: 0px 0px 5px 5px rgba(0,0,0,0.5);
- -webkit-box-shadow: 0px 0px 5px 5px rgba(0,0,0,0.5);
- box-shadow: 0px 0px 5px 5px rgba(0,0,0,0.5);
}
-#navigationbar .curtab {
- border-top-left-radius: 5px;
- border-top-right-radius: 5px;
- -moz-border-radius-topleft: 5px;
- -moz-border-radius-topright: 5px;
-}
-
-#frame , #header {
- border-top-left-radius: 10px;
- border-top-right-radius: 10px;
- -moz-border-radius-topleft: 10px;
- -moz-border-radius-topright: 10px;
+#header, #navigationbar {
+ background-color: #C3FFB2;
}
#frame {
- border-bottom-left-radius: 10px;
- border-bottom-right-radius: 10px;
- -moz-border-radius-bottomleft: 10px;
- -moz-border-radius-bottomright: 10px;
+ border: 4px solid #176800;
}
-#frame , #navigationbar .curtab {
- background-color: white;
+@media (max-width: 35em) {
+ #frame {
+ border: none;
+ width: 100%;
+ margin: 0px;
+ }
+ body {
+ padding: 0px;
+ background-color: black;
+ }
}
-#navigationbar {
-
- background-color: #232323; /* for non-css3 browsers */
- filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#000000', endColorstr='#303030'); /* for IE */
- background: -webkit-gradient(linear, left top, left bottom, from(#000), to(#303030)); /* for webkit browsers */
- background: -moz-linear-gradient(top, #000, #303030); /* for firefox 3.6+ */
- text-align: center;
- padding-top: 0.2em;
+#frame , #navigationbar .curtab {
+ background-color: white;
}
-#navigationbar, #navigationbar .curtab, #navigationbar .notab {
- border-top: 1px solid black;
+#navigationbar {
+ margin: 0px;
+ padding: 0px;
+ text-align: left;
}
#navigationbar .notab, #navigationbar .curtab {
- margin-top: 0.2em;
- padding-top: 0.0em;
- padding-bottom: 0.2em;
- margin-bottom: 0.0em;
+ display: inline-block;
+ margin: 0px;
+ margin-left: 4px;
+ margin-right: 4px;
+ padding: 1px;
}
#navigationbar .spacing {
@@ -67,16 +55,12 @@ body {
font-size: 0px;
/* space between tabs in the navigation bar */
width: 10px;
- border: 0px solid red;
+ //border: 0px solid red;
}
-#navigationbar .notab {
- border: 1px solid transparent;
- border-bottom: 1px solid #141414;
-}
#navigationbar .curtab {
- border: 1px solid white;
+ background-color: #176800;
border-bottom: 0px solid transparent;
}
@@ -87,11 +71,11 @@ body {
}
#navigationbar .notab a {
- color: #9fbc00;
+ color: black;
}
#navigationbar .curtab a {
- color: #101010;
+ color: #efefef;
}
@@ -129,10 +113,25 @@ body {
#header h1 {
text-align: center;
+ font-size: 2em;
}
#header {
padding: 0.2em;
+ text-align: center;
+}
+
+#header #squeezeheader {
+ display: inline-block;
+ vertical-align: top;
+}
+
+#header #logoname {
+ margin: auto;
+ display: inline-block;
+}
+#header #icon {
+ height: 3em;
}
@@ -146,17 +145,19 @@ h1 {
}
#subheader {
- text-align: center;
+ text-align: left;
font-size: 0.6em;
+ color: black;
}
-h2 {
+h2, h3 {
width: 100%;
- font-size: 1em;
color: #2e3436;
border-bottom: 1px solid #bcbcbc;
}
+h2 { font-size: 1.3em; }
+h3 { font-size: 1.0em; }
li {
margin-top: 0.4em;
@@ -317,3 +318,40 @@ table thead th {
margin-top: 0em;
margin-bottom: 0em;
}
+
+.tabbarseparator, .subpagebar {
+ background-color: #176800;
+}
+
+.tabbarseparator {
+ min-height: 4px;
+}
+
+.subpagebar {
+ padding: 0em;
+ padding-left: 0.4em;
+ padding-right: 0.4em;
+ padding-top: 3px;
+}
+
+.subpagebar .subpage {
+ padding: 2px;
+ line-height: 1.3em;
+ padding-left: 0.9em;
+ padding-right: 0.9em;
+ margin: 2px;
+}
+
+.subpagebar .subpage a {
+ color: white;
+}
+
+.subpagebar .subpagecur a {
+ color: black;
+ display: inline-block;
+}
+
+.subpagebar .subpagecur {
+ background-color: white;
+}
+
diff --git a/www/migration.txt b/www/migration.txt
new file mode 100644
index 00000000..c5b16aac
--- /dev/null
+++ b/www/migration.txt
@@ -0,0 +1 @@
+include::../MIGRATION[]
diff --git a/www/tutorial.txt b/www/tutorial.txt
new file mode 100644
index 00000000..eaf030f4
--- /dev/null
+++ b/www/tutorial.txt
@@ -0,0 +1 @@
+include::../doc/herbstluftwm-tutorial.txt[]