summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorglasseyes <dglassey@gmail.com>2018-10-25 13:46:44 +0700
committerglasseyes <dglassey@gmail.com>2018-10-25 13:46:44 +0700
commitd1948ed24d149a270dd00788a2c4a017a51cc88c (patch)
treef6a3d206322c269cfbed0902a085675711dc81b2 /Makefile.am
New upstream version 1.0.8
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am64
1 files changed, 64 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..f8380a0
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,64 @@
+# vim:set noet ts=4:
+#
+# ibus-kmfl - The kmfl engine for IBus
+#
+# Copyright (c) 2009 Doug Rintoul <doug_rintoul@sil.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+SUBDIRS = \
+ src \
+ icons \
+ m4 \
+ po \
+ $(NULL)
+
+ACLOCAL_AMFLAGS = -I m4
+
+EXTRA_DIST = \
+ autogen.sh \
+ @PACKAGE_NAME@.spec.in \
+ $(NULL)
+
+noinst_DIST = \
+ $(NULL)
+
+
+DISTCLEANFILES = \
+ po/stamp-it \
+ $(NULL)
+
+rpm: dist @PACKAGE_NAME@.spec
+ rpmbuild -bb \
+ --define "_sourcedir `pwd`" \
+ --define "_builddir `pwd`" \
+ --define "_srcrpmdir `pwd`" \
+ --define "_rpmdir `pwd`" \
+ --define "_specdir `pwd`" \
+ @PACKAGE_NAME@.spec
+
+srpm: dist @PACKAGE_NAME@.spec
+ rpmbuild -bs \
+ --define "_sourcedir `pwd`" \
+ --define "_builddir `pwd`" \
+ --define "_srcrpmdir `pwd`" \
+ --define "_rpmdir `pwd`" \
+ --define "_specdir `pwd`" \
+ @PACKAGE_NAME@.spec
+
+clean-rpm:
+ $(RM) -r "`uname -i`"
+
+clean-local: clean-rpm