summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorglasseyes <dglassey@gmail.com>2018-10-25 13:46:44 +0700
committerglasseyes <dglassey@gmail.com>2018-10-25 13:46:44 +0700
commitd1948ed24d149a270dd00788a2c4a017a51cc88c (patch)
treef6a3d206322c269cfbed0902a085675711dc81b2 /configure.ac
New upstream version 1.0.8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac80
1 files changed, 80 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..2caa048
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,80 @@
+# vim:set et ts=4:
+#
+# ibus-kmfl - The kmfl engine for IBus
+#
+# Copyright (c) 2009 Doug Rintoul <doug_rintoul@sil.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+# if not 1, append datestamp to the version number.
+m4_define([ibus_released], [0])
+m4_define([ibus_major_version], [1])
+m4_define([ibus_minor_version], [2])
+m4_define([ibus_micro_version], [0])
+m4_define(ibus_maybe_datestamp,
+ m4_esyscmd([if test x]ibus_released[ != x1; then date +.%Y%m%d | tr -d '\n\r'; fi]))
+
+m4_define([ibus_version],
+ ibus_major_version.ibus_minor_version.ibus_micro_version[]ibus_maybe_datestamp)
+
+AC_INIT([ibus-kmfl], [1.0.8], [http://code.google.com/p/ibus/issues/entry],[ibus-kmfl])
+AM_INIT_AUTOMAKE([1.10])
+AC_GNU_SOURCE
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+
+# define PACKAGE_VERSION_* variables
+AM_SANITY_CHECK
+AM_MAINTAINER_MODE
+AM_DISABLE_STATIC
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_CXX
+AC_ISC_POSIX
+AC_HEADER_STDC
+AM_PROG_LIBTOOL
+
+# check ibus
+PKG_CHECK_MODULES(IBUS, [
+ ibus-1.0 >= 1.2.0
+])
+
+# check kmfl
+
+# check env
+AC_PATH_PROG(ENV, env)
+AC_SUBST(ENV)
+
+# define GETTEXT_* variables
+GETTEXT_PACKAGE=ibus-kmfl
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define to the read-only architecture-independent data directory.])
+
+AM_GNU_GETTEXT([external])
+AM_GNU_GETTEXT_VERSION(0.16.1)
+
+
+# OUTPUT files
+AC_CONFIG_FILES([ po/Makefile.in
+Makefile
+ibus-kmfl.spec
+src/Makefile
+src/kmfl.xml.in
+icons/Makefile
+m4/Makefile
+])
+
+AC_OUTPUT