summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Kern <pkern@debian.org>2008-01-12 10:21:28 +0100
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2016-06-21 11:57:28 +0200
commitf9134c0be076c5d2ed4084382a73115d7709e5c5 (patch)
tree9c2b7aa5c1a62538d5d17c9622d7efdb6e5dc88f
parent9bcf5d55433e75a7095b1905984af479e6833d74 (diff)
Imported Debian patch 0.28-4
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/01_loff_t_dev_t_conflict.dpatch31
-rwxr-xr-xdebian/rules6
5 files changed, 44 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 915e2ad..dc67ef3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+ifplugd (0.28-4) unstable; urgency=low
+
+ * QA upload.
+ * Fix FTBFS on amd64, thanks to Y Giridhar Appaji Nag. (Closes: #451432)
+
+ -- Philipp Kern <pkern@debian.org> Sat, 12 Jan 2008 10:21:28 +0100
+
ifplugd (0.28-3) unstable; urgency=low
* QA upload.
diff --git a/debian/control b/debian/control
index d4bff2a..a64dfc2 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: ifplugd
Section: net
Priority: optional
Maintainer: Debian QA Group <packages@qa.debian.org>
-Build-Depends: debhelper (>> 4.1.16), libdaemon-dev (>= 0.7), lynx | lynx-ssl, pkg-config, po-debconf
+Build-Depends: debhelper (>> 4.1.16), dpatch, libdaemon-dev (>= 0.7), lynx | lynx-ssl, pkg-config, po-debconf
Standards-Version: 3.6.1
Package: ifplugd
diff --git a/debian/patches/00list b/debian/patches/00list
new file mode 100644
index 0000000..3a0ebac
--- /dev/null
+++ b/debian/patches/00list
@@ -0,0 +1 @@
+01_loff_t_dev_t_conflict
diff --git a/debian/patches/01_loff_t_dev_t_conflict.dpatch b/debian/patches/01_loff_t_dev_t_conflict.dpatch
new file mode 100644
index 0000000..cbae5be
--- /dev/null
+++ b/debian/patches/01_loff_t_dev_t_conflict.dpatch
@@ -0,0 +1,31 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 01_loff_t_dev_t_conflict.dpatch from Jeremie Corbier <jcorbier@ubuntu.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fixes FTBFS: Conflict between sys/types.h linux/types.h loff_t/dev_t
+
+@DPATCH@
+diff -urNad ifplugd-0.28~/src/interface.c ifplugd-0.28/src/interface.c
+--- ifplugd-0.28~/src/interface.c 2005-01-04 16:25:31.000000000 -0800
++++ ifplugd-0.28/src/interface.c 2007-01-12 19:19:14.000000000 -0800
+@@ -23,7 +23,6 @@
+ #endif
+
+ #include <linux/sockios.h>
+-#include <linux/if_ether.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/ioctl.h>
+diff -urNad ifplugd-0.28~/src/interface.h ifplugd-0.28/src/interface.h
+--- ifplugd-0.28~/src/interface.h 2004-05-09 16:20:56.000000000 -0700
++++ ifplugd-0.28/src/interface.h 2007-01-12 19:19:45.000000000 -0800
+@@ -21,6 +21,9 @@
+ * Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+ */
+
++/* From <linux/if_ether.h> */
++#define ETH_ALEN 6
++
+ int interface_auto_up;
+ int interface_do_message;
+
diff --git a/debian/rules b/debian/rules
index f66c68b..fcd9348 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,8 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+include /usr/share/dpatch/dpatch.make
+
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -21,7 +23,7 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
-config.status: configure
+config.status: patch configure
dh_testdir
# Add here commands to configure the package.
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc
@@ -43,7 +45,7 @@ build-stamp: config.status
touch build-stamp
-clean:
+clean: unpatch
dh_testdir
dh_testroot
rm -f build-stamp