summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Pitt <mpitt@debian.org>2016-04-27 00:34:24 +0200
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2016-06-21 11:57:33 +0200
commit8b3c90e3ff12464a9e2263a1aa87dd45aa9a9a6a (patch)
treefc47da06bdb2edbbcc003bde2708dbfa4fab8a43
parent1c2ef76758f93b34889afba04971d1cf3a253b36 (diff)
Imported Debian patch 0.28-19.1
-rw-r--r--debian/changelog9
-rw-r--r--debian/ifplugd.udev.agent14
2 files changed, 14 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 0c84be6..0e05396 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+ifplugd (0.28-19.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * debian/ifplugd.udev.agent: Drop using the obsolete and udev-private
+ /lib/udev/hotplug.functions and directly call logger for the debug
+ messages and echo to stderr for invalid usage. (Closes: #810116)
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 27 Apr 2016 00:34:24 +0200
+
ifplugd (0.28-19) unstable; urgency=low
* Added interface poll delay < 1sec using the new -T option. (Closes:
diff --git a/debian/ifplugd.udev.agent b/debian/ifplugd.udev.agent
index 0d3b9a1..d59f787 100644
--- a/debian/ifplugd.udev.agent
+++ b/debian/ifplugd.udev.agent
@@ -1,19 +1,15 @@
#!/bin/sh
# udev agent script
-HOTPLUGFUNCS=/lib/udev/hotplug.functions
-[ -f $HOTPLUGFUNCS ] || exit 1
-. $HOTPLUGFUNCS
-
if [ -z "$INTERFACE" ]; then
- mesg Bad invocation: \$INTERFACE is not set
+ echo 'Bad invocation: $INTERFACE is not set' >&2
exit 1
fi
DAEMON_NAME=ifplugd
DAEMON=/usr/sbin/$DAEMON_NAME
if [ ! -x $DAEMON ]; then
- mesg No $DAEMON_NAME executable: $DAEMON
+ echo "No $DAEMON_NAME executable: $DAEMON" >&2
exit 1
fi
@@ -21,7 +17,7 @@ CFG=/etc/default/$DAEMON_NAME
if [ -f $CFG ]; then
. $CFG
else
- mesg No $DAEMON_NAME configuration file
+ echo "No $DAEMON_NAME configuration file" >&2
exit 1
fi
@@ -62,7 +58,7 @@ ifplugd_daemon () {
# Interface is in hotplug allowed list
case "$ACTION" in
add|register)
- debug_mesg Invoking $DAEMON_NAME for $INTERFACE
+ logger -t ifplugd -p daemon.debug "Invoking $DAEMON_NAME for $INTERFACE"
# check for interface specific arguments
IF1=$(echo $INTERFACE | sed "s/-/_/")
@@ -77,7 +73,7 @@ ifplugd_daemon () {
exec $DAEMON -i $INTERFACE $A
;;
remove|unregister)
- debug_mesg Stopping $DAEMON_NAME for $INTERFACE
+ logger -t ifplugd -p daemon.debug "Stopping $DAEMON_NAME for $INTERFACE"
# kill a running ifplugd daemon
exec $DAEMON -k -i $INTERFACE