summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWalter Franzini <walter.franzini@gmail.com>2011-08-29 09:25:34 +0200
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2016-06-21 11:57:33 +0200
commit1c2ef76758f93b34889afba04971d1cf3a253b36 (patch)
treeba059606674d9ad9c80b27ef4a0cd5924f79d4f3
parent61d621555721eea96cd7d4a6096418bb8a203968 (diff)
Imported Debian patch 0.28-19
-rw-r--r--debian/changelog9
-rw-r--r--debian/control4
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/07_add_fractional_delays.dpatch101
4 files changed, 112 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 9b1c130..0c84be6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+ifplugd (0.28-19) unstable; urgency=low
+
+ * Added interface poll delay < 1sec using the new -T option. (Closes:
+ 638854) - thanks to George Shuklin
+ * Bump Standards-Version to 3.9.2 (no changes needed).
+ * Removed references to Vcs-{Svn,Browser} since not used.
+
+ -- Walter Franzini <walter.franzini@gmail.com> Mon, 29 Aug 2011 09:25:34 +0200
+
ifplugd (0.28-18) unstable; urgency=low
* Updates Danish debconf translation. (Closes: 596153)
diff --git a/debian/control b/debian/control
index 4756b15..b449d72 100644
--- a/debian/control
+++ b/debian/control
@@ -3,10 +3,8 @@ Section: net
Priority: optional
Maintainer: Walter Franzini <walter.franzini@gmail.com>
Build-Depends: debhelper (>= 5), dpatch, autotools-dev, libdaemon-dev (>= 0.7), pkg-config, po-debconf
-Standards-Version: 3.9.1
+Standards-Version: 3.9.2
Homepage: http://0pointer.de/lennart/projects/ifplugd/
-Vcs-Svn: svn://svn.debian.org/svn/collab-maint/ext-maint/ifplugd/unstable
-Vcs-Browser: http://svn.debian.org/wsvn/collab-maint/ext-maint/ifplugd/unstable/?op=log
Package: ifplugd
Architecture: any
diff --git a/debian/patches/00list b/debian/patches/00list
index fc7fea4..ca8a301 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -4,3 +4,4 @@
04_up_down_beep_options
05_396895_HOTPLUG_conf_man
06_509015_better_delays
+07_add_fractional_delays.dpatch
diff --git a/debian/patches/07_add_fractional_delays.dpatch b/debian/patches/07_add_fractional_delays.dpatch
new file mode 100644
index 0000000..deeed44
--- /dev/null
+++ b/debian/patches/07_add_fractional_delays.dpatch
@@ -0,0 +1,101 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 07_add_fractional_delays.dpatch by <root@cvt-xs6>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' ifplugd-0.28~/man/ifplugd.8 ifplugd-0.28/man/ifplugd.8
+--- ifplugd-0.28~/man/ifplugd.8 2011-08-22 17:20:53.000000000 +0400
++++ ifplugd-0.28/man/ifplugd.8 2011-08-22 17:22:09.000000000 +0400
+@@ -48,6 +48,9 @@
+ \fB\-t | \-\-poll-time=\f1 \fISECS\f1
+ Specify poll time in seconds (default: 1)
+ .TP
++\fB\-T | \-\-poll-utime=\f1 \fIUSECS\f1
++Specify poll time in microseconds, added to -t (default: 0)
++.TP
+ \fB\-u | \-\-delay-up=\f1 \fISECS\f1
+ Specify delay for configuring interface (default: 0)
+ .TP
+diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' ifplugd-0.28~/man/ifplugd.8.xml.in ifplugd-0.28/man/ifplugd.8.xml.in
+--- ifplugd-0.28~/man/ifplugd.8.xml.in 2011-08-22 17:20:53.000000000 +0400
++++ ifplugd-0.28/man/ifplugd.8.xml.in 2011-08-22 17:20:53.000000000 +0400
+@@ -132,6 +132,13 @@
+ Specify poll time in seconds (default: 1)
+ </p></optdesc>
+ </option>
++
++ <option>
++ <p><opt>-T | --poll-utime=</opt> <arg>USECS</arg></p>
++ <optdesc><p>
++ Specify poll time in useconds, summing with -t (default: 1)
++ </p></optdesc>
++ </option>
+
+ <option>
+ <p><opt>-u | --delay-up=</opt> <arg>SECS</arg></p>
+diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' ifplugd-0.28~/src/ifplugd.c ifplugd-0.28/src/ifplugd.c
+--- ifplugd-0.28~/src/ifplugd.c 2011-08-22 17:20:53.000000000 +0400
++++ ifplugd-0.28/src/ifplugd.c 2011-08-22 17:20:53.000000000 +0400
+@@ -68,6 +68,7 @@
+ char *extra_arg = NULL;
+
+ int polltime = 1,
++ pollutime = 0,
+ delay_up = 0,
+ delay_down = 5;
+
+@@ -483,7 +484,7 @@
+ struct timeval tv;
+
+ tv.tv_sec = polltime;
+- tv.tv_usec = 0;
++ tv.tv_usec = pollutime;
+
+ if (t) {
+ int delay = t - time(NULL);
+@@ -664,6 +665,7 @@
+ " -r --run=EXEC Specify program to execute (%s)\n"
+ " -I --ignore-retval Don't exit on nonzero return value of program executed (%s)\n"
+ " -t --poll-time=SECS Specify poll time in seconds (%i)\n"
++ " -T --poll-utime=USECS Specify poll time in microseconds, add to -t (%i)\n"
+ " -u --delay-up=SECS Specify delay for configuring interface (%i)\n"
+ " -d --delay-down=SECS Specify delay for deconfiguring interface (%i)\n"
+ " -m --api-mode=MODE Force API mode (mii, priv, ethtool, wlan, auto) (%s)\n"
+@@ -694,6 +696,7 @@
+ run,
+ ignore_retval ? "on" : "off",
+ polltime,
++ pollutime,
+ delay_up,
+ delay_down,
+ m,
+@@ -719,6 +722,7 @@
+ {"iface", required_argument, 0, 'i'},
+ {"run", required_argument, 0, 'r'},
+ {"poll-time", required_argument, 0, 't'},
++ {"poll-utime", required_argument, 0, 'T'},
+ {"delay-up", required_argument, 0, 'u'},
+ {"delay-down", required_argument, 0, 'd'},
+ {"api-mode", required_argument, 0, 'm'},
+@@ -744,7 +748,7 @@
+ for (;;) {
+ int c;
+
+- if ((c = getopt_long(argc, argv, "asni:r:t:u:d:hkbUDfFvm:pqwx:cISRzlMW", long_options, &option_index)) < 0)
++ if ((c = getopt_long(argc, argv, "asni:r:t:T:u:d:hkbUDfFvm:pqwx:cISRzlMW", long_options, &option_index)) < 0)
+ break;
+
+ switch (c) {
+@@ -772,6 +776,10 @@
+ polltime = atoi(optarg);
+ if (polltime < 0) polltime = 0;
+ break;
++ case 'T':
++ pollutime = atoi(optarg);
++ if (pollutime < 0) pollutime = 0;
++ break;
+ case 'u':
+ delay_up = atoi(optarg);
+ break;