summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Shadura <andrew.shadura@collabora.co.uk>2016-06-21 11:57:24 +0200
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2016-06-21 11:57:24 +0200
commit0af3fe8aecc7ee52a6ee0eb926aab985513c4204 (patch)
tree1297533f6cec6790a4c11fab567c69a2dfc56369 /Makefile.am
Imported Upstream version 0.26
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..600e429
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,40 @@
+# $Id: Makefile.am 116 2004-12-19 00:24:29Z lennart $
+
+# This file is part of ifplugd.
+#
+# ifplugd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# ifplugd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with ifplugd; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+EXTRA_DIST=bootstrap.sh README LICENSE ifplugd.spec ifplugd.spec.in
+SUBDIRS=src man conf doc patches
+
+MAINTAINERCLEANFILES = README ifplugd.spec
+noinst_DATA = README ifplugd.spec
+
+README:
+ rm -f README
+ $(MAKE) -C doc README
+ cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/ifplugd
+ cp ifplugd-@PACKAGE_VERSION@.tar.gz $$HOME/homepage/private/projects/ifplugd
+ cp man/ifplugd.8.xml man/ifplugstatus.8.xml man/ifplugd.conf.5.xml man/xmltoman.css man/xmltoman.xsl man/xmltoman.dtd doc/README.html doc/style.css doc/NEWS $$HOME/homepage/private/projects/ifplugd
+ cp $$HOME/homepage/private/projects/ifplugd/README.html $$HOME/homepage/private/projects/ifplugd/index.html
+
+distcleancheck:
+ @:
+
+.PHONY: homepage distcleancheck