summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..43f4ec5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_clean:
+ rm -rf src/img2pdf.egg-info
+ rm -f img2pdf.1
+ dh_auto_clean
+
+override_dh_auto_build:
+ dh_auto_build
+ help2man --no-info --name="lossless conversion of raster images to pdf" ./src/img2pdf.py -o img2pdf.1