summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Marciniszyn <mike.marciniszyn@intel.com>2014-10-10 16:56:58 -0400
committerMike Marciniszyn <mike.marciniszyn@intel.com>2014-10-10 16:56:58 -0400
commit6f42cdb1bb8cc4f15149589ab5fa39775fa5470a (patch)
tree0bc290c45e8b82c0ef7f9ad15473675a5e970dca
parent6da4debe258811f3eafd1aa770777c3e421d9774 (diff)
correct issues with new MIC stuff
The rpm name and tarball name need to keep the prior name. Signed-off-by: Mike Marciniszyn <mike.marciniszyn@intel.com>
-rw-r--r--Makefile22
-rw-r--r--infinipath-psm.spec.in171
2 files changed, 167 insertions, 26 deletions
diff --git a/Makefile b/Makefile
index af05012..d79c4bd 100644
--- a/Makefile
+++ b/Makefile
@@ -50,8 +50,6 @@ TARG_DIR ?= $(top_srcdir)
TMI_DIR := $(top_srcdir)/contrib/$(TMI_NAME)
TMI_NAME := tmi-2009-11-20
-RPM_NAME := $(if $(PSM_HAVE_SCIF:0=),$(if $(MIC:0=),intel-mic-psm-card,intel-mic-psm),infinipath-psm)
-TARBALL_NAME := $(if $(PSM_HAVE_SCIF:0=),$(if $(MIC:0=),mic-psm-card,mic-psm),ipath-psm)
TARGLIB := libpsm_infinipath
SUBDIRS:= ptl_self ptl_ips ptl_am libuuid ipath
@@ -209,8 +207,8 @@ tmiclean:
$(MAKE) -C contrib/$(TMI_NAME) verbs=PSM clean
-.PHONY: intel-mic-psm.spec
-intel-mic-psm.spec: intel-mic-psm.spec.in
+.PHONY: infinipath-psm.spec
+infinipath-psm.spec: infinipath-psm.spec.in
sed -e 's/@VERSION@/'${VERSION}'/g' -e 's/@RELEASE@/'${RELEASE}'/g' $< > $@
if [ X$(MIC) != X1 ]; then \
if [ X$(PSM_USE_SYS_UUID) = X1 ]; then \
@@ -228,13 +226,13 @@ intel-mic-psm.spec: intel-mic-psm.spec.in
-e '/@REQUIRES-DEVEL@/d' \
-e 's/@PSM_UUID@/USE_PSM_UUID=1/g' $@ ; \
fi
-dist: distclean intel-mic-psm.spec
+dist: distclean infinipath-psm.spec
rm -rf $(RPM_BUILD_DIR)
- mkdir -p intel-mic-psm-${VERSION_RELEASE}
+ mkdir -p infinipath-psm-${VERSION_RELEASE}
for x in $$(/usr/bin/find . -name ".git" -prune -o \
-name "cscope*" -prune -o \
-name "*.spec.in" -prune -o \
- -name "intel-mic-psm-${VERSION_RELEASE}" -prune -o \
+ -name "infinipath-psm-${VERSION_RELEASE}" -prune -o \
-name "*.orig" -prune -o \
-name "*~" -prune -o \
-name "#*" -prune -o \
@@ -243,13 +241,13 @@ dist: distclean intel-mic-psm.spec
-name ".gitignore" -prune -o \
-print); do \
dir=$$(dirname $$x); \
- mkdir -p intel-mic-psm-${VERSION_RELEASE}/$$dir; \
- [ ! -d $$x ] && cp $$x intel-mic-psm-${VERSION_RELEASE}/$$dir; \
+ mkdir -p infinipath-psm-${VERSION_RELEASE}/$$dir; \
+ [ ! -d $$x ] && cp $$x infinipath-psm-${VERSION_RELEASE}/$$dir; \
done ; \
if [ -d .git ] ; then git log -n1 --pretty=format:%H > \
- intel-mic-psm-${VERSION_RELEASE}/COMMIT ; fi
- tar czvf intel-mic-psm-${VERSION_RELEASE}.tar.gz intel-mic-psm-${VERSION_RELEASE}
- rm -rf intel-mic-psm-${VERSION_RELEASE}
+ infinipath-psm-${VERSION_RELEASE}/COMMIT ; fi
+ tar czvf infinipath-psm-${VERSION_RELEASE}.tar.gz infinipath-psm-${VERSION_RELEASE}
+ rm -rf infinipath-psm-${VERSION_RELEASE}
ofeddist:
USE_PSM_UUID=1 $(MAKE) dist
diff --git a/infinipath-psm.spec.in b/infinipath-psm.spec.in
index 7e3be4a..a366dce 100644
--- a/infinipath-psm.spec.in
+++ b/infinipath-psm.spec.in
@@ -1,49 +1,171 @@
-Summary: QLogic PSM Libraries
+# Copyright (c) 2012. Intel Corporation. All rights reserved.
+# Copyright (c) 2010. QLogic Corporation. All rights reserved.
+#
+# This software is available to you under a choice of one of two
+# licenses. You may choose to be licensed under the terms of the GNU
+# General Public License (GPL) Version 2, available from the file
+# COPYING in the main directory of this source tree, or the
+# OpenIB.org BSD license below:
+#
+# Redistribution and use in source and binary forms, with or
+# without modification, are permitted provided that the following
+# conditions are met:
+#
+# - Redistributions of source code must retain the above
+# copyright notice, this list of conditions and the following
+# disclaimer.
+#
+# - Redistributions in binary form must reproduce the above
+# copyright notice, this list of conditions and the following
+# disclaimer in the documentation and/or other materials
+# provided with the distribution.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+# BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+# ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+#
+
+Summary: Intel PSM Libraries
Name: infinipath-psm
Version: @VERSION@
Release: @RELEASE@
Epoch: 4
License: GPL
Group: System Environment/Libraries
-URL: http://www.qlogic.com/
+URL: http://www.intel.com/
Source0: %{name}-%{version}-%{release}.tar.gz
Prefix: /usr
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+Provides: infinipath-psm = %{version}
+# MIC package
+Conflicts: intel-mic-psm
+# OFED package
+Obsoletes: infinipath-libs <= %{version}-%{release}
+Conflicts: infinipath-libs <= %{version}-%{release}
+# mpss package
+Obsoletes: mpss-psm <= %{version}-%{release}
+Conflicts: mpss-psm <= %{version}-%{release}
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
@REQUIRES@
-Conflicts: infinipath-libs
-%package devel
-Summary: Development files for QLogic PSM
+%package -n infinipath-psm-devel
+Summary: Development files for Intel PSM
Group: System Environment/Development
-Requires: %{name} = %{epoch}:%{version}-%{release}
+Requires: infinipath-psm = %{version}-%{release}
+Provides: infinipath-psm-devel = %{version}
+# MIC package
+Conflicts: intel-mic-devel
+# OFED package
+Obsoletes: infinipath-devel <= %{version}-%{release}
+Conflicts: infinipath-devel <= %{version}-%{release}
+# mpss package
+Obsoletes: mpss-psm-dev <= %{version}-%{release}
+Conflicts: mpss-psm-dev <= %{version}-%{release}
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
@REQUIRES-DEVEL@
-Conflicts: infinipath-devel
+
+%package -n intel-mic-psm
+Summary: Intel PSM Libraries
+License: GPL
+Group: System Environment/Libraries
+Prefix: /usr
+Provides: intel-mic-psm = %{version}
+# non-MIC package
+Conflicts: infinipath-psm
+# OFED package
+Obsoletes: infinipath-libs <= %{version}-%{release}
+Conflicts: infinipath-libs <= %{version}-%{release}
+# mpss package
+Obsoletes: mpss-psm <= %{version}-%{release}
+Conflicts: mpss-psm <= %{version}-%{release}
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+@REQUIRES@
+
+%package -n intel-mic-psm-devel
+Summary: Development files for Intel PSM
+Group: System Environment/Development
+Requires: intel-mic-psm = %{version}-%{release}
+Provides: intel-mic-psm-devel = %{version}
+# non-MIC package
+Conflicts: infinipath-psm-devel
+# OFED package
+Obsoletes: infinipath-devel <= %{version}-%{release}
+Conflicts: infinipath-devel <= %{version}-%{release}
+# mpss package
+Obsoletes: mpss-psm-dev <= %{version}-%{release}
+Conflicts: mpss-psm-dev <= %{version}-%{release}
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+@REQUIRES-DEVEL@
+
+# %package card-devel
+# Summary: Development files for Intel Xeon Phi
+# Group: System Environment/Development
+# Requires: %{name} = %{version}-%{release}
+# Requires(post): /sbin/ldconfig
+# Requires(postun): /sbin/ldconfig
+
+
+%global debug_package %{nil}
+
+#PSM_HAVE_SCIF is one of: 0 1
+%{!?PSM_HAVE_SCIF: %global PSM_HAVE_SCIF 0}
+
+%define INFINIPATH_MAKEARG PSM_HAVE_SCIF=0 MIC=0
+%define INTEL_MAKEARG PSM_HAVE_SCIF=1 MIC=0
+%define INTEL_CARD_MAKEARG PSM_HAVE_SCIF=1 MIC=1 LOCAL_PREFIX=/opt/intel/mic/psm
+%define card_prefix /opt/intel/mic/psm
+
+%if "%{PSM_HAVE_SCIF}" == "0"
+ %define MAKEARG PSM_HAVE_SCIF=0 MIC=0
+%else
+ %if "%{PSM_HAVE_SCIF}" == "1"
+ %define MAKEARG PSM_HAVE_SCIF=1 MIC=0
+ %else
+ %define MAKEARG PSM_HAVE_SCIF=0 MIC=0
+ %define PSM_HAVE_SCIF "1"
+ %endif
+%endif
%description
-The PSM Messaging API, or PSM API, is QLogic's low-level
-user-level communications interface for the Truescale
+The PSM Messaging API, or PSM API, is Intel's low-level
+user-level communications interface for the True Scale
family of products. PSM users are enabled with mechanisms
necessary to implement higher level communications
interfaces in parallel environments.
-%description devel
+%description -n infinipath-psm-devel
+Development files for the libpsm_infinipath library
+
+%description -n intel-mic-psm
+The PSM Messaging API, or PSM API, is Intel's low-level
+user-level communications interface for the True Scale
+family of products. PSM users are enabled with mechanisms
+necessary to implement higher level communications
+interfaces in parallel environments.
+
+%description -n intel-mic-psm-devel
Development files for the libpsm_infinipath library
%prep
-%setup -q -n infinipath-psm-%{version}-%{release}
+%setup -q -n %{name}-%{version}-%{release}
%build
-%{__make} @PSM_UUID@
+%{__make} @PSM_UUID@ %{MAKEARG}
%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT
export DESTDIR=$RPM_BUILD_ROOT
-%{__make} install
+%{__make} install %{MAKEARG}
%clean
rm -rf $RPM_BUILD_ROOT
@@ -53,20 +175,41 @@ rm -rf $RPM_BUILD_ROOT
%post devel -p /sbin/ldconfig
%postun devel -p /sbin/ldconfig
+%if "%{PSM_HAVE_SCIF}" == "1"
+%files -n intel-mic-psm
+%defattr(-,root,root,-)
+/usr/lib64/libpsm_infinipath.so.*
+/usr/lib64/libinfinipath.so.*
+/usr/sbin/psmd
+
+%files -n intel-mic-psm-devel
+%defattr(-,root,root,-)
+/usr/lib64/libpsm_infinipath.so
+/usr/lib64/libinfinipath.so
+/usr/include/psm.h
+/usr/include/psm_mq.h
+%endif
+
+
+%if "%{PSM_HAVE_SCIF}" == "0"
%files
%defattr(-,root,root,-)
/usr/lib64/libpsm_infinipath.so.*
/usr/lib64/libinfinipath.so.*
-%files devel
+%files -n infinipath-psm-devel
%defattr(-,root,root,-)
/usr/lib64/libpsm_infinipath.so
/usr/lib64/libinfinipath.so
/usr/include/psm.h
/usr/include/psm_mq.h
+%endif
+
%changelog
+* Tue Nov 6 2012 Mitko Haralanov <mitko.haralanov@intel.com> - @VERSION@-1
+- Add Intel Xeon Phi related changes
* Tue May 11 2010 Mitko Haralanov <mitko@qlogic.com> - @VERSION@-1
- Initial build.