summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAna Beatriz Guerrero Lopez <ana@debian.org>2016-04-04 10:19:31 +0200
committerRoland Fehrenbacher <rf@q-leap.de>2017-12-28 20:11:47 +0000
commitc3c4d239e4d4f57eab354dee6265cb59d158ab8d (patch)
treec7723b55ba8c6a62def8cde8bb41dcf0ee0ecf6f
parent40309c38b92df77ce57b5b4784a22f81e29cf042 (diff)
Improve architecture detection. (Closes: #807149)
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules7
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 85d919c..afea7c9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+infinipath-psm (3.3+19.g67c0807.open-2) UNRELEASED; urgency=medium
+
+ * Improve architecture detection. (Closes: #807149)
+
+ -- Ana Beatriz Guerrero Lopez <ana@debian.org> Mon, 04 Apr 2016 10:18:09 +0200
+
infinipath-psm (3.3+19.g67c0807.open-1) unstable; urgency=medium
* Team upload.
diff --git a/debian/rules b/debian/rules
index 471ab6c..11a0cea 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,8 +3,13 @@
include /usr/share/dpkg/buildflags.mk
include /usr/share/dpkg/pkg-info.mk
+ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+ifeq ($(ARCH),amd64)
+ ARCH := x86_64
+endif
+
MAKE_OPTIONS := INSTALL_PREFIX=/usr libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
- PSM_HAVE_SCIF=0 USE_PSM_UUID=0 arch=$(shell arch)
+ PSM_HAVE_SCIF=0 USE_PSM_UUID=0 arch=$(ARCH)
%:
dh $@ --parallel