summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Niebur <ryanryan52@gmail.com>2009-09-05 12:45:28 -0700
committerRyan Niebur <ryanryan52@gmail.com>2009-09-05 12:45:28 -0700
commit2ad5ab800551066d87fdcc086fe880c9b6843bbc (patch)
treef4de6705dd65f08592047e3667358cfdfec364c8
parent00fef8e0f6a5174634fb570b173c4aaa5b7e3d62 (diff)
patches from upstream SVN
-rw-r--r--debian/changelog13
-rw-r--r--debian/patches/59.patch (renamed from debian/patches/manpage-move_self.patch)23
-rw-r--r--debian/patches/60.patch (renamed from debian/patches/clarify-timeout-option)7
-rw-r--r--debian/patches/61.patch (renamed from debian/patches/inotifywatch-SIGUSR1.patch)15
-rw-r--r--debian/patches/62.patch (renamed from debian/patches/fix-recursive-events.patch)16
-rw-r--r--debian/patches/series5
6 files changed, 48 insertions, 31 deletions
diff --git a/debian/changelog b/debian/changelog
index ca3afa1..5023c0e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+inotify-tools (3.13-2) UNRELEASED; urgency=low
+
+ * remove clarify-timeout-option patch, use the patch from upstream SVN
+ (60.patch)
+ * add patch, 59.patch, from upstream svn to clarify move_self in the
+ manpage (Closes: #533536)
+ * add patch, 61.patch, from upstream SVN to make inotifywatch react to
+ SIGUSR1 (Closes: #509842)
+ * add patch, 62.patch, from upstream SVN to fix recursive monitoring
+ when you limit the events (closes: #447672) (LP: 254751)
+
+ -- Ryan Niebur <ryanryan52@gmail.com> Sat, 05 Sep 2009 12:44:19 -0700
+
inotify-tools (3.13-1) unstable; urgency=low
* New Upstream Version (Closes: #494782)
diff --git a/debian/patches/manpage-move_self.patch b/debian/patches/59.patch
index 0eb7798..7f9187f 100644
--- a/debian/patches/manpage-move_self.patch
+++ b/debian/patches/59.patch
@@ -1,32 +1,31 @@
-patch from upstream SVN r59, author is Radu.
-http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=533536
+------------------------------------------------------------------------
+r59 | raduv | 2009-08-25 03:55:12 -0700 (Tue, 25 Aug 2009) | 1 line
-Index: man/inotifywait.1
-===================================================================
---- man/inotifywait.1 (revision 58)
-+++ man/inotifywait.1 (working copy)
+Documented MOVE_SELF in man pages.
+------------------------------------------------------------------------
+
+--- a/man/inotifywait.1
++++ b/man/inotifywait.1
@@ -248,6 +248,11 @@
.B MOVE.
.TP
+.B move_self
-+A watched file or directory was moved. After this event, the file or directory
++A watched file or directory was moved. After this event, the file or directory
+is no longer being watched.
+
+.TP
.B create
A file or directory was created within a watched directory.
-Index: man/inotifywatch.1
-===================================================================
---- man/inotifywatch.1 (revision 58)
-+++ man/inotifywatch.1 (working copy)
+--- a/man/inotifywatch.1
++++ b/man/inotifywatch.1
@@ -201,6 +201,11 @@
.B MOVE.
.TP
+.B move_self
-+A watched file or directory was moved. After this event, the file or directory
++A watched file or directory was moved. After this event, the file or directory
+is no longer being watched.
+
+.TP
diff --git a/debian/patches/clarify-timeout-option b/debian/patches/60.patch
index e9dddff..04a8e0f 100644
--- a/debian/patches/clarify-timeout-option
+++ b/debian/patches/60.patch
@@ -1,7 +1,8 @@
-Make it more understandable how it works.
-See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464829
+------------------------------------------------------------------------
+r60 | raduv | 2009-09-05 02:41:44 -0700 (Sat, 05 Sep 2009) | 1 line
-forwaded to Radu (new upstream maintainer) on Sep/04/2009.
+Man page clarification for --timeout option. (Thanks Ryan)
+------------------------------------------------------------------------
--- a/man/inotifywait.1
+++ b/man/inotifywait.1
diff --git a/debian/patches/inotifywatch-SIGUSR1.patch b/debian/patches/61.patch
index c2caa68..827118d 100644
--- a/debian/patches/inotifywatch-SIGUSR1.patch
+++ b/debian/patches/61.patch
@@ -1,11 +1,12 @@
-http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=509842
-forwarded upstream, not applied in package until upstream acks it
+------------------------------------------------------------------------
+r61 | raduv | 2009-09-05 02:41:55 -0700 (Sat, 05 Sep 2009) | 1 line
+
+Make inotifywatch react to SIGUSR1 - print partial results as per Debian bug #509842 (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=509842) - thanks, Ryan
+------------------------------------------------------------------------
-diff --git a/src/inotifywatch.c b/src/inotifywatch.c
-index fe0d738..cb412d6 100644
--- a/src/inotifywatch.c
+++ b/src/inotifywatch.c
-@@ -75,15 +75,26 @@ void handle_signal( int signal __attribute__((unused)) ) {
+@@ -75,15 +75,26 @@
done = true;
}
@@ -35,7 +36,7 @@ index fe0d738..cb412d6 100644
done = false;
char * regex = NULL;
char * iregex = NULL;
-@@ -183,6 +194,7 @@ int main(int argc, char ** argv)
+@@ -183,6 +194,7 @@
signal( SIGALRM, handle_signal );
alarm( timeout );
}
@@ -43,7 +44,7 @@ index fe0d738..cb412d6 100644
inotifytools_initialize_stats();
// Now wait till we get event
-@@ -256,8 +268,12 @@ int main(int argc, char ** argv)
+@@ -256,8 +268,12 @@
}
} while ( !done );
diff --git a/debian/patches/fix-recursive-events.patch b/debian/patches/62.patch
index 5b94771..79dae33 100644
--- a/debian/patches/fix-recursive-events.patch
+++ b/debian/patches/62.patch
@@ -1,12 +1,12 @@
-http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=447672
-https://bugs.launchpad.net/ubuntu/+source/inotify-tools/+bug/254751
-sent upstream, waiting for a reply.
+------------------------------------------------------------------------
+r62 | raduv | 2009-09-05 02:42:07 -0700 (Sat, 05 Sep 2009) | 1 line
+
+Monitor in background events like create, move_to, move_from when inotifywait is run with --monitor and --recursive. (Thanks Ryan)
+------------------------------------------------------------------------
-diff --git a/src/inotifywait.c b/src/inotifywait.c
-index 9c031bc..e6fec43 100644
--- a/src/inotifywait.c
+++ b/src/inotifywait.c
-@@ -129,6 +129,7 @@ void output_event_csv( struct inotify_event * event ) {
+@@ -129,6 +129,7 @@
int main(int argc, char ** argv)
{
int events = 0;
@@ -14,7 +14,7 @@ index 9c031bc..e6fec43 100644
bool monitor = false;
int quiet = 0;
unsigned long int timeout = 0;
-@@ -175,6 +176,10 @@ int main(int argc, char ** argv)
+@@ -175,6 +176,10 @@
// If events is still 0, make it all events.
if (events == 0)
events = IN_ALL_EVENTS;
@@ -25,7 +25,7 @@ index 9c031bc..e6fec43 100644
FileList list = construct_path_list( argc, argv, fromfile );
-@@ -235,7 +240,7 @@ int main(int argc, char ** argv)
+@@ -235,7 +240,7 @@
}
}
diff --git a/debian/patches/series b/debian/patches/series
index 97a660f..44f98f4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,5 @@
-clarify-timeout-option
fix-hyphens-in-manpages
+59.patch
+60.patch
+61.patch
+62.patch