summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Niebur <ryanryan52@gmail.com>2009-04-05 00:54:05 -0700
committerRyan Niebur <ryanryan52@gmail.com>2009-04-05 00:54:05 -0700
commitdd350f26110a618e725e6adf9d02254ca3671722 (patch)
treebf78941a7f46d35d784480aaa790feefbbbb46c0
parent6e5a39181bea2319df2e4b04bfa7dbc56ce9eb32 (diff)
Imported Upstream version 3.13
-rw-r--r--ChangeLog16
-rwxr-xr-xconfigure20
-rw-r--r--configure.ac2
-rw-r--r--libinotifytools/src/Makefile.am2
-rw-r--r--libinotifytools/src/Makefile.in2
-rw-r--r--libinotifytools/src/inotifytools.c4
-rw-r--r--man/inotifywait.12
-rw-r--r--man/inotifywatch.12
-rw-r--r--src/inotifywait.c21
9 files changed, 42 insertions, 29 deletions
diff --git a/ChangeLog b/ChangeLog
index e3a45fb..c2ed706 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,19 @@
+2008-01-01 08:50 Rohan McGovern
+
+ * configure.ac, libinotifytools/src/Makefile.am:
+ VERSION 3.13
+
+2008-01-01 08:39 Rohan McGovern
+
+ * src/inotifywait.c:
+ Fixes: --timefmt option is ignored
+
+2007-11-24 23:02 Rohan McGovern
+
+ * libinotifytools/src/inotifytools.c:
+ Fixes inaccurate documentation (remove out-of-date todolist
+ entry).
+
2007-11-24 00:54 Rohan McGovern
* configure.ac, libinotifytools/src/Makefile.am:
diff --git a/configure b/configure
index c6d4502..70e1295 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.61 for inotify-tools 3.12.
+# Generated by GNU Autoconf 2.61 for inotify-tools 3.13.
#
# Report bugs to <rohan@mcgovern.id.au>.
#
@@ -728,8 +728,8 @@ SHELL=${CONFIG_SHELL-/bin/sh}
# Identity of this package.
PACKAGE_NAME='inotify-tools'
PACKAGE_TARNAME='inotify-tools'
-PACKAGE_VERSION='3.12'
-PACKAGE_STRING='inotify-tools 3.12'
+PACKAGE_VERSION='3.13'
+PACKAGE_STRING='inotify-tools 3.13'
PACKAGE_BUGREPORT='rohan@mcgovern.id.au'
ac_unique_file="src/inotifywait.c"
@@ -1393,7 +1393,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures inotify-tools 3.12 to adapt to many kinds of systems.
+\`configure' configures inotify-tools 3.13 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1463,7 +1463,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of inotify-tools 3.12:";;
+ short | recursive ) echo "Configuration of inotify-tools 3.13:";;
esac
cat <<\_ACEOF
@@ -1566,7 +1566,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-inotify-tools configure 3.12
+inotify-tools configure 3.13
generated by GNU Autoconf 2.61
Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
@@ -1580,7 +1580,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by inotify-tools $as_me 3.12, which was
+It was created by inotify-tools $as_me 3.13, which was
generated by GNU Autoconf 2.61. Invocation command line was
$ $0 $@
@@ -2250,7 +2250,7 @@ fi
# Define the identity of the package.
PACKAGE='inotify-tools'
- VERSION='3.12'
+ VERSION='3.13'
cat >>confdefs.h <<_ACEOF
@@ -20350,7 +20350,7 @@ exec 6>&1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by inotify-tools $as_me 3.12, which was
+This file was extended by inotify-tools $as_me 3.13, which was
generated by GNU Autoconf 2.61. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -20403,7 +20403,7 @@ Report bugs to <bug-autoconf@gnu.org>."
_ACEOF
cat >>$CONFIG_STATUS <<_ACEOF
ac_cs_version="\\
-inotify-tools config.status 3.12
+inotify-tools config.status 3.13
configured by $0, generated by GNU Autoconf 2.61,
with options \\"`echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`\\"
diff --git a/configure.ac b/configure.ac
index 89f48aa..47b4df1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([inotify-tools], [3.12], [rohan@mcgovern.id.au])
+AC_INIT([inotify-tools], [3.13], [rohan@mcgovern.id.au])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([src/inotifywait.c])
AM_CONFIG_HEADER([config.h])
diff --git a/libinotifytools/src/Makefile.am b/libinotifytools/src/Makefile.am
index c766158..a8873e1 100644
--- a/libinotifytools/src/Makefile.am
+++ b/libinotifytools/src/Makefile.am
@@ -2,7 +2,7 @@ SUBDIRS = inotifytools
lib_LTLIBRARIES = libinotifytools.la
libinotifytools_la_SOURCES = inotifytools.c inotifytools_p.h redblack.c redblack.h
-libinotifytools_la_LDFLAGS = -version-info 4:0:4
+libinotifytools_la_LDFLAGS = -version-info 4:1:4
check_PROGRAMS = test
test_SOURCES = test.c
diff --git a/libinotifytools/src/Makefile.in b/libinotifytools/src/Makefile.in
index f4c8a9c..e523fb1 100644
--- a/libinotifytools/src/Makefile.in
+++ b/libinotifytools/src/Makefile.in
@@ -202,7 +202,7 @@ target_alias = @target_alias@
SUBDIRS = inotifytools
lib_LTLIBRARIES = libinotifytools.la
libinotifytools_la_SOURCES = inotifytools.c inotifytools_p.h redblack.c redblack.h
-libinotifytools_la_LDFLAGS = -version-info 4:0:4
+libinotifytools_la_LDFLAGS = -version-info 4:1:4
test_SOURCES = test.c
test_LDADD = libinotifytools.la
TESTS = test
diff --git a/libinotifytools/src/inotifytools.c b/libinotifytools/src/inotifytools.c
index 09fbcf9..6b0fb96 100644
--- a/libinotifytools/src/inotifytools.c
+++ b/libinotifytools/src/inotifytools.c
@@ -117,10 +117,6 @@
* gamin's approach sounds good: let the user watch an inode using several
* different filenames, and when an event occurs on the inode, generate an
* event for each filename.
- *
- * @todo Improve wd/filename storage. At the moment a doubly-linked list is used,
- * so lookups take linear time. This could be a problem if watching
- * hundreds of thousands of files.
*/
#define MAX_EVENTS 4096
diff --git a/man/inotifywait.1 b/man/inotifywait.1
index 351a34f..71c10a7 100644
--- a/man/inotifywait.1
+++ b/man/inotifywait.1
@@ -1,4 +1,4 @@
-.TH inotifywait 1 "November 24, 2007" "inotifywait 3.12"
+.TH inotifywait 1 "January 01, 2008" "inotifywait 3.13"
.SH NAME
inotifywait \- wait for changes to files using inotify
diff --git a/man/inotifywatch.1 b/man/inotifywatch.1
index 1f7f4e3..72483df 100644
--- a/man/inotifywatch.1
+++ b/man/inotifywatch.1
@@ -1,4 +1,4 @@
-.TH inotifywatch 1 "November 24, 2007" "inotifywatch 3.12"
+.TH inotifywatch 1 "January 01, 2008" "inotifywatch 3.13"
.SH NAME
inotifywatch \- gather filesystem access statistics using inotify
diff --git a/src/inotifywait.c b/src/inotifywait.c
index 3ebaa94..9c031bc 100644
--- a/src/inotifywait.c
+++ b/src/inotifywait.c
@@ -147,16 +147,6 @@ int main(int argc, char ** argv)
return EXIT_ERROR;
}
- if ( timefmt ) inotifytools_set_printf_timefmt( timefmt );
- if (
- (regex && !inotifytools_ignore_events_by_regex(regex, REG_EXTENDED) ) ||
- (iregex && !inotifytools_ignore_events_by_regex(iregex, REG_EXTENDED|
- REG_ICASE))
- ) {
- fprintf(stderr, "Error in `exclude' regular expression.\n");
- return EXIT_ERROR;
- }
-
if ( !inotifytools_initialize() ) {
fprintf(stderr, "Couldn't initialize inotify. Are you running Linux "
"2.6.13 or later, and was the\n"
@@ -168,6 +158,17 @@ int main(int argc, char ** argv)
return EXIT_ERROR;
}
+ if ( timefmt ) inotifytools_set_printf_timefmt( timefmt );
+ if (
+ (regex && !inotifytools_ignore_events_by_regex(regex, REG_EXTENDED) ) ||
+ (iregex && !inotifytools_ignore_events_by_regex(iregex, REG_EXTENDED|
+ REG_ICASE))
+ ) {
+ fprintf(stderr, "Error in `exclude' regular expression.\n");
+ return EXIT_ERROR;
+ }
+
+
if ( format ) validate_format(format);
// Attempt to watch file