summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 47b4df1..5d9b3fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,18 +1,19 @@
-# -*- Autoconf -*-
+# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([inotify-tools], [3.13], [rohan@mcgovern.id.au])
+AC_INIT([inotify-tools], [3.14], [radu.voicilas@gmail.com])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([src/inotifywait.c])
-AM_CONFIG_HEADER([config.h])
-AM_CONFIG_HEADER([libinotifytools/src/inotifytools/inotify.h])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_HEADERS([libinotifytools/src/inotifytools/inotify.h])
+AC_CONFIG_MACRO_DIR([m4])
AC_DEFINE([_GNU_SOURCE], [], [For a few GNU-specific functions])
AC_PROG_MAKE_SET
# Checks for programs.
AC_PROG_CC
-AC_PROG_LIBTOOL
+LT_INIT
AC_PATH_PROG(DOXYGEN, doxygen, NO_DOXYGEN)
@@ -45,7 +46,7 @@ AM_CONDITIONAL([DOXYGEN_ENABLE], test x$DOXYGEN != xNO_DOXYGEN )
AC_CHECK_HEADERS([sys/inotify.h mcheck.h])
AC_LANG(C)
AC_MSG_CHECKING([whether sys/inotify.h actually works])
-AC_RUN_IFELSE(
+AC_COMPILE_IFELSE(
AC_LANG_PROGRAM([[#include <sys/inotify.h>]],
[[return (-1 == inotify_init());]]
),